• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[DEV][ROM][2.7.] CyanogenMod 11 (Android 4.4.4)

1290 posts in this topic

Posted · Report post

Welcome back mate!!!

0

Share this post


Link to post
Share on other sites

Posted · Report post

Not yet implemented. There's all kinds of settings missing, it's still early days of CM11. Iirc disabling all animations will kill screen off animation as well.

I'll add this to the FAQ in the third post. It's been disabled on low memory devices among few other things.

https://github.com/KonstaT/android_device_zte_atlas40/commit/b5630f929bda64452c8c787dcb4030fc0cb0abf5

You can enable it by removing/commenting/changing to false single line in /system/build.prop.

ro.config.low_ram=true
There's nothing stopping you contributing better translations. All translation work is done by the community.

http://wiki.cyanogenmod.org/w/Doc:_Translation_Guide

There's plenty of third party launchers available.

https://play.google.com/store/search?q=launcher&c=apps

Thanks :) and to others who objected to my question... I was only asking, not complaining, asking out of curiosity. I gathered it was something to do with that. Just wanted to find out.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Thank you sooo much, Konstat. Merry Christmas!

0

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks KonstaT  :)  :D 

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Hello again.I try new rom 2 days,really great performance and appearance,but i have again sensors problem,when i put proxical.zip it seems work good now.The biggest oder problem is after few ours workig i start to receive massage android.process.media stoped ->losing ringtones,but SD is online.IDK were is problem.After fresh preinstall(delete all types cahes/partition factory reset) phone work nice but for few our.So i must back to 4.3.1 :((((

P.S. When i pres 2-3 times power button i get restart of phone is that part of new rom???

Edited by Wildemo
0

Share this post


Link to post
Share on other sites

Posted · Report post

Workin great! But no notification ringer sounds?

Never mind after couple of reboots everything works correctly.

Great work, more responsive than 4.3.

Yes, same here. When I checked, both incoming call ringtone and notification tone were set to None. Further, the ringtones list only had 3 items in it, while the notification tone list's lone item is 'None' (so, no chanse to hear it).

Reboots did not help.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Well, after using it for a couple of days, this is turning out to be the best ROM so far even though it's an initial release... KonstaT, i have no words other than SUPERB job! Everything worked perfectly so far, apart from a couple of apps that hadn't worked since JB 4.2.2, but i guess it's up to the app developers to get their sh** together and update their apps! 

 

I would also like to add that i tried enabling the transparency and found that it slows down the responsiveness quite a bit, so my advice is to leave it on "low RAM" mode and enjoy a great experience! A little advice for people who are having problems after flashing, from my experience, i had some bugs when i flashed with my SD card from the previous ROM, so i decided to format the card under Windows and ONLY put the ROM and GAPPS package on it and do the wiping and flashing straight after inserting the freshly formatted SD card... This way, maybe, there weren't any leftover files that interfered with the new ROM... I know this is a bit extreme and maybe a pain in the a** to restore the data afterwards but i didn't mind a little hassle as long as it resulted in a bug free fresh ROM... This is just something i've noticed while playing around with various ROMs in the past months...

 

 

Glad to have you back KonstaT, and i honeslty hope you keep up the good work you've done so far! Cheers my friend!

0

Share this post


Link to post
Share on other sites

Posted · Report post

now, before i ask my question, i wanna say that this rom will stay the best custom rom for our device even if that is unable to be done. so, is there any way to make ms google now verbally respond to some of my questions i.e. is it cold outside (previous roms have had this feature)

It already does that. I asked her to 'make me a sandwich' and she didn't respond very politely. ;)
 
You have install Google Search from the Play Store, right? None of the Google apps that can be installed from the Play Store are included in the OP's gapps package.
1

Share this post


Link to post
Share on other sites

Posted · Report post

 

We are dealing with EOL'd (= end of life) hardware here. Qualcomm dropped support for msm7x27a on Android 4.1. ZTE dropped support for this device on Android 4.0. That means that you're not supposed to run anything beyond 4.0 on this device!
 
We don't have 3.4 kernel (on which all three Jelly Beans and KitKat is based on). We can't utilize ION memory allocator (camera wouldn't work because we don't have proprietaries[*] for it). We're stuck using legacy display HALs (basically from Android 4.1) because it would take insane amount of work to update the 3.0.8 kernel to work with a newer one (also MDP3 has been depracated since 4.1 anyway). We can't use newer display drivers (Adreno blobs[*]) because our display HAL is ancient, we can't utilize ION memory allocator and Qualcomm never even made ones for msm7x27a because it was EOL'd on 4.1. That's only the display side of things (dumbing it down and cutting few corners). Media implementation is another (yet similar) story.
 
What's missing? What comes to kernel, display HAL and display drivers we don't have anything to make things work like they're supposed to in Jelly Bean and beyond.
 
[*] proprietary/blob = prebuilt binary extracted from stock firmware on our (or some other) device - things we don't have source code for

 

There was some previous attemps to shave some RAM from kernel memory allocations but there was reports that it caused instability in some cases.

 

You really should learn to wake before your alarm would go off like any normal person. :P That way you can also make use of a feature that allows you dismiss the alarm before it goes off. Literally the only new feature added in KitKat that I've found useful.
 
Gapps package from the first post doesn't support ART. There's all kinds of KitKat gapps packages floating around internet these days. Some of the more recent ones can't be even installed with our current recoveries though.
 
I'm not sure if ART currently works in CM anyway. It's at least strongly advised against to. It's an experimental feature and only use for it currently is if you're an app developer and you want to ready your apps for future Android versions.

 

Except for the gapps forceclosing, ART seems to be working. if you can live without gapps, simply don't flash it. and install apk's manually. should work fine :)

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

hmmmmm... no wifi for me... Again... Greek Acqua user...  :(

 

Allthough I installed wifi patch from 4.3 (I thought it could work...)....

Edited by epyloxias
0

Share this post


Link to post
Share on other sites

Posted · Report post

I'm glad you're back with us KonstaT
great job this rom, today I installed and everything is working properly camera, Viber, tones and is very fast and has plenty of free memory, Great
thanks
0

Share this post


Link to post
Share on other sites

Posted · Report post

Thank you KonstaaaaT

0

Share this post


Link to post
Share on other sites

Posted · Report post

is anyone expiriencing random reboots?

0

Share this post


Link to post
Share on other sites

Posted · Report post

@Kontsat, when are you going to make this ROM to Xiaomi x9?

0

Share this post


Link to post
Share on other sites

Posted · Report post

@Kontsat, when are you going to make this ROM to Xiaomi x9?

sorry, what?

1

Share this post


Link to post
Share on other sites

Posted · Report post

Well, I was playing with it for a bit and I didn't find any issues and as I experienced this rom is the fastest for our phone.

You're the best, Konstat! :-)

1

Share this post


Link to post
Share on other sites

Posted · Report post

BRILLIANT!!! EXTRAORDINARY!!! 1000+ for KonstaT and his awesome work! Phone runs like a bullet, wifi lock'n loaded, everything works smoothly so far.

For acqua users, after installing rom and gapps, install this: http://www.modaco.com/index.php?/topic/365741-[ROM][PATCH]-ZTE-Blade-III-->-ZTE-Acqua-compatibility-for-all-ROMs#entry4509.

Welldone mate!!!

0

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks KonstaT works perfect !! 

0

Share this post


Link to post
Share on other sites

Posted · Report post

is anyone expiriencing random reboots?

i'm experiencing that too but i think it's our phones, not the rom cuz it started happening to me while i was using cm10.2, then i switched to cm10 (still rebooting) and now i use cm11 and it's still rebooting

0

Share this post


Link to post
Share on other sites

Posted · Report post

i'm experiencing that too but i think it's our phones, not the rom cuz it started happening to me while i was using cm10.2, then i switched to cm10 (still rebooting) and now i use cm11 and it's still rebooting

Did you overclocked your phone? This could be a reason for your reboots.

0

Share this post


Link to post
Share on other sites

Posted · Report post

install XPOSED INSTALLER, then XBLAST MOD... (googling for those two) and then you can change CRT animation

When activated,systemUI crashes and only back button works :P after few minutes blue screen flashes and reboots

0

Share this post


Link to post
Share on other sites

Posted · Report post

Great work KonstaT, I'm using your ROM on an Aussie phone model "ZTE T22 Urbane" similar specs to the Blade III. Running smoothly with no issues that I found.

Runs all the apps that I'm using. Your a legend !!

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

i'm experiencing that too but i think it's our phones, not the rom cuz it started happening to me while i was using cm10.2, then i switched to cm10 (still rebooting) and now i use cm11 and it's still rebooting
Your battery is loose, the conectors losing contact. Put a piece of paper between battery and battery case and it won't happen again. ;-) Edited by daliborhes
2

Share this post


Link to post
Share on other sites

Posted · Report post

Your battery is loose, the conectors losing contact. Put a piece of paper between battery and battery case and it won't happen again. ;-)

Yeah this is the solution.I had same problem with stock rom(4.0.4 ICS),and i tried connecting with charger and did not reboot.Now im using a piece of paper and everything is Ok.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.