• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[APP]Huawei Y300 unlock bootloader,flash twrp and root with tutorial

69 posts in this topic

Posted (edited)

Hi everybody,i have made a small app for unlocking bootloader,flashing recovery,and rooting,i hope you will like it,and i hope it will help you.If there is some "bug",please report it to me,it's the first version,and I'm sleepy,so maybe i missed something...To install,just run .exe file :)

https://mega.co.nz/#!zI5XgA4S!YwI3ixgn-v4-yPNfQek6XCDW4NZkexD2fNdoVw77S68

Ignore tutorial inside app,use video i created :D

Video tutorial by me:

http://www.youtube.com/watch?v=1VzAz0Vlax4&feature=youtu.be

IMPORTANT: Anyone who is using Windows 64bit have to install app first,and then cut the folder C:\\Program Files(x86)\Huawei Y300 AIO to C:\\Program Files\ :P

Edited by ProHunter
8

Share this post


Link to post
Share on other sites

Posted

Is it possible to make a full backup of everything, including stock recovery, before flashing a custom recovery and root?

0

Share this post


Link to post
Share on other sites

Posted

Nope,you can do that right after installing (flashing) recovery,there is an option to make backup...

0

Share this post


Link to post
Share on other sites

Posted

Is there a similar app for the G510? I just want to root my phone - and I can't find a simple reliable set of instructions anywhere - probably not looking hard enough, I know....

0

Share this post


Link to post
Share on other sites

Posted (edited)

I don't think there is an app like this for G510,i made this only for Y300,because i have that phone,so i can't make app for G510,because i can't test it... :)

Edited by ProHunter
0

Share this post


Link to post
Share on other sites

Posted

good to go. if you find solution to edit the topic, kindly add "automated process" or "automatic tool to root...."

0

Share this post


Link to post
Share on other sites

Posted

it works ok on windows 8.1? i had some troubles when i rooted etc my y300 manually.

thanks for the app btw

0

Share this post


Link to post
Share on other sites

Posted

it works ok on windows 8.1? i had some troubles when i rooted etc my y300 manually.

thanks for the app btw

Hmm,i'm unable to try on windows 8,because i use Win 7,but it should work,but you will need .net framework 4.0 or 4.5, i forgot which one i set(i think it was 4.5),i was sleepy... :blush:

0

Share this post


Link to post
Share on other sites

Posted

I don't think there is an app like this for G510,i made this only for Y300,because i have that phone,so i can't make app for G510,because i can't test it... :)

No problem, I finally managed it following the instructions here: http://androidforums.com/ascend-all-things-root/774004-huawei-ascend-g510-development-thread.html#post6165643

0

Share this post


Link to post
Share on other sites

Posted (edited)

V1.1 of my app you can find in first post,it include some minor bug fixes and slightly easier setup... :)

Edited by ProHunter
0

Share this post


Link to post
Share on other sites

Posted

Nice! Voted up :)

Now, this just needs to get pinned so that newcomers can take away all that stress of rooting,unlocking,flashing and what not!

Cheers.

0

Share this post


Link to post
Share on other sites

Posted

get errors whem clieck install driver, on win 8.1

 

See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.
 
************** Exception Text **************
System.ComponentModel.Win32Exception (0x80004005): The system cannot find the file specified
   at System.Diagnostics.Process.StartWithShellExecuteEx(ProcessStartInfo startInfo)
   at System.Diagnostics.Process.Start()
   at System.Diagnostics.Process.Start(ProcessStartInfo startInfo)
   at HuaweiY300.Form1.button6_Click(Object sender, EventArgs e)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ButtonBase.WndProc(Message& m)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
 
 
************** Loaded Assemblies **************
mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.34003 built by: FX45W81RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
----------------------------------------
HuaweiY300
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/HuaweiY300%20AIO/Tools/UnlockTools/HuaweiY300.exe
----------------------------------------
System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.33440 built by: FX45W81RTMREL
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.33440 built by: FX45W81RTMREL
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.34003 built by: FX45W81RTMGDR
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Xml
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.33440 built by: FX45W81RTMREL
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
 
************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.
 
For example:
 
<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>
 
When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.
0

Share this post


Link to post
Share on other sites

Posted

Try to download and install .net framework 4.5...I guess thats a problem...

0

Share this post


Link to post
Share on other sites

Posted (edited)

Try to download and install .net framework 4.5...I guess thats a problem...

try to do this, but seemed it was there already:

 

Details
 
The .NET Framework 4.5 and this update are already installed on your computer.
checked 

378675

.NET Framework 4.5.1 installed with Windows 8.1

Edited by roy2014
0

Share this post


Link to post
Share on other sites

Posted

phone not found..huawei y300-151 user..help

0

Share this post


Link to post
Share on other sites

Posted (edited)

Did you installed drivers first?

@roy 2014 Did you downloaded HuaweiY300v1.1.exe from first post,or it's some older version?

Edited by ProHunter
0

Share this post


Link to post
Share on other sites

Posted

i see that i need SuperSU-v1.86.zip.how do i get it?

0

Share this post


Link to post
Share on other sites

Posted (edited)

You have everything you need in my app...

Edited by ProHunter
0

Share this post


Link to post
Share on other sites

Posted

Hi,

 

First of all, thanks for releasing this app! It's a great idea!

 

Secondly, I'm having trouble getting the app running. I have tried the app on Windows 7, 8 and 8.1. All three computers had .Net Framwork 3.5 and 4.5 installed. Doesn't matter which button I press, I keep on getting the same error message:

 

post-1033314-0-15778500-1388704990_thumb

 

See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.
 
************** Exception Text **************
System.ComponentModel.Win32Exception (0x80004005): The system cannot find the file specified
   at System.Diagnostics.Process.StartWithShellExecuteEx(ProcessStartInfo startInfo)
   at System.Diagnostics.Process.Start()
   at System.Diagnostics.Process.Start(ProcessStartInfo startInfo)
   at HuaweiY300.Form1.button10_Click(Object sender, EventArgs e)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ButtonBase.WndProc(Message& m)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
 
 
************** Loaded Assemblies **************
mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.17929 built by: FX45RTMREL
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
----------------------------------------
HuaweiY300
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/HuaweiY300%20AIO/Tools/UnlockTools/HuaweiY300.exe
----------------------------------------
System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.17929 built by: FX45RTMREL
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.17929 built by: FX45RTMREL
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.17929 built by: FX45RTMREL
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
 
************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.
 
For example:
 
<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>
 
When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

 

 

 
Could you help me please?
 
Thanks you!
0

Share this post


Link to post
Share on other sites

Posted

Did you installed drivers first?

 

yes sir i installed the drivers found in your gui then restarted my pc, but still got the same error "phone not found"  :(

0

Share this post


Link to post
Share on other sites

Posted (edited)

 

Hi,

 

First of all, thanks for releasing this app! It's a great idea!

 

Secondly, I'm having trouble getting the app running. I have tried the app on Windows 7, 8 and 8.1. All three computers had .Net Framwork 3.5 and 4.5 installed. Doesn't matter which button I press, I keep on getting the same error message:

 

attachicon.giferror.png

 

 

 
Could you help me please?
 
Thanks you!

 

Hi,I'm sorry for trouble with my software,but i have compiled this software on my laptop,and after that,i downloaded it from the link i gave, on my desktop,and it's working perfectly fine....(P.S It have to be installed on C partition,if you don't have it,it's not going to work)...I will make a new version for about 10days...

Edited by ProHunter
0

Share this post


Link to post
Share on other sites

Posted

yes sir i installed the drivers found in your gui then restarted my pc, but still got the same error "phone not found"  :(

go to Settings  -> Developer Options and make sure USB debugging is ticked.

after that turn off phone,pull out battery and put it back after 5sec

hold Volume Down + Power ON button,phone should freeze on Huawei logo

Connect phone with usb,and then try,it should find your device... :)

0

Share this post


Link to post
Share on other sites

Posted

go to Settings  -> Developer Options and make sure USB debugging is ticked.

after that turn off phone,pull out battery and put it back after 5sec

hold Volume Down + Power ON button,phone should freeze on Huawei logo

Connect phone with usb,and then try,it should find your device... :)

i've followed your advice sir but still got the same message, but anyway thanks for your help, maybe i'll just wait for the reply from huawei website.. by the way i'm using huawei y300-151

0

Share this post


Link to post
Share on other sites

Posted

hi I get the same errors as roy2014 and I´m trying to do it manually with your software.

in your readme file the line 16.Run "Install Recovery" and follow instructions, is the flash_recovery.bat ?

in line 18.Run "SuperSU(root)" and copy file to your memory card, is just copying SuperSU-v1.86.zip to a SD card?

After the process I´m able to install the cyanogen rom for android 4.4?

Thx

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.