• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[ICS][AOSP]Android 4.0.4 MoltenMotherBoard

30 posts in this topic

Posted (edited)

This is pretty much an AOSP build of ICS for the Crescent, built of MoltenMotherBoard's sources

 

Other Credits:

  • tilal6991 - for being awesome, helping Dazzozo with getting started and offering a ton of advice and fixes.
  • Dazzozo - god of crescent
  • Fuzzra - getting this off the ground in the first place, we wouldn't be here now without his initial work!
  • Fuzzra and UndauntedOlly - Orange UK Signal Boost!
  • TomGiordano - the ZTE overlord.
  • fr0do - the awesome Vivacity guinea-pig with getting the buttons fixed up!
  • The entire CyanogenMod team - For supporting armv6 devices!
  • MoltenMotherBoard team
  • C3C0 For his work on ICS kernel
  • rymate1234
  • H3ROS for his great governor

Sources:

What type of device do I have?:

  • P736V: Orange San Francisco II, Free Blade S and other variants.
  • P736E: T-Mobile Vivacity, Telenor Touch Plus and other variants.

Downloads:

Details:

  • Android 4.0.4 - Ice Cream Sandwich in pure AOSP flavour!
  • Adreno 200 ARMv6 GPU drivers for awesome 3D performance - Ice Cream Sandwich running smooth on the Crescent!
  • Hardware acceleration! (hell even omx might be working thanks to the hacky hacks)
Edited by gbosh
0

Share this post


Link to post
Share on other sites

Posted (edited)

Working:

  • Hardware Acceleration
  • Mobile Data - 3G/2G
  • Network and RIL
  • Sound
  • Sensors
  • Live Wallpapers
  • USB Mass Storage
  • Calculator
  • Gallery
  • Rear Camera
  • Wi-Fi
  • Bluetooth
  • Camcorder
  • Hardware decoding (with the hackiest of hacks)
  • Panorama

Not Working and being worked on:

  • Wi-fi tethering
  • Screenshots and multitasking previews are upside-down

Not working:

  • Front Camera (hahahahaha lol nope)
  • Camera flash (hahahahaha lol nope)
Edited by gbosh
0

Share this post


Link to post
Share on other sites

Posted (edited)

R1 - 28/12/13

  • Initial build
  • Enabled volume boost at kernel level
Edited by gbosh
0

Share this post


Link to post
Share on other sites

Posted

Thanks for this. I wonder how this will rank performance wise. It's always easy to assume performance is better on a new install.

I'm guessing this only just fits a 200mb system partition?

0

Share this post


Link to post
Share on other sites

Posted

Good job man!

0

Share this post


Link to post
Share on other sites

Posted

Do I need TPT for this rom? If yes please give me a link for tpt.

Thanks

0

Share this post


Link to post
Share on other sites

Posted

I think 160mb system space is enough for rom and gapps

0

Share this post


Link to post
Share on other sites

Posted

@gbosh

thanks! yes 160 mb is enough.Rom is wery smoth and fast, no random reboots.

wifi tethering works with "wifi tether for root users". only proximity sensor need calibration... if is possible.?

0

Share this post


Link to post
Share on other sites

Posted

So camera flash working or not ?

 

Thanks.

0

Share this post


Link to post
Share on other sites

Posted

Nope, and it's very highly unlikely it ever will on any 4.x rom

0

Share this post


Link to post
Share on other sites

Posted

I can't find options for proximity sensor calibration and settings for brightnes levels. Any solution?

Thanks.

0

Share this post


Link to post
Share on other sites

Posted (edited)

I installed this rom using a 160mb system TPT.

 

The rom may be small enough to fit, but with gaps is does not fit.

 

The way android deals with this scenario is just stupid, apps just go missing etc.

 

This means, because I installed gaps before superuser, I am going to have to re-install from scratch because I cannot remove the system apps to make more space! Doh!

Edited by dodgetimmy
0

Share this post


Link to post
Share on other sites

Posted (edited)

GPS doesn't seem to be working.

 

This rom is slimmer than Slimbean!

Edited by dodgetimmy
0

Share this post


Link to post
Share on other sites

Posted

I installed this rom using a 160mb system TPT.

 

The rom may be small enough to fit, but with gaps is does not fit.

 

The way android deals with this scenario is just stupid, apps just go missing etc.

 

This means, because I installed gaps before superuser, I am going to have to re-install from scratch because I cannot remove the system apps to make more space! Doh!

You could try with trimed gapps http://www.mediafire.com/download/vti8xb50wb2awh5/lite-gapps-ics-20120429-signed.zip thanks to Dovahpig.

0

Share this post


Link to post
Share on other sites

Posted

Thanks, it fits fine if you use barely any gaps :)

 

GPS is still a problem though, I'm guessing it just has't been implemented?

0

Share this post


Link to post
Share on other sites

Posted (edited)

Yeah, mobile data 'appears' to work but doesn't actually connected, but otherwise good job!

@Trotil Also thanks for link the trimmed gapps! (and Dovahpig of course) 

Edited by SCORE!
0

Share this post


Link to post
Share on other sites

Posted

Yeah, mobile data 'appears' to work but doesn't actually connected, but otherwise good job!

Did you mean GPS or Mobile Data? Mobile data works fine for me.

0

Share this post


Link to post
Share on other sites

Posted

Did you mean GPS or Mobile Data? Mobile data works fine for me.

Yeah, mobile data. I haven't tried GPS yet but for some reason I can't get a data signal although I can make & receive calls?
0

Share this post


Link to post
Share on other sites

Posted

Data works for me, are you sure you have your apn setup?

I'll have a look at gps soon and see what I can do

0

Share this post


Link to post
Share on other sites

Posted

Thanks man, just checked & apn isn't set up, just blank page.

0

Share this post


Link to post
Share on other sites

Posted

I just checked, GPS works fine for me.

0

Share this post


Link to post
Share on other sites

Posted

I found T mobile APN and created a new one, but mobile data it still didn't work. Any fixes or tips available? I'm getting gps working in maps. Really like this rom, just wish the mobile data worked  :(

0

Share this post


Link to post
Share on other sites

Posted

You can use the apn you used on whatever ROM it works on and just enter it in this rom.

Or just Paste any apn-conf.xml to your /system/etc from any rom were mobile data works, this e.g is cyanogenmod 9's https://docs.google.com/file/d/0B_f-rFtMJSdjQVlqNmF1eVJnaFU/edit

When I update this ROM I will include the standard apns and the proximity calibration.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Okay, now I have got which rom is which correct, I tested GPS the other day with this rom and although it finds a signal, I found the instructions were lagging behind a lot, the google arrow in navigation(google maps) especially. As an example, the application seems to get stuck with the arrow showing in one location and then later when you tap the screen it seems to catch up again

 

I am wondering if its just me this is happening too and whether there is something wrong with the GPS chip in my handset. Or perhaps my SD card just isn't fast enough or something.

 

The other thing is, if you take the phone just walking about, it can't seem to get a GPS signal at all and relies only on the mobile signal to work out roughly where you are, this results in it never knowing which direction you are travelling in because you go very slow.

 

Of course I am making sure at this point I actually have a signal according to android and that there are no tall buildings around.

 

Just none of it seems to work like GB roms do when it comes to GPS.

Edited by dodgetimmy
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.