• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[ROM] [PAC] [KK][UNOFFICIALL][Y300/G510] [BETA 1.0] [FM ADDED]

145 posts in this topic

Posted

Any news? I'm very anxious to install this ROM because I never tried PAC-Roms, so...sorry if i'm boring you!

I have problem with chil kernel source. always same error and build stops:

Screenshot_from_2014_05_04_16_03_46.jpg

Anyone got idea how to solve this?

0

Share this post


Link to post
Share on other sites

Posted (edited)

I have problem with chil kernel source. always same error and build stops:

 

Anyone got idea how to solve this?

This is not related kernel problem. Maybe Vold patch on common device break it or cm's vold is crashed.

 

Try to repo sync and apply again patches. 

Edited by eloimuns
1

Share this post


Link to post
Share on other sites

Posted

This is not related kernel problem. Maybe Vold patch on common device break it or cm's vold is crashed.

 

Try to repo sync and apply again patches. 

thanks...

I did it twice but no luck. Every time during start build vold patch was applyed so problem could be in:???

<project path="system/vold" name="android_system_vold" groups="pdk" remote="cm" />
0

Share this post


Link to post
Share on other sites

Posted

thanks...

I did it twice but no luck. Every time during start build vold patch was applyed so problem could be in:???

<project path="system/vold" name="android_system_vold" groups="pdk" remote="cm" />
Mmm.. Delete system/vold folder, sync again and apply patches and build.
1

Share this post


Link to post
Share on other sites

Posted

Mmm.. Delete system/vold folder, sync again and apply patches and build.

You were right about vold folder. I made build but chil kernel is not compatible with pac for some reason.?? boot loop ...

0

Share this post


Link to post
Share on other sites

Posted

You were right about vold folder. I made build but chil kernel is not compatible with pac for some reason.?? boot loop ...

IDK.. Take a logcat but if with cm works (idk if it work with cm), with pac will work.

1

Share this post


Link to post
Share on other sites

Posted (edited)

one strange thing that confuse me is size of boot image:

6.4 MB (6,350,848 bytes)

Its always around 5.5 mb

btw build went smooth with no errors...

 

correction:

not a boot loop, constant reboots (not even a start up) without chance to make logcat.

Edited by Y300-0100
0

Share this post


Link to post
Share on other sites

Posted

one strange thing that confuse me is size of boot image:

6.4 MB (6,350,848 bytes)

Its always around 5.5 mb

btw build went smooth with no errors...

correction:

not a boot loop, constant reboots (not even a start up) without chance to make logcat.

Are you using correct defconfig of chill kernel? You mod another things than my pac-u8951 sources?
1

Share this post


Link to post
Share on other sites

Posted

 

<?xml version="1.0" encoding="UTF-8"?>

<manifest>

  <remove-project name="androidarmv6/android_hardware_qcom_display-legacy" />

  <remove-project name="androidarmv6/android_hardware_qcom_media_legacy" />

  <project name="PAC-U8951/android_device_huawei_u8833" path="device/huawei/u8833" remote="github" revision="cm-11.0" />

  <project name="PAC-U8951/android_device_huawei_msm7x27a-common" path="device/huawei/msm7x27a-common" remote="github" revision="cm-11.0" />

  <project name="chil360/chil360-kernel" path="kernel/huawei/huawei-kernel-3.4" remote="github" revision="kitkat" />

  <project name="Pinky-Inky-and-Clyde/proprietary_vendor_huawei" path="vendor/huawei" remote="github" revision="cm-11.0" />

  <project name="Dazzozo/android_hardware_atheros_wifi_ath6kl-huawei" path="hardware/atheros/wifi/ath6kl-huawei" remote="github" revision="master" />

  <project name="legaCyMod/android_hardware_atheros_wlan" path="hardware/atheros/wlan" remote="github" revision="cm-11.0" />

  <project name="Dazzozo/android_hardware_qcom_display-legacy" path="hardware/qcom/display-legacy" remote="github" revision="jellybean-mr2" />

  <project name="Dazzozo/android_external_webkit" path="external/webkit" remote="github" revision="kitkat" />

  <project name="Dazzozo/android_hardware_qcom_media-legacy" path="hardware/qcom/media-legacy" remote="github" revision="jellybean-mr2" />

  <project name="PAC-U8951/android_device_huawei_u8951" path="device/huawei/u8951" remote="github" revision="cm-11.0" />

</manifest>

just this

0

Share this post


Link to post
Share on other sites

Posted

just this

And the defconfig of kernel are correct?
1

Share this post


Link to post
Share on other sites

Posted (edited)

And the defconfig of kernel are correct?

I just set path to chil kernel. Could you be more precise about def config of kernel please because I am new at this.

Btw. In my new build I have set path to new art, dalvik and bionic and new build seems to be smoother and faster than previous.(daz kernel). And antutu jumped at 7000 without any tweaks.

Edited by Y300-0100
0

Share this post


Link to post
Share on other sites

Posted

I just set path to chil kernel. Could you be more precise about def config of kernel please because I am new at this.

 

The defconfig of Dazzozo kernel is this: https://github.com/PAC-U8951/android_device_huawei_u8833/blob/cm-11.0/BoardConfig.mk#L36

 

But maybe, on Chill kernel use another defconfig. In their kenel if you don't know it, go arch/arm/defconfigs and search for the correct and redefine in boardconfig.

2

Share this post


Link to post
Share on other sites

Posted (edited)

Thanks a lot. I will try it later.

edit:

I think I find mismatch in:

 

chil

android_device_huawei_msm7x27a-common / BoardConfigCommon.mk

# Kernel
BOARD_KERNEL_BASE := 0x00200000
BOARD_KERNEL_CMDLINE := androidboot.hardware=huawei androidboot.selinux=permissive
BOARD_PAGE_SIZE := 2048
TARGET_KERNEL_SOURCE := kernel/huawei/huawei-kernel-3.4
TARGET_KERNEL_CUSTOM_TOOLCHAIN := linaro-4.7-13.04/bin/arm-linux-gnueabihf-
BOARD_MKBOOTIMG_ARGS := --ramdisk_offset 0x01800000

# Lights
TARGET_PROVIDES_LIBLIGHTS := true

Dazzozo

android_device_huawei_msm7x27a-common / BoardConfigCommon.mk

# Kernel
BOARD_KERNEL_BASE := 0x00200000
BOARD_KERNEL_CMDLINE := androidboot.hardware=huawei androidboot.selinux=permissive
BOARD_PAGE_SIZE := 2048
TARGET_KERNEL_SOURCE := kernel/huawei/huawei-kernel-3.4

# Lights
TARGET_PROVIDES_LIBLIGHTS := true

 

Edited by Y300-0100
0

Share this post


Link to post
Share on other sites

Posted

 

Thanks a lot. I will try it later.

edit:

I think I find mismatch in:

 

chil

android_device_huawei_msm7x27a-common / BoardConfigCommon.mk

# Kernel
BOARD_KERNEL_BASE := 0x00200000
BOARD_KERNEL_CMDLINE := androidboot.hardware=huawei androidboot.selinux=permissive
BOARD_PAGE_SIZE := 2048
TARGET_KERNEL_SOURCE := kernel/huawei/huawei-kernel-3.4
TARGET_KERNEL_CUSTOM_TOOLCHAIN := linaro-4.7-13.04/bin/arm-linux-gnueabihf-
BOARD_MKBOOTIMG_ARGS := --ramdisk_offset 0x01800000

# Lights
TARGET_PROVIDES_LIBLIGHTS := true

Dazzozo

android_device_huawei_msm7x27a-common / BoardConfigCommon.mk

# Kernel
BOARD_KERNEL_BASE := 0x00200000
BOARD_KERNEL_CMDLINE := androidboot.hardware=huawei androidboot.selinux=permissive
BOARD_PAGE_SIZE := 2048
TARGET_KERNEL_SOURCE := kernel/huawei/huawei-kernel-3.4

# Lights
TARGET_PROVIDES_LIBLIGHTS := true

 

 

Try it :)

1

Share this post


Link to post
Share on other sites

Posted

Try it :)

thx for pointers. Already on it...

 

now uploading build with slimkat art, bionic and dalvik but with Dazzozo kernel ;)

0

Share this post


Link to post
Share on other sites

Posted

Thanks

0

Share this post


Link to post
Share on other sites

Posted (edited)

Downloading and testing

 

Edit : weather on persistent statusbar doesn't work 

Reedit : expanded desktop doesn't work

Edited by luca020400
0

Share this post


Link to post
Share on other sites

Posted (edited)

Downloading and testing

 

Edit : weather on persistent statusbar doesn't work 

Reedit : expanded desktop doesn't work

expanded desktop u have to enable first in pac pallets and then in buttons/power menu and it will work.

weather style ~above carrier text~ works for me

weather style ~weather panel~ works for me

weather style ~persistent notification  ~ does not work which is annoying when works (most people say) :)

Edited by Y300-0100
0

Share this post


Link to post
Share on other sites

Posted

ok thanks in this way expanded desktop work and for the weather same for me

0

Share this post


Link to post
Share on other sites

Posted

this is last cm 11 based? 06 nighly

0

Share this post


Link to post
Share on other sites

Posted (edited)

this is last cm 11 based? 06 nighly

06/05 Pac source, cm 11 based (dazz kernel) and with added sources for art, dalvik and bionic from slimkat souces.

 

Build from source...

 

Next step is to add chil kernel source to a build and it seams to going well... So far build is holding :)

Edited by Y300-0100
0

Share this post


Link to post
Share on other sites

Posted

Thank you for your work! Tring it, seems good, but slower than other roms! Thank you again!

0

Share this post


Link to post
Share on other sites

Posted (edited)

This night i left my phone on, but it doesn't entered deep sleep mode (with slim it does), and the battery has gone from charged to 80%! How can i solve this?

P.s. Sorry for the double post!

Edited by davidfiorentino
0

Share this post


Link to post
Share on other sites

Posted

  • Anyone working on this one?
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.