luca020400

[Mod] [All] Mega Swap Script Collection

Recommended Posts

luca020400    640

FEATURES
Single swap ( /cache  /system or /data ) and dual Swap /system and /cache
Improve the performance of your cell
Fstrim in /data /system /cache (To learn more of FSTRIM http://fcns.eu/2013/09/12/improve-ssd-performance-with-fstrim/ )

Zipalign

REQUIREMENTS
Kernel with swap (recommended kernels chil CeXtel and sληορsιs)
Kernel/ROM with Init.d (recommended kernels chil CeXtel and sληορsιs)

VARIANTS OF THE SCRIPTS

Single swap :
64 MB /cache
100 MB /cache

64 MB /data
100 MB /data
64 MB /system
100 MB /system

Dual swap :
128 MB /cache and /system ( 64 MB for each partition )
200 MB /cache and /system ( 100 MB for each partition )
 

Swap disabler

Zipalign enabler and disabler

Fstrim enabler and disabler
Zram disabler
( All roms )
Zram enabler ( Only  moddingg33k kernel )

 

INSTRUCTIONS
1º Copy the script to the sd or internal
2º Wipe cache
3º Flash the zip
4º Reboot

TESTED DEVICES
Huawei ascend Y300 WITH 4.1/4.4.2

DOWNLOADS
My Personal Server

THANKS TO
Victod

Darky

Edited by luca020400

Share this post


Link to post
Share on other sites
luca020400    640

Can someone test with android gingerbreab and ics

Share this post


Link to post
Share on other sites
luca020400    640

I have also added zram enabler only for sinopsis kernel and fstrim enabler

Share this post


Link to post
Share on other sites
thebros991    0

I have flashed swapmod1.6, that would give me 100*2 of swap and fstrim. When i open diskinfo, in /cache and /system There is less space than before (100mb) But in the section "ram" The voice "swap" doesen t exist. Why?

Share this post


Link to post
Share on other sites
thebros991    0

OK found the problem I will upload the fix in 10 minuts

For this moment delete the 99Swap in /etc/init.d and pur this http://www.mediafire.com/view/?lfuzgnpjj15o14f

I have changed the file but nothing is different. The swapfiles are in /system and /cache. But swap isn t working. If i put free in terminal all swap values are 0 . Have i committed mistakes?

1)Wipe dalvik and cache

2)flash disable zram.zip

3)flash swap 1.6

4)Reboot

Share this post


Link to post
Share on other sites
luca020400    640

Try reflaah the kernel

 

EDIT : fuond the problem : busybox i will release a new version of scipt

EDIT 2 : updated

Edited by luca020400

Share this post


Link to post
Share on other sites
Dragonhof    0

what is the best way to give my y300 better performance? im running c-rom by elyogomez but i just want to get the best out of my phone with any 4.4 rom so what rom do you suggest with what kernel?

Share this post


Link to post
Share on other sites
luca020400    640

If you want use swap you have to flash disable zram and then you can flash all the script 

Share this post


Link to post
Share on other sites
barnir    1

ZRAM + swap, is there any issue in having this 2 at same time?

 

I installed fstrim, zipalign,zram enabler and 2x100mb on slimstock

Edited by barnir

Share this post


Link to post
Share on other sites
luca020400    640

In this way you will got a bootloop you have to disable zram

Share this post


Link to post
Share on other sites
barnir    1

so when installing swap it removes the zram enabler? cause the phone booted normally xd 

Share this post


Link to post
Share on other sites
luca020400    640

Yes my swapscript disable zram automatically

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.