Jump to content
Mourta

LiquidSmooth 3.2, Unofficial and optimized [updated 2014-09-16]

Recommended Posts

Yes, I knew it, but a non-anykernel version of the kernel would make everything more simple

 

oh yes, definitely

Share this post


Link to post
Share on other sites

if u want a secondary rom with default kernel then u should install as primary and flash kernel n backup n restore as secondary rom

http://forum.xda-developers.com/showpost.php?p=50793943&postcount=67

Ah, that is the trick the kexec support must be on primary kernel, that help me much, thanks. Edited by justchris20

Share this post


Link to post
Share on other sites

Ah, that is the trick the kexec support must be on primary kernel, that help me much, thanks.

Yes, right. Basically, if you flash a kexec-hardboot patched kernel on the top of the internal rom, you'll be able to flash whatever rom you want, as secondary.. And it'll work fine with its own built in kernel without problems, but the problem appears if you need to flash a different anykernel-patched kernel on the top of that secondary rom, which is not possible
  • Upvote 1

Share this post


Link to post
Share on other sites

Hi there,

 

I have a problem flashing LiquidSmooth. As it said in the first post, maybe I did something wrong.

Here is my config:

  • TWRP 2.7.1.0 (Multirom Support, but not used)
  • SlimKat Rom installed
  • nothing more.
  • Battery at 100%

 

Now my steps:

  1. booted in recovery and did a Backup
  2. Wipe
    1. Factory Reset
    2. Advanced Wipe (marked all except Internal and external SD)
  3. Install
    1. LS-KK-v3.2-2014-08-02-p880.zip
    2. pa_gapps-modular-mini-4.4.4-20140811-signed.zip
  4. Reboot
  5. Stucked in bootanimation for >20 Minutes. The temperature on the display was really hot.

After removing the Battery I let the phone cool down and tried it with new downloaded Rom an gapps in 2 differnt ways

Second try. The same with Wipe Dalvik Cache after flash

Third Try. The same without gapps and without Dalvik wipe

 

I don't know what to do next. I flashed roms a dozens of times but this one won't boot.

Share this post


Link to post
Share on other sites

[*]Install

  • LS-KK-v3.2-2014-08-02-p880.zip
  • pa_gapps-modular-mini-4.4.4-20140811-signed.zip
[*]Reboot

Mmm, you have forgotten to install Mourta's kernel, maybe? :P Edited by Giuseppe Vallone

Share this post


Link to post
Share on other sites

Did you restore or flash anything else after flashing the ROM, the GApps and the kernel?

No. only 3 zips now with the latest post from giuseppe. Rom, Gapps, Kernel

 

Edit:

The older version of the rom is working (LS-KK-v3.2-2014-07-21-p880.zip)

I'll try to install the new one on top. Fingers crossed

Edited by guest07

Share this post


Link to post
Share on other sites

No. only 3 zips now with the latest post from giuseppe. Rom, Gapps, Kernel

Edit:

The older version of the rom is working (LS-KK-v3.2-2014-07-21-p880.zip)

I'll try to install the new one on top. Fingers crossed

Fine, let we know! :)

Share this post


Link to post
Share on other sites

No chance, same problem. Phone is running hot and stuck un bootanimation.

I changed the govenor to undemand before updating.

 

Mhh maybe it shouldn't be.

Share this post


Link to post
Share on other sites

No. only 3 zips now with the latest post from giuseppe. Rom, Gapps, Kernel

 

Edit:

The older version of the rom is working (LS-KK-v3.2-2014-07-21-p880.zip)

I'll try to install the new one on top. Fingers crossed

 

Very strange. I flashed the same ROM and kernel last night (just with different GApps, but that shouldn't make any difference), and after two reboots it worked properly.

 

Which runtime do you use?

Edited by tool_king

Share this post


Link to post
Share on other sites

I'm confused with all this multirom talk, if you flashed this why would you want the option to swap to an inferior rom?

Share this post


Link to post
Share on other sites

Very strange. I flashed the same ROM and kernel last night (just with different GApps, but that shouldn't make any difference), and after two reboots it worked properly.

 

Which runtime do you use?

Dalvik. I never used Art. 

My baseband Version is v20D. Could that be a Problem. I flashed it because i thought  this solves my GPS fix problems in v20b.

Share this post


Link to post
Share on other sites

Dalvik. I never used Art. 

My baseband Version is v20D. Could that be a Problem. I flashed it because i thought  this solves my GPS fix problems in v20b.

 

Afaik, the baseband has absolutely nothing to do with the booting process.

Share this post


Link to post
Share on other sites

No. only 3 zips now with the latest post from giuseppe. Rom, Gapps, Kernel

 

Edit:

The older version of the rom is working (LS-KK-v3.2-2014-07-21-p880.zip)

I'll try to install the new one on top. Fingers crossed

 

you flashed the newer LS over the older that worked before

 

do you have flashed the kernel again after flashing the newer LS ROM?

Share this post


Link to post
Share on other sites

No. only 3 zips now with the latest post from giuseppe. Rom, Gapps, Kernel

Edit:

The older version of the rom is working (LS-KK-v3.2-2014-07-21-p880.zip)

I'll try to install the new one on top. Fingers crossed

Try booting without gapps...

Share this post


Link to post
Share on other sites

Unluckily I have to report that going back to dalvik doesn't fix the problem, I was thinking it's because of the gapps..

Share this post


Link to post
Share on other sites

New Kernel works great, thanks for the effort!

 

Is there a reason, why I can't boot to bootloader anymore? I only see the LG logo for a long time, but nothing more happens. 10 sec power reboots to rom. Tried to boot to bootloader from TWRP Manager, CWM Manager, Advanced Power Menu and ADB...

 

Thanks in advance!

Share this post


Link to post
Share on other sites

Okay, I wiped everything and now it's finally back to normal.

 

I'm trying to get into ART again, this time before reinstalling apps or restoring them through Titanium Backup.

 

Thanks to everyone who tried to help me in my desperate case. :)

 

Edit: After switching to ART, going to Play Store leads me to a fc of android.process.media.

 

Now that I recall it well, I saw that error message before all the stormshit happened... I think there's something wrong with ART in the rom build, as I didn't install any of my apps atm. Or could it be the PA Gapps? I'll try to download a different version and reformat and reinstall everything and see what happens.

 

Edit2: I'll just reboot the smartphone for now and see if that message will appear again whenever I open Google Play Store and Gmail and other apps, I couldn't download a thing that the message appeared and made the stock browser crash.

 

Edit3: After a reboot, it seems the message doesn't appear anymore.. Let's hope no other shits will happen to me, especially after restoring from Titanium Backup. :(

Edited by Krislv

Share this post


Link to post
Share on other sites

Please read :

http://forum.xda-developers.com/showthread.php?t=2296711

A little update from LG...

I wrote them that they have messed up our bootloader, and told them the bugs/problems/... well, see yourself:

1) "adb reboot bootloader" doesn't bring me into bootloader. Well it does, but even though i have unlocked the bootloader, it still says it would be locked.

instead i need to use "adb reboot oem-unlock" to get into bootloader.

- P880 does not support "adb reboot bootloader" to go into bootloader. P880 only works "adb reboot oem-unlock" instead of "adb reboot bootloader" to go into bootloader. and then you can use the fastboot command mode after accept unlock bootloader.

2) "fastboot reboot" partly reboots the device, but then it keeps stuck at the first LG splash screen. pressing power button for 10 seconds brings me into recovery then, instead of into the ROM.

- P880 supports "fastboot reboot", before flashing the customize image, "fastboot reboot" reboot normally.

3) "fastboot flash system [path/to/system.img]" gives me "fatal error: unknown partition"

- P880 can only flash boot, recovery. Ex> fastboot flash boot/recovery boot.img/recovery.img

4) "fastboot boot [...]" doesn't work at all.

- P880 does not support "fastboot boot [...]" command

- P880 supports only flash, erase, reboot as you already seen in bootloader unlock warning message.

5) I have found no way to boot into fastboot/bootloader without a booting phone. Maybe you could try to add the possibility to boot directly into fastboot.

- You can only go into fastboot mode using "adb reboot oem-unlock"

Edited by creedence

Share this post


Link to post
Share on other sites

Okay, I wiped everything and now it's finally back to normal.

I'm trying to get into ART again, this time before reinstalling apps or restoring them through Titanium Backup.

Thanks to everyone who tried to help me in my desperate case. :)

Edit: After switching to ART, going to Play Store leads me to a fc of android.process.media.

Now that I recall it well, I saw that error message before all the stormshit happened... I think there's something wrong with ART in the rom build, as I didn't install any of my apps atm. Or could it be the PA Gapps? I'll try to download a different version and reformat and reinstall everything and see what happens.

Edit2: I'll just reboot the smartphone for now and see if that message will appear again whenever I open Google Play Store and Gmail and other apps, I couldn't download a thing that the message appeared and made the stock browser crash.

Edit3: After a reboot, it seems the message doesn't appear anymore.. Let's hope no other shits will happen to me, especially after restoring from Titanium Backup. :(

I always use banks gapps and never have any problems

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×