Jump to content
Mourta

LiquidSmooth 3.2, Unofficial and optimized [updated 2014-09-16]

Recommended Posts

Ehh...i just had "sleep of death" as i call it. Charger pluged, and phone didnt response. I had to power press to reboot. Anyone else?

I had a couple of "sleeps of death" with the previous version of the rom, but now that problem is gone for me thanks to Mortua.

Share this post


Link to post
Share on other sites

I had a couple of "sleeps of death" with the previous version of the rom, but now that problem is gone for me thanks to Mortua.

 

Oups, wrong quote. I also had several "sleeps of death", and still have. 

Edited by BaluP880

Share this post


Link to post
Share on other sites

Oups, wrong quote. I also had several "sleeps of death", and still have. 

Did you undervolt your device? Which settings do you use? Without any information (or even better logs, dmesg,...), Mourta won't be able do fix anything.

Share this post


Link to post
Share on other sites

When using gesture unlock, accessing lockscreen camera doesn't work for me. It's a very unimportant bug, just thought I should post it.

Share this post


Link to post
Share on other sites

I really like the rom, very smooth compared to slimbeans (from where I came)! :) Great work! :) 

 

I installed version 8-17 however I would like to install 08-22 :D

Do I need to format system, cache and "everything" else?

 

And does 08-22 liquidsmooth contains 08-23  kernel ? :)

 

And last question: do you recommend using ART ?

 

thx in advance.

Share this post


Link to post
Share on other sites

I installed version 8-17 however I would like to install 08-22 :D

Do I need to format system, cache and "everything" else?

 

And does 08-22 liquidsmooth contains 08-23  kernel ? :)

 

And last question: do you recommend using ART ?

No, you don't have to wipe or format anything, if you already have been on the 08-17 version so far. The new kernel is already merged within the new rom. I personally prefer ART, but it's a matter of taste I guess.

Share this post


Link to post
Share on other sites
Hello @Mourta ,first off all thank you for this fantastic rom , i have no words to say how greatful we all are for your job :D .
Since yesterday I am on your latest release + mourta-stable_08-23 kernel and i have set everything as you proposed in the OP .
After one day of use i have to say that i am impressed . Perfect deep sleep , fast and fluid, too many optimizations and features etc..
I have one request if you don't mind , in built-in SMS app(and with keyboard generaly), word prediction and spell checker doesn't work in my language (i am from Greece) but if i switch to English works perfectly. So i am guessing that Greek language missing. Can you add it please? Thanks in advance and keep up the good work! 

Share this post


Link to post
Share on other sites

Yup they occured to me also those sleep of death, but that aside the rom is nearly perfect, great work.

Share this post


Link to post
Share on other sites

Are u all with those bsod's on ART? I was facing it too now trying dalvik.

Also ok google everywhere causing microphone not working in calls for me.

If it is app problem please skip it. But i think its something with blobs or those audio wrappers which Adam made.

Edited by Gerard Szulc

Share this post


Link to post
Share on other sites

Are u all with those bsod's on ART? I was facing it too now trying dalvik.

Also ok google everywhere causing microphone not working in calls for me.

If it is app problem please skip it. But i think its something with blobs or those audio wrappers which Adam made.

Nope, dalvik. Recommended settings using Kernel Tweaker, no undervolting, no overclocking. Latest ROM and latest Kernel. Beside these SODs the best ROM I ever used!!!! thanks a lot for that!

Share this post


Link to post
Share on other sites

no... made a clean install on ART and no bsod problems

 

try to install LS

boot

set to ART

reboot to recovery

flash GAPPs

reboot

install/restore your apps (if you use TB than check the list of apps to prevent that you restore apps like Google+ updates or stuff like this..) had this in userapps 

and Trickstermod without data (if you use it)

reboot to recovery and wipe dalvik/cache

boot and wait

Share this post


Link to post
Share on other sites

I am on previous version of ROM and on latest kernel and it started after flashing it. seems it is  kernel related.

And it didnt happen on charging. I'll grab a logcat when it comes again

Share this post


Link to post
Share on other sites

I'm aware of the issue, i know why it occurs (only when charging, the rest i cannot account for and will know nothing about without proper logs, i prefer bootlog logs and so should you as users, it's simple to use and simple for me to find the problem) and i am in the process of fixing it.

 

I didn't realize that we have a linked LP/GPU interface and that is my bad, i instituted a full overclocking capability but that cannot be done as it is, this is why it hangs when transitioning from the charging to use or sleep (sleep is so fast that if your phone is not on, it is immediate).

  • Upvote 1

Share this post


Link to post
Share on other sites

No, you don't have to wipe or format anything, if you already have been on the 08-17 version so far. The new kernel is already merged within the new rom. I personally prefer ART, but it's a matter of taste I guess.

 

So, i just install the rom and the kernel (separate zips since the kernel isn't included) ?

Share this post


Link to post
Share on other sites

So, i just install the rom and the kernel (separate zips since the kernel isn't included) ?

The kernel is already included in the rom. So just flash the rom and the gapps, that's it.

Share this post


Link to post
Share on other sites

great rom again, but i was testing tonight to connect the phone to my bluetooth speaker and it didnt work, have only once before gotten this error but don't remember wich rom. it used to work with liquid smooth. anyone else gotten this error? thank you

Share this post


Link to post
Share on other sites

great rom again, but i was testing tonight to connect the phone to my bluetooth speaker and it didnt work, have only once before gotten this error but don't remember wich rom. it used to work with liquid smooth. anyone else gotten this error? thank you

Bluetooth works fine here..please, grab logs if you want to report a bug, no one can help you without them

Share this post


Link to post
Share on other sites

For all off you that have SoD try using on-demand CPU governor it helped me on previous build.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×