Mourta

LiquidSmooth 3.2 featuring Mourta-Kernel 3.4.x (updated 2014-10-15)

Recommended Posts

@Marek: not for me.

Mourta, the problem with the occasional boot into a black screen still persists after a few reboots but I am sure it will settle eventually during development.

And no, I didn't restore anything, but I can't think of any way that could cause problems if it's only app data.

Thank you for your support!

Share this post


Link to post
Share on other sites

Maybe he's not using the app RingtonePlayer? Is this perchance part of the app RingtoneMaker?

I can't fix broken apps for you, you'll have to ask the app maker to do that for you.

No, I don' have installed any apps which would modify mine ringtones. But, maybe is the problem theme engine, and now I have muted phone and phone sleeps. But this is not a permanent fix Edited by LGaljo

Share this post


Link to post
Share on other sites

No, I don' have installed any apps which would modify mine ringtones. But, maybe is the problem theme engine, and now I have muted phone and phone sleeps. But this is not a permanent fix

 

There is no included app called RingtonePlayer so no, this is something you either did not wipe or installed.

Share this post


Link to post
Share on other sites

@Marek: not for me.

Mourta, the problem with the occasional boot into a black screen still persists after a few reboots but I am sure it will settle eventually during development.

And no, I didn't restore anything, but I can't think of any way that could cause problems if it's only app data.

Thank you for your support!

 

Well if you didn't restore anything then app data would not be there at all.

 

The problem is that i cannot troubleshoot it since it doesn't happen for me, i am using the same things you are (i presume), full wipe, install ROM and install GAPPS from the latest mini modular and reboot, then let whatever apps i'm using reinstall automatically.

 

I specifically reworked the reboot interface to prevent this, at the very least your phone should reboot automatically if this happens but it doesn't.

 

I'm going to need you to provide a log of it since i cannot for the world of me reproduce this problem, i have rebooted my phone MANY times to test it and every time it boots up normally.

Share this post


Link to post
Share on other sites

Well if you didn't restore anything then app data would not be there at all.

Since I opened some apps, there will have some data been generated, but I didn't restore any - yet ;).

 

I have sent you a PM with a Dmesg that captures the event.

Share this post


Link to post
Share on other sites

I installed your LS and I can say that is the most smooth rom I ever had. But there are some issues which are disturbing me when using:

 

1. agressive cpu scaling - it uses all four cores on high frequency too often - 3.1 kernel is powering off some cores. (interactive + balanced, default settings)

 

2. gpu is allways on higest frequency - it drains my battery unbeliveable fast, there is no way how to change it

 

3. "dead boots" - after kernel booting only black screen - it's not so bad problem, it's only disturbing - it couses me when I'm powering on device from off state (not reboot)

 

4. some graphical things are sometimes corrupted - I played some videos by freedi YT player and half of screen (with video) was only some lines - it seemed like g. play corruped imgs. This is not allways present - it's very rare to get it..

 

Overall it is the best rom, if you solve that freq problems

 

I was using Mahdi before your rom and I have to say that there are no lags as I had.

post-1048585-0-10599700-1413553921_thumb

Edited by SuperLamic

Share this post


Link to post
Share on other sites

I installed your LS and I can say that is the most smooth rom I ever had. But there are some issues which are disturbing me when using:

1. agressive cpu scaling - it uses all four cores on high frequency too often - 3.1 kernel is powering off some cores. (interactive + balanced, default settings)

2. gpu is allways on higest frequency - it drains my battery unbeliveable fast, there is no way how to change it

3. "dead boots" - after kernel booting only black screen - it's not so bad problem, it's only disturbing - it couses me when I'm powering on device from off state (not reboot)

4. some graphical things are sometimes corrupted - I played some videos by freedi YT player and half of screen (with video) was only some lines - it seemed like g. play corruped imgs. This is not allways present - it's very rare to get it..

Overall it is the best rom, if you solve that freq problems

I was using Mahdi before your rom and I have to say that there are no lags as I had.

I think number 1 en 3 problems will be solved when you flash the separate kernel http://www.mediafire.com/?h9tdfahqlmam2l6

Same link as mourta posted in his 3.4 kernel thread

Dunno what happend but it fixed those problems for me

If. You read some commit from mourta you will see that GPU. Info will be incorrect because of some changes he made about the glitches I have no idea

Share this post


Link to post
Share on other sites

thanks for reply, I installed it, but it seems to me as same build present in LS too (so I don't think that can fix something). I got "dead boot" again and I grabbed last kmsg but I'm not sure if there's anything that can help. Also I got two another bugs: charger is sometimes doesn't recognized properly (same for PC), I got it after reboot. Other one is audio routing: when I'm not using my phone for half day and then I connect headphones (without playing anything) and then I play YT from it's app, music is routed to speaker instead of headphones, so I have to disconnect headphones and connect it again - after that it's ok. This bug is not some random, I got it two times in same cases - I came home and wanted to play something..

 

Anyway that battery problems aren't so bad for me - I use xiaomi power bank. But if I wouldn't have it, it is problem, because phone can drain 40% it's battery with 40 mins of youtube and some web.. (then it's hot like I play dead trigger)

 

Last thing: this rom has some serious problems with deepsleep, my phone warms my leg even I'm doing nothing on it, I don't say that's bad feature in winter but when I'm in school it isn't right thing..

 

EDIT: I'm testing deep sleep now and it seems to be ok but in school, where I need battery, it drains - maybe I'm just unlucky user...

last_kmsg.zip

Edited by SuperLamic

Share this post


Link to post
Share on other sites

thanks for reply, I installed it, but it seems to me as same build present in LS too (so I don't think that can fix something). I got "dead boot" again and I grabbed last kmsg but I'm not sure if there's anything that can help. Also I got two another bugs: charger is sometimes doesn't recognized properly (same for PC), I got it after reboot. Other one is audio routing: when I'm not using my phone for half day and then I connect headphones (without playing anything) and then I play YT from it's app, music is routed to speaker instead of headphones, so I have to disconnect headphones and connect it again - after that it's ok. This bug is not some random, I got it two times in same cases - I came home and wanted to play something..

 

Anyway that battery problems aren't so bad for me - I use xiaomi power bank. But if I wouldn't have it, it is problem, because phone can drain 40% it's battery with 40 mins of youtube and some web.. (then it's hot like I play dead trigger)

 

Last thing: this rom has some serious problems with deepsleep, my phone warms my leg even I'm doing nothing on it, I don't say that's bad feature in winter but when I'm in school it isn't right thing..

 

EDIT: I'm testing deep sleep now and it seems to be ok but in school, where I need battery, it drains - maybe I'm just unlucky user...

make factory and cache reset and flash kernel....

Share this post


Link to post
Share on other sites

i have allmost 2 hours onscreen rom sleep excellent performance its good but no optimal with ashphalt 8 on dalvik ,i switch to runtime to test it

Share this post


Link to post
Share on other sites

camera not working when i make video calls :(

 

Grouper blobs have skype problems.

 

Hangout works, use that.

Share this post


Link to post
Share on other sites

I installed your LS and I can say that is the most smooth rom I ever had. But there are some issues which are disturbing me when using:

 

1. agressive cpu scaling - it uses all four cores on high frequency too often - 3.1 kernel is powering off some cores. (interactive + balanced, default settings)

 

2. gpu is allways on higest frequency - it drains my battery unbeliveable fast, there is no way how to change it

 

3. "dead boots" - after kernel booting only black screen - it's not so bad problem, it's only disturbing - it couses me when I'm powering on device from off state (not reboot)

 

4. some graphical things are sometimes corrupted - I played some videos by freedi YT player and half of screen (with video) was only some lines - it seemed like g. play corruped imgs. This is not allways present - it's very rare to get it..

 

Overall it is the best rom, if you solve that freq problems

 

I was using Mahdi before your rom and I have to say that there are no lags as I had.

 

 

I have no idea why it works but apparently flashing the exact same kernel as is in this rom fixes the problem with cpuquiet scaling, i need to rewrite that init.rc anyway, it's not compliant to the new code.

 

2. No, it's just reported wrong, it's always scaling between 200-520 and no app will tell you what it's currently at as i didn't expose it to sysfs yet, video is in upgrade and the reporting won't be implemented until i'm happy with the way everything else works because it would be stupid to do it, it might hang other processes so it is reported once at the exact frequency it's running at that moment, for most people it will be 495, for others it will be 384.

 

3. I'm going to configure a reboot monitor for the next release to fix this issue, if it's even necessary by the next version. See there is a bootloader handing over video to kernel issue that isn't fixed by nvidias updates, i have to rewrite the whole thing to make it work and that isn't as easy as you might think and there certainly is no use doing it until i have video drivers right where they should be, at a mix between 3.4, 3.8 and 3.10, cherrypicking all we can use thereby making the transition to current latest kernel oh so much easier.

 

The choice was either to just blast the kernel and then backtrack to where the problem lies or to do a massive upgrade and then do small upgrades and bring it to the latest working for a release and then cherrypick to pick it up to date until it is fully compatible and just implement the whole shebang into 3.10.

 

I went with the latter.

 

Right now i've added over 600 commits, about 450 of them are my own rewrites of functions because we CAN use CMU if we really want to, once that goes into testing it confirms whether this was time well spent or wasted... as a hint on what it does, i am running full 3D advanced with a frame rate of over 30 at all times, this used to get between 7-15.

 

It might be worth it, i ask for patience with these implementations, not everything will be perfect at first release.

 

4. this also seems to be fixed by flashing the kernel seperatly, i would love to know why but i'm of the persuation of "if it isn't broken i'm not going to fiddle with it".

Share this post


Link to post
Share on other sites

Thank you for explanation, flashing your kernel again really helped, now freq seems to work ok. I know you said you're still working on gpu things but I have some omx crashing quite often (once per few yt videos) so I grabbed the logs, I hope that can help you.

 

I really appreciate your work, it's the best for our mobile (and newest). I tested lots of roms and most of them are having less bugs than yours (of course old blobs and old kernel..), but I haven't found any rom which can beat yours in lags. Your rom is just lagfree and I really like it. (dat multitasking there is the best)

 

I know I may look as man who really wants to show your rom as the most bugged rom for our mobile, no I just want to point at bugs, so you can see what is not working. (and fix it probably :) )

omxcrash.zip

Edited by SuperLamic

Share this post


Link to post
Share on other sites

After some googling I've found the reason of g. play corrupted imgs: GCC 4.9. I also found some commit that can fix it: https://github.com/JustArchi/android_external_webp/commit/36c6201fbb108d6b757f860e2cd57f3982191662 I don't know if it's usable for us but I hope yeah :) you're the best mourta

 

I'll implement the parts of this that would work in our next build, it does strange things to the general interface when you enable 3d engine for the interface withou our current hardfp drivers so i'll have to rewrite it.

 

The problem is gone in the current version of google play services anyway, just upgrade.

Share this post


Link to post
Share on other sites

Hey , Mourta , is it possible to fix green screen in camera ? If yes when it will be possible ? 

P.S. It's the best rom ^^ nice work

Share this post


Link to post
Share on other sites

I'll implement the parts of this that would work in our next build, it does strange things to the general interface when you enable 3d engine for the interface withou our current hardfp drivers so i'll have to rewrite it.

The problem is gone in the current version of google play services anyway, just upgrade.

I've updated gapps, so google play is now 5.0.32 but imgs are still corrupted. I don't think that they fixed it. What version of g. play got fix for it?

Share this post


Link to post
Share on other sites

Hallo

I have some problems with the new ROM. I tried several installation methods:

Install over your previous rom and tried two times with full wipe of system/data/cache.

 

1. Webpages are not shown correctly. Testet with internal browser, boat browser and habit browser. Best way to test it, is browsing to facebook

 

2. Poweramp crashes directly after start. I tried other musicplayer ( simple mp3, Play Music ) . They work, but stopped after playing some tracks. Its not depending wich track is played

So its not so nice.

 

These are the only problems i have. All other parts work perfektly. Nice work. :D

 

 

post-1045030-0-79562400-1414054718_thumb

poweramp.txt

browser.txt

Share this post


Link to post
Share on other sites
Hello to all Forum. I am new to the rom in my mobile. I found this forum and decided to try the rom. I installed LS-KK-v3.2-2014-09-18-p880.zip, and the kernel-kernel-3.4-10-10.zip mourta. I works great, very smooth. Now I've seen the update 2014/10/15. I can do the upgrade ?. The kernel is the same, or have to change ?.
 
Thanks for accepting me in the forum.
 
Excuse me if this poorly written but I am translating with google, my English is not so fluent.

Share this post


Link to post
Share on other sites

Hello to all Forum. I am new to the rom in my mobile. I found this forum and decided to try the rom. I installed LS-KK-v3.2-2014-09-18-p880.zip, and the kernel-kernel-3.4-10-10.zip mourta. I works great, very smooth. Now I've seen the update 2014/10/15. I can do the upgrade ?. The kernel is the same, or have to change ?.

Thanks for accepting me in the forum.

Excuse me if this poorly written but I am translating with google, my English is not so fluent.

yeah, it works really great .. best rom I ever had. If you install it, install Mourta kernel 3.4 again to your phone or it will scale freq so agressively. ( you can find the zip in kernel thread)

Share this post


Link to post
Share on other sites
Hello, unfortunately I had to return to the LS-KK-rom v3.2-2014-09-18-p880. The GPS has failed me. Twice it has been blocked and I had to remove the battery to restart, one using FB, and another using Whatsapp. It is not, not just convinced me the latest version of the 10-15. 
I hope my opinion helps serve to improve the rom. 
greetings

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.