fonz93

[ROM][5.1.1] F-AOSP [Y300/G510] [16/05/2015]

467 posts in this topic

This rom and without customizations ?? when this will be possible

DON'T ask to port features from CyanogenMod, SlimRoms, ParanoidAndroid, LiquidSmooth, CarbonROM or any other project

0

Share this post


Link to post
Share on other sites

Wow, fonz93 very good job.

I will try this when the black screen issue is fixed, hopefully.

Edited by krux3r
0

Share this post


Link to post
Share on other sites

Wow, fonz93 very good job.

I will try this when the black screen issue is fixed, hopefully.

Btw, I would like to donate to you for your hard work, anyway to do it?

If yes pm me. :)

Use the huge PayPal Donate button in his signature. :)

1

Share this post


Link to post
Share on other sites

Use the huge PayPal Donate button in his signature. :)

Im on Tapatalk so I didnt see it.

My bad.

0

Share this post


Link to post
Share on other sites

My offtop...

 

Fonz, maybe port Ubuntu touch?  :D

0

Share this post


Link to post
Share on other sites

Hi fonz maybe this error occurs on the screen in black In the latest versions of the Linux kernel it has moved the video mode setting in the kernel. So all programming clock speeds specific hardware and records video card occur in the core rather than the X driver when the X server starts . Unfortunately, some cards does not work properly and ended up with a black screen after startup or after a suspencion mode. The solution is to add the nomodeset grub parameter instructs the kernel to not load the video drivers that are loaded X

Hola fonz quiza esto tenga lugar en el error de la pantalla en negro En las ultimas versiones del kernel de Linux se ha movido el ajuste del modo de vídeo en el núcleo. Así que toda la programación de las velocidades de reloj de hardware específicos y registros de la tarjeta de vídeo ocurren en el núcleo en lugar de en el controlador X cuando el servidor X se inicia. Por desgracia, en algunas tarjetas esto no funciona correctamente y terminamos con una pantalla en negro tras el arranque o despues de un modo suspencion. La solución pasa por añadir el parámetro nomodeset en grub, indica al kernel para que no cargue los controladores de vídeo que las X se carguen

0

Share this post


Link to post
Share on other sites

Hi fonz maybe this error occurs on the screen in black In the latest versions of the Linux kernel it has moved the video mode setting in the kernel. So all programming clock speeds specific hardware and records video card occur in the core rather than the X driver when the X server starts . Unfortunately, some cards does not work properly and ended up with a black screen after startup or after a suspencion mode. The solution is to add the nomodeset grub parameter instructs the kernel to not load the video drivers that are loaded X

Hola fonz quiza esto tenga lugar en el error de la pantalla en negro En las ultimas versiones del kernel de Linux se ha movido el ajuste del modo de vídeo en el núcleo. Así que toda la programación de las velocidades de reloj de hardware específicos y registros de la tarjeta de vídeo ocurren en el núcleo en lugar de en el controlador X cuando el servidor X se inicia. Por desgracia, en algunas tarjetas esto no funciona correctamente y terminamos con una pantalla en negro tras el arranque o despues de un modo suspencion. La solución pasa por añadir el parámetro nomodeset en grub, indica al kernel para que no cargue los controladores de vídeo que las X se carguen

 

Latest one we are using is 3.4.107, i got black screens on 3.4.106 too

0

Share this post


Link to post
Share on other sites

Did you already try to install an UPDATE.APP?

 

Also, there's an option to fix partitions in TWRP, i don't really know if it works or not, nor what it does..

I mean, my device is not broken, i just modded the partition table with this tutorial, i have aosp mod running well on it right now, every jb and kk rom installs well, except for your lollipop roms cuz of the new way to flash the /system partition of lolli, i just need the stock partition table of the g510 cuz i forgot to backup the mine, someone just need to write a few commands in the shell to show the partition table, that's what i want lol, but i think nobody understand me.

 

Offtopic: It's funny, i used to develop with Alberto97 a few years ago in xda for some other old huawei devices i got surprised to see his name here :p

0

Share this post


Link to post
Share on other sites

I mean, my device is not broken, i just modded the partition table with this tutorial, i have aosp mod running well on it right now, every jb and kk rom installs well, except for your lollipop roms cuz of the new way to flash the /system partition of lolli, i just need the stock partition table of the g510 cuz i forgot to backup the mine, someone just need to write a few commands in the shell to show the partition table, that's what i want lol, but i think nobody understand me.

 

Offtopic: It's funny, i used to develop with Alberto97 a few years ago in xda for some other old huawei devices i got surprised to see his name here :P

 

 

Isn't this what are you looking for?

 

Anyway, an UPDATE.APP should restore the stock partition table

 

Try with TWRP 2.6.3.3?

 

Edit: g510-100 partition table:  http://pastebin.com/2527WZVv

Hope this helps.

Edited by fonz93
0

Share this post


Link to post
Share on other sites

Isn't this what are you looking for?

 

Anyway, an UPDATE.APP should restore the stock partition table

 

 

Try with TWRP 2.6.3.3?

 

Edit: g510-100 partition table:  http://pastebin.com/2527WZVv

Hope this helps.

Oh thank you wbrambley! i didn't saw it :P

0

Share this post


Link to post
Share on other sites
I'll give it a try in a few days. I had a HARD time with the Google Keyboard in the 19/04 rom of CM12.1; the gestural input was not working anymore, and i CAN'T write without swiping.
Anyways, thank you so much for this work fonz93 !
0

Share this post


Link to post
Share on other sites

Edit: deleted, pointless.

Edited by fonz93
0

Share this post


Link to post
Share on other sites

The status bar transparent thing I turn on / off , I do not really like the all black..

Thanks

0

Share this post


Link to post
Share on other sites

Before that you start to ask:

 

1) Yes, switchable pair it's enabled

2) No, Transparencies on AOSP are disabled for low mem devices even with the highendgfx .prop enabled

3) Yes, i will enable transparencies in the next build, i've just forgot to apply the patch on this one.

Edited by fonz93
3

Share this post


Link to post
Share on other sites

@all

 

Can you try this kernel and report me if black screens are still there? i am testing it right now, but if you do that too, we will know sooner if it works or not, thanks.

 

 

https://drive.google.com/file/d/0B-xonQbKq2U2X2RuMEhTSjJvdEU/view?usp=sharing

 

Actually the ROM works fine for me... And I haven't had the "black screen of the death" (xD) in my experience with ROM...

 

Do I need to flash the test kernel anyway? :O

0

Share this post


Link to post
Share on other sites

Some people do not read the red letter grades, perhaps think they are ornamental.

@fonz93 Could I make a repack of the kernel for CM12.1?

0

Share this post


Link to post
Share on other sites

Will port on g330?

Sorry for my bad english =\

 

I don't really know.. Right now, building an Y300 ROM requires 3 hours, uploading 2 hours, if i build for G330 too it will require again 3 + 2, during the 3 hours of building i can barely do something on the PC as i am on linux and can't use my games, programs, sometimes is laggy too.. while uploading i can't use the connection because it takes all the bandwidth, if it's really worth for you (i mean, i can't waste 5 hours and then you change the ROM after 2 hours, it's fine, i know that Lollipop is not stable yet and you want all working, but my PC while building uses electricity, that is not free)

 

Actually the ROM works fine for me... And I haven't had the "black screen of the death" (xD) in my experience with ROM...

 

Do I need to flash the test kernel anyway? :o

 

The bug is there, i just got it yesterday, flash the kernel only if you want to, i mean, it is only for testing purpose, just to know if the change i made fixed blackscreens or not.

 

Some people do not read the red letter grades, perhaps think they are ornamental.

@fonz93 Could I make a repack of the kernel for CM12.1?

 

Of course

 

OK, THANKS

 

 

YOU'RE WELCOME

Edited by fonz93
7

Share this post


Link to post
Share on other sites

I got two black screen ;(

 

Oh my god, thanks for reporting

Edited by fonz93
0

Share this post


Link to post
Share on other sites

Paste this lane in the build.prop for transparencies. ro.config.low_ram=false

0

Share this post


Link to post
Share on other sites

I am testing new kernel but for now no black screen. I am tested 15.04. build also and had first black screen after 1 weak. I well be back.

Edited by POmniac
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.