Jump to content
KonstaT

[DEV][ROM][20.10.] LineageOS 13 (Android 6.0.1) for Chuwi Vi10 Plus, Hi10 Plus, Hi10 Pro, Hibook, Hibook Pro & Hi12

Recommended Posts

19 hours ago, KonstaT said:

New build.

http://konstakang.com/devices/chuwi_vi10plus/CM13

-fix issue with slow wakeup from deep sleep
-fix long press on capasitive home key (thanks to yener90)
-patch recently disclosed BlueBorne and KRACK vulnerabilities
-Android security patch level: 1 October 2017 (merged)

 

I got real happy when I saw this. You're the man! Thanks A LOT.

 

Share this post


Link to post
Share on other sites
37 minutes ago, Hi12Guy said:

Is it possible to activate Deep Sleep in Chuwi Hi12 Tablet with external App like Deep Sleep Battery Saver?

It's not possible with any app or otherwise.

Chuwi hasn't released Linux kernel source for Hi12. Prebuilt binary kernel extracted from stock Lollipop firmware doesn't work with Marshmallow userspace proprietary binary drivers.

Edited by KonstaT

Share this post


Link to post
Share on other sites
On 20.10.2017 at 5:53 PM, KonstaT said:

New build.

http://konstakang.com/devices/chuwi_vi10plus/CM13

-fix issue with slow wakeup from deep sleep
-fix long press on capasitive home key (thanks to yener90)
-patch recently disclosed BlueBorne and KRACK vulnerabilities
-Android security patch level: 1 October 2017 (merged)

Unfortunately on my HI10 Pro still no difference. It still wakres slowly up from standby :(

Share this post


Link to post
Share on other sites
3 hours ago, yener90 said:

Unfortunately on my HI10 Pro still no difference. It still wakres slowly up from standby :(

Did you install the updated compatibility patch? You always need to use the one that matches the ROM version.

Edited by KonstaT

Share this post


Link to post
Share on other sites
1 hour ago, KonstaT said:

Did you install the updated compatibility patch? You always need to use the one that matches the ROM version.

of course, but I also realized that I have the same issue on CM12.1 

Share this post


Link to post
Share on other sites
3 hours ago, yener90 said:

of course, but I also realized that I have the same issue on CM12.1 

Something else wrong in your end then. IIRC people with exFAT sdcards with large amount of individual files have also reported similar issues.

Share this post


Link to post
Share on other sites
2 hours ago, KonstaT said:

Something else wrong in your end then. IIRC people with exFAT sdcards with large amount of individual files have also reported similar issues.

Hmm, I also have exfat sd card. I will check this out, thanks for your hint :)

 

EDIT: Didn't worked, formatted whole sd card to fat32, still slow wake up from standby

Edited by yener90

Share this post


Link to post
Share on other sites
On 20/10/2017 at 5:53 PM, KonstaT said:

New build.

http://konstakang.com/devices/chuwi_vi10plus/CM13

-fix issue with slow wakeup from deep sleep
-fix long press on capasitive home key (thanks to yener90)
-patch recently disclosed BlueBorne and KRACK vulnerabilities
-Android security patch level: 1 October 2017 (merged)

After installing your latest build I cannot get Titanium or ES File explorer to load. The "install" tab is greyed out. Is there some setting to fix this problem. Tried allow from unknown sources, but didn't help. Wake up is now magic.

Share this post


Link to post
Share on other sites
5 hours ago, mattiesrag said:

After installing your latest build I cannot get Titanium or ES File explorer to load. The "install" tab is greyed out. Is there some setting to fix this problem. Tried allow from unknown sources, but didn't help. Wake up is now magic.

I can reproduce that with some .apk files. If you press multitasking button and return back from multitasking view to package installer, install button is not greyed out anymore. Or you can just install those apps from the Play Store...

Looks like a Lineage OS upstream issue with PackageInstaller and it was already fixed on the 22th (https://review.lineageos.org/#/c/194170/).

Edited by KonstaT

Share this post


Link to post
Share on other sites
1 hour ago, KonstaT said:

I can reproduce that with some .apk files. If you press multitasking button and return back from multitasking view to package installer, install button is not greyed out anymore. Or you can just install those apps from the Play Store...

Looks like a Lineage OS upstream issue with PackageInstaller and it was already fixed on the 22th (https://review.lineageos.org/#/c/194170/).

Thanks for your advice. Worked like a charm. Enjoying your ROM.

Share this post


Link to post
Share on other sites

Good Evening to everyone,

I have made a clean installation of w10, but i clear all partition of the disk, there were a lot.. 

Now windows 10 is much better, but i haven't android, i have deleted its partitions.

Is possible to create a new partition to install KonstaT cm13 or remix os?

Thanks for everything..

Edited by GinosCicci

Share this post


Link to post
Share on other sites
2 hours ago, GinosCicci said:

Good Evening to everyone,

I have made a clean installation of w10, but i clear all partition of the disk, there were a lot.. 

Now windows 10 is much better, but i haven't android, i have deleted its partitions.

Is possible to create a new partition to install KonstaT cm13 or remix os?

Thanks for everything..

No, if you want to keep your current Windows installation. You can start from clean, though. Install the correct stock Android from Chuwi forum (Hi10 Plus?) with Intel Platform Flash Tool (this will create Android partition structure). Then re-install Windows. Then proceed to installing TWRP and which ever custom ROM you like.

Share this post


Link to post
Share on other sites
On 30.10.2017 at 1:37 PM, KonstaT said:

I can reproduce that with some .apk files. If you press multitasking button and return back from multitasking view to package installer, install button is not greyed out anymore. Or you can just install those apps from the Play Store...

Looks like a Lineage OS upstream issue with PackageInstaller and it was already fixed on the 22th (https://review.lineageos.org/#/c/194170/).

I cant uninstall any apps. Tablet restarts. Do you habe the Problem too?

Share this post


Link to post
Share on other sites
39 minutes ago, yener90 said:

I cant uninstall any apps. Tablet restarts. Do you habe the Problem too?

No, can't reproduce such issue. Logcat?

Share this post


Link to post
Share on other sites
9 hours ago, KonstaT said:

No, if you want to keep your current Windows installation. You can start from clean, though. Install the correct stock Android from Chuwi forum (Hi10 Plus?) with Intel Platform Flash Tool (this will create Android partition structure). Then re-install Windows. Then proceed to installing TWRP and which ever custom ROM you like.

My God.. All such work? 

Share this post


Link to post
Share on other sites
9 hours ago, KonstaT said:

No, can't reproduce such issue. Logcat?

Solved it, was a wrong bios setting, which I tried days before to improve slow sleep awake issue.

Without sd card it is fast, but with sd card, its slow. Regardsless fat32 or exfat or even raw, without any format 

Share this post


Link to post
Share on other sites

Good Morning, 

Unfortunately I wasn't able to flash android by Intel Platform Flash Tool.. 

I believe my chuwi isn't recognized.. It don't appear on tool interface.. 

Share this post


Link to post
Share on other sites
3 hours ago, GinosCicci said:

Good Morning, 

Unfortunately I wasn't able to flash android by Intel Platform Flash Tool.. 

I believe my chuwi isn't recognized.. It don't appear on tool interface.. 

Did you install Intel drivers linked in TWRP page? Did you boot your device to DX loader keeping both volume up and down keys pressed?

Edited by KonstaT

Share this post


Link to post
Share on other sites

Hi Konsta , 

I've installed latest edition of the Intel tool that automatically installed drivers. 

Yes I've booted mine h10 plus to DX fastboot...  

Share this post


Link to post
Share on other sites
14 hours ago, GinosCicci said:

Hi Konsta , 

I've installed latest edition of the Intel tool that automatically installed drivers. 

Yes I've booted mine h10 plus to DX fastboot...  

Which still doesn't mean it's not a driver issue.

You can boot to Android bootloader from DX loader with 'fastboot boot loader.efi' where loader.efi is extracted from stock Android firmware package. See if Intel Platform Flash Tool recognizes the device in Android bootloader.

Share this post


Link to post
Share on other sites

No Konsta, device isn't recognized in Intel Platform Flash Tool.. I think you are right when you say it's a driver issue but at this moment i can't resolve the problem.. 

 

Edit :

Great Konsta..

Solved.. 

I've installed drivers of Twrp and flashed successfully. 

Thanks a lot Master 

Edited by GinosCicci

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×