Jump to content
adeii

[DEV][ROM][6.0.1][ALL] Lineage OS 13.0 [06.06.2017.]

Recommended Posts

10 hours ago, zetaperu said:

Does anyone know what is the program in this ROM that disables the button install in certain apk's?
I have several apks that I need to install and these only show the cancel button activated

Must be some bug in frameworks. Try to turn off / turn on screen and INSTALL wil be enabled.

Share this post


Link to post
Share on other sites
On 11/29/2017 at 8:46 AM, degradatoome said:

2017.10.20?

Do anyone has changelog of this new version?

march build - LOS uses android sources 6.0.1_r77

june build - LOS uses android sources 6.0.1_r79

october build  - LOS uses android sources 6.0.1_r81

                      - Snap is retrieved

Edited by adeii

Share this post


Link to post
Share on other sites
On 11/29/2017 at 3:31 AM, zetaperu said:

Someone knows the difference between
lineage-13.0-20171020-ported-u8833
and
lineage-13.0-20171020-odexed-u8833
?

1. initial october build got no working BT nor camera nor root.

2. since june build got working apps - bin, lib, xbin is used as base for porting october build to working rom - so that rom is ported. Some files are older, but rom works.

3. deodexed october build is fully working rom with working BT and Camera, rom is less in size, but installing is loooong and rom lags - but deodexed BT, Camera and services.jar are used for next repack.

4. odexed october build is initial october build repacked with deodexed BT, Camera, services.jar that work, all files are new :)

Edited by adeii

Share this post


Link to post
Share on other sites
On 11/28/2017 at 2:44 PM, lunaticbrain said:

hi, i just got confused about rom files
i have Huawei G510 - 0010 Dual sim card
i test so many rom to support dual sim card and i see there is solution here
but your instruction is not usfull
pls help me 

need to flash all of them ?
and how to backup baseband or modem or radio file before flash the new one?
 

No, not all. Difference between u8951 and u8951d version is additional package that enable 2nd SIM slot, tested and made by madix-33.

Just use basic rom: lineage-13.0-2017****-u8951.zip (yes, you should got only 1st SIM works), and flash ril+radio+audio_u8833_cm13.zip (it is the same as u8951, so u8951 version is not made).

Now test phone call, you should be heard more the one minute. If that is OK, you could try lineage-13.0-2017****-u8951d.zip + ril+radio+audio_u8833_cm13.zip.

ONLY for DUAL-SIM phones:

Do you have these lines in /system/build.prop

ro.dual.sim.phone=true
persist.dsds.enabled=true

?

 

Edited by adeii

Share this post


Link to post
Share on other sites
On 11/24/2017 at 5:32 PM, Carontes said:

I have a problem with the sd card. Rarely my phone detects it and when it does it reboots itslef. It also happens with RR. Is it only my problem or is it a "bug"?

it could be media_r and media_rw permission for sdcard - flash this file below. or could be "bin/vold" and "bin/vdc".

fixed: platform.xml

 

platform-flashable.zip

Edited by adeii

Share this post


Link to post
Share on other sites
6 hours ago, adeii said:

No, not all. Difference between u8951 and u8951d version is additional package that enable 2nd SIM slot, tested and made by madix-33.

Just use basic rom: lineage-13.0-2017****-u8951.zip (yes, you should got only 1st SIM works), and flash ril+radio+audio_u8833_cm13.zip (it is the same as u8951, so u8951 version is not made).

Now test phone call, you should be heard more the one minute. If that is OK, you could try lineage-13.0-2017****-u8951d.zip + ril+radio+audio_u8833_cm13.zip.

 

Is there any bug for basic Rom that you suggest ?

Share this post


Link to post
Share on other sites
7 hours ago, adeii said:

Must be some bug in frameworks. Try to turn off / turn on screen and INSTALL wil be enabled.

Perfect, making the power off and on the button is enabled install ... now appears for certain applications installed the message 'Unfortunately, the application stopped' will there be any solution?

Share this post


Link to post
Share on other sites
7 hours ago, adeii said:

it could be media_r and media_rw permission for sdcard - flash this file below. or could be "bin/vold" and "bin/vdc".

platform-flashable.zip

It's not a platform.xml problem. I was thinking the same, it could be a bin/vold problem.

P.S. You missed a sintax error in the file

	<permission name="android.permission.ACCESS_ALL_EXTERNAL_STORAGE" >
        <group gid="sdcard_r" />
        <group gid="sdcard_rw" />
        <group gid="sdcard_all" />
		<group gid="media_rw" />

you missed the last     </permission>

I hope you could fix this error, because as soon as I tried my SD after that zip it has been detected but my phone reboots immediately

Share this post


Link to post
Share on other sites
13 hours ago, zetaperu said:

Perfect, making the power off and on the button is enabled install ... now appears for certain applications installed the message 'Unfortunately, the application stopped' will there be any solution?

OK. What app do you try to install? From store or downloaded apk? Do you use original or patched/spoofed services.jar?

Share this post


Link to post
Share on other sites
13 hours ago, Carontes said:

It's not a platform.xml problem. I was thinking the same, it could be a bin/vold problem.

P.S. You missed a sintax error in the file

	<permission name="android.permission.ACCESS_ALL_EXTERNAL_STORAGE" >
        <group gid="sdcard_r" />
        <group gid="sdcard_rw" />
        <group gid="sdcard_all" />
		<group gid="media_rw" />

you missed the last     </permission>

I hope you could fix this error, because as soon as I tried my SD after that zip it has been detected but my phone reboots immediately

Thank you for found error! Try one of these vold and platform (fixed).

aicp11-vold.zip

slim6-vold.zip

platform-flashable.zip

Share this post


Link to post
Share on other sites
14 hours ago, lunaticbrain said:

Is there any bug for basic Rom that you suggest ?

if you can not be heard to other caller, problem is in rild and libril... and some other file.  That is only bug in "basic" rom.

Share this post


Link to post
Share on other sites
5 hours ago, adeii said:

OK. What app do you try to install? From store or downloaded apk? Do you use original or patched/spoofed services.jar?

It is a file downloaded from APKPure, where previously it was possible to install without problem in the ROM version of the month of june

Edited by zetaperu

Share this post


Link to post
Share on other sites
On 12/1/2017 at 3:39 PM, zetaperu said:

It is a file downloaded from APKPure, where previously it was possible to install without problem in the ROM version of the month of june

I just installed APKPure 2.4.0 beta and got sudden reboot and bootloop :(

Share this post


Link to post
Share on other sites

AFTERMATH

Do not use october LineageOS anymore, there is nothing new (except security patches) or better then june LineageOS.

Use lineage-13.0-2017060x-UNOFFICIAL-u8xxx. There will be NOT more new builds. Sorry.

If you want to use microG, flash spoofed-LOS13-june-u8833 and NanoMod-microG-14.x. Some permissions, like Storage and Signature spoofing for Google Play Store, have to be manually enabled.

If you want Snap beside Camera2, flash this from mega.nz, I hope it works.

If otherside caller can not hear you, flash just ril+radio+audio_u8833_cm13.

If app updating make you problems: - remove odex part before update, or

                                                                 - uninstall and install new version or

                                                                 - install manually from downloaded apk and integrate it in system with LuckyPatcher/Link2SD/Apps2SD/etc...

Share this post


Link to post
Share on other sites

If there are no new compilations for this ROM, which one would you recommend now for Huawei Y300-0151 with Android 6.0.1?

Share this post


Link to post
Share on other sites
19 hours ago, zetaperu said:

If there are no new compilations for this ROM, which one would you recommend now for Huawei Y300-0151 with Android 6.0.1?

As I can see here https://www.phonegg.com/compare/3146-3147-Huawei-Ascend-Y300-0100-vs-Huawei-Ascend-Y300-0151

Diff. is that Y300-0151 has additional 1900MHz band for UMTS i HSPA. So, your Y300-0151 is single SIM? I guess you can use

lineage-13.0-20170605-UNOFFICIAL-u8833 and also lineage-13.0-20170606-UNOFFICIAL-u8951 (almost the same).

But since this version of Y300 don't use european baseband, maybe you should change line: gsm.version.baseband=2030 of /system/build.prop to something else.

Share this post


Link to post
Share on other sites

That's right, 1 SIM, which baseband would you recommend to change?

Edited by zetaperu

Share this post


Link to post
Share on other sites
17 hours ago, zetaperu said:

That's right, 1 SIM, which baseband would you recommend to change?

Since custom rom do not change /modem and /cust partition, you can try it without changes (leave it at 2030), if sim is not detected, try 1040.

Share this post


Link to post
Share on other sites
6 hours ago, zetaperu said:

Which is more stable:
lineage-13.0-20170605-UNOFFICIAL-u8833 or Broken-v4.9.1-u8833-6.0.1-noRoot-20171110.zip?
Why?

I guess LineageOS. If you try Broken, I suggest you Broken-v4.9.1-u8951-6.0.1-SU-Snap-20171118.zip (works on Y300 + no fuss about Magisk + has Snap app)

Edited by adeii

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×