Jump to content
nutsda

LineageOS 14.1 for Vodafone Smart Ultra 6

Recommended Posts

45 minutes ago, RufusK21 said:

@nutsda

No idea of this is enough. Definitely some camera related errors in here though, I exported this from your suggested app, recording it from the GApps camera app opening and crashing:

https://pastebin.com/rbmKYPjz

 

Thanks, also if you open the menu & select the dmesg option (it doesn't let you export that one) & just have a flick through that to see if it shows up any errors for the camera.

  • Like 1

Share this post


Link to post
Share on other sites

@Karb10

I haven't had an echo problem. My phone did overheat the first time, but a reboot sorted that out.

Maybe reinstall the ROM

Share this post


Link to post
Share on other sites

@ RufusK21How to install magic in safety net i need to install stock rom, I need to reset the download counter?

Edited by Karb10

Share this post


Link to post
Share on other sites
8 hours ago, nutsda said:

New build up lineage-14.1-20180410-UNOFFICIAL-p839v55.zip

Lineage sources updated

MTP now works properly on Linux, untested on windows

Widevine DRM now functioning properly (fixes apps requiring Digital Rights Management to run - like Netflix)

Cheers @nutsda

DRM function definitely working, Netflix running smoothly, many thanks :)

MTP still not working on Windows, I see you incorporated some of the usb build.prop code, which made it work for me last build, but this time it's not doing anything...

Main Camera still not functioning, definitely due to the ROM after testing with stock software. 

Thanks for the fixes so far though

Share this post


Link to post
Share on other sites

 rom magisk can not pass two times srock roma spin I made a clean boot but I can not get past cts.

Share this post


Link to post
Share on other sites

I have laid Lineageos in this way, so I guess it might be coming out?

Method 1: Updater Script Hack to fix Error 7

Note: Use this method only when you’re 100% sure that the ROM you’ve downloaded is for your device. What this does is to bypass assert checks in recovery so that you can install the ROM without any checks.

  1. Open the Lineage OS ROM zip using any archiving software like 7zip, WinRAR, etc… You can also open it on your device.
  2. Now, you need to navigate to this path: META-INF » com » google » android » updater-script.
  3. Open the file updater-script in a text editor. You’ll see a bunch of lines with the command assert and the model name of the device next to it.
    updater script lineage os
  4. If there’s a mismatch with the codename of the device in the script, you’ll get Error 7 while flashing.
  5. So, just either edit the code to match your device’s codename or delete all the lines having the code “assert & getprop”
  6. Save the file.
  7. Try to install the ROM now.

Share this post


Link to post
Share on other sites
On 11/04/2018 at 8:47 AM, nutsda said:

New build up lineage-14.1-20180410-UNOFFICIAL-p839v55.zip

Lineage sources updated

MTP now works properly on Linux, untested on windows

Widevine DRM now functioning properly (fixes apps requiring Digital Rights Management to run - like Netflix)

Mtp working on windows, USB debugging enabled by default is the problem, disable it before plugging.

If still not detected then manually install -mtp USB driver from device manager, Done.

I suspect the DRM issue was causing the file permission bugs from last build.

Both cameras work.

Volume controls while making a call are still broken.

Edited by Odour Fone

Share this post


Link to post
Share on other sites
1 hour ago, Odour Fone said:

Mtp working on windows, USB debugging enabled by default is the problem, disable it before plugging.

If still not detected then manually install -mtp USB driver from device manager, Done.

I suspect the DRM issue was causing the file permission bugs from last build.

Both cameras work.

Volume controls while making a call are still broken.

Hmm, windows detection still being temperamental for me.

I wonder what causes some people's cameras to work and others not...

Share this post


Link to post
Share on other sites
1 hour ago, Odour Fone said:

Mtp working on windows, USB debugging enabled by default is the problem, disable it before plugging.

If still not detected then manually install -mtp USB driver from device manager, Done.

I suspect the DRM issue was causing the file permission bugs from last build.

Both cameras work.

Volume controls while making a call are still broken.

 

39 minutes ago, RufusK21 said:

Hmm, windows detection still being temperamental for me.

I wonder what causes some people's cameras to work and others not...

What version of windows are you running? As I wonder if it is more of a device driver issue rather than Android.

The camera I don't know what's up yet, especially since it's only a few people having issues not everyone

  • Like 1

Share this post


Link to post
Share on other sites

@nutsda @RufusK21

There are at least two versions of this phone. They were distinguishable because the screens had different tints. (There's posts about this in the su6 forum here in a thread about rooting I think) It also seemed some were more locked down through the Boot loader than others.

On the previous build MTP worked on windows 7 8 10, tested.This time I just plugged into 7.

There was a bug on 180118 build where switching between USB tether then back to MTP would fail until restart.

MTP can be set as the default mode in developer options instead of charge which may help inconsistencies.

Edited by Odour Fone

Share this post


Link to post
Share on other sites
17 hours ago, Odour Fone said:

@nutsda @RufusK21

There are at least two versions of this phone. They were distinguishable because the screens had different tints. (There's posts about this in the su6 forum here in a thread about rooting I think) It also seemed some were more locked down through the Boot loader than others.

On the previous build MTP worked on windows 7 8 10, tested.This time I just plugged into 7.

There was a bug on 180118 build where switching between USB tether then back to MTP would fail until restart.

MTP can be set as the default mode in developer options instead of charge which may help inconsistencies.

Share this post


Link to post
Share on other sites

Yeah, I have selected MTP in developer options, and have disabled debugging. Running Windows 10 which could be the issue if 7 is working for you. Yeah very confused about the camera thing. Would there be a way to determine if there's a correlation between the issue and the 'model' the person has? Maybe values in their stock build.prop or something? Is there an official difference between the two versions that someone could discern?

Share this post


Link to post
Share on other sites
1 hour ago, Karb10 said:

  Does VoLTE work?

I am unable to test it, so I don't know if it works or not, hopefully someone on here can let us know.

Share this post


Link to post
Share on other sites
6 hours ago, nutsda said:

 

 

6 hours ago, nutsda said:

I am unable to test it, so I don't know if it works or not, hopefully someone on here can let us know.

@nutsda

I hope...

What is your latest SElinux enforcing update?

Share this post


Link to post
Share on other sites
1 hour ago, Karb10 said:

 

@nutsda

I hope...

What is your latest SElinux enforcing update?

It's just a built-in security feature that until now has been disabled to allow Lineage to work, but now I have fixed the issues allowing it to be enabled & help make the system more secure.

  • Like 2

Share this post


Link to post
Share on other sites
On 19.04.2018 at 10:35 AM, nutsda said:

It's just a built-in security feature that until now has been disabled to allow Lineage to work, but now I have fixed the issues allowing it to be enabled & help make the system more secure.

 LineageOS 15.1 likely to be built into this phone?

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×