xenose

How to fix the homescreen bug on MPx200 with Jmms installed

77 posts in this topic

Which part would you like explained botty? This thread has deviated a little from the original post :-)

Matt

0

Share this post


Link to post
Share on other sites

hi... can someone explain to me what is experienced when people say that their homescreens are 'garbled'... the reason i ask is that i had put my own homescreen on... the message counters displayed correctly on my screen...

howvever, the problem i was getting was that whenever the homscreen was re-painted (i.e. when returning to homescreen from the menu or another program) some of my memory was eaten up... (to be exact 48k each time...) and as you can imagine after using the phone all day it would run out of memory pretty quick... :)

anyway, i tried setting the default skin again but made no difference... did a hard reset and then installed apps one at a time to see which was causing the problem. i think it came back to jmms if i remember correctly... then came across this fix thread and did what the instructions said... seams to be working fine now... no problems with mms or memory disappearing... although i'm not getting a count for mms messages...

does my memory problem sound like something that would be caused by 'garbled' skins??? or could have been down to something else??? and if so any ideas what??? problems gone now but i'm still curious... any info to help me sleep better at night would be much appreciated... :roll:

regards,

hiffy.

PS. keep up the good work people...

0

Share this post


Link to post
Share on other sites

Some homescreens are designed to display the message counts in a certain way- for example, they might have an icon for SMS, email etc. as a part of the background, and then have the message count lined up to fit in with the background.

The problem is that the Orange MMS software has been designed in such a way that the message count is always displayed in the same format- "SMS: (number), MMS: (number), Email: (number)"- meaning that if you've got a homescreen designed to show the messages in a specific way, they simply don't come out the way they were intended, so the screen looks a mess.

I don't know enough to say whether the memory problem would be related to this though, although from your tests it certainly sounds to me like it's down to the jMMS software.

0

Share this post


Link to post
Share on other sites

sorry guys after changing the registry i can't connect to the internet.keep having the following error.

" unable to connect.Verify you have network coverage and try again".

it works before i change the setting......

anyone can share where i went wrong...also i could have screw up another CLSID entry call 2FFD93B3-0FF0-4228-

anyone can share what should be the entry for the above

thanks

0

Share this post


Link to post
Share on other sites
sorry guys after changing the registry i can't connect to the internet.keep having the following error.

" unable to connect.Verify you have network coverage and try again".

it works before i change the setting......

anyone can share where i went wrong...also i could have screw up another CLSID entry call 2FFD93B3-0FF0-4228-

anyone can share what should be the entry for the above

thanks

Looks like you might have done what I did- if you've changed the setting to "Windowstpcutil.dll", then try changing it to just "tpcutil.dll" (without the quotes.)

Also, the registry entry for 2FFD9... etc. on my phone is the same- "tpcutil.dll" (without quotes.)

0

Share this post


Link to post
Share on other sites

thanks, but still having the same problem.....

can't hard reset the phone also.

not sure where it went wrong

0

Share this post


Link to post
Share on other sites

Hi guys,

trying to fix the message count on the homescreen..

first of all the tpcutil.dll file does not appear to be present anywhere on my phone (after doing a hard reset). Also, I'm fairly sure that two of MMSRegister.exe, MMSReceive.exe, MMSNotification.exe used to run on startup before I reset the phone. Do you think it might be something to do with this?

0

Share this post


Link to post
Share on other sites

Hey guys.

Listen, I have an MPX200 with the generic rom and Jmms installed, and I find the registry entry. The only thing is, when I change it, nothing happens on the homescreen, and if I reset the phone, it resets the registry value back to the Jmms default.

Any ideas?

0

Share this post


Link to post
Share on other sites

Hi Kian

I had exactly the same problem as yours. What I did was doing exactly what they mentioned above, but I do not restart my phone after registry fix.

So after you change your registry, dont restart, just change to another homeskin, and it will be updated.

The small problem is that you cant get your phone to be restarted, u'll then have to do the registry fix again :D

Hope it works for u.

Hey guys.

Listen, I have an MPX200 with the generic rom and Jmms installed, and I find the registry entry. The only thing is, when I change it, nothing happens on the <a href=http://smartphone.modaco.com/viewtopic.php?t=714>homescreen</a>, and if I reset the phone, it resets the registry value back to the Jmms default.

Any ideas?

0

Share this post


Link to post
Share on other sites

Hi guys you prob know this already but if you go to www.customcabbage.co.uk/cabbage.php you can fix the jmms problem using there custom web page you can change loads inc operator name etc thats how i did mine cheers Dave

0

Share this post


Link to post
Share on other sites

I can't seem to fix it even changing registry.

If i change registry it works fine if i change the theme without rebooting the phone

after a reboot it goes back using the jmms plugin. dont knwo what else i can do

0

Share this post


Link to post
Share on other sites

Hmm, i've used custom cabbage with mixed results.

I lose the patch when i power the phone off and back on again

Basically when i instal the cab (i've done it numerous times now) it tells me it need to uninstall the previous version 1st. So it does that then installs again.

Once it's installed i have to change homescreens for the counter to change.

Sometimes this is lost on a power off/on cycle yet sometimes i turn it back on and the patch is still applied?! :S What's going on here?

Cheers,

Mike

0

Share this post


Link to post
Share on other sites

Hi guys.I wonder if i am asking at the right topic.but i have a problem with homescreen.Recently,i downloaded a Ferrari Homescreen,and its actually quite cool .when u scroll down(blue button,yr background will be different when in MRU,profile,Schedule,and also Miss Call.

However,i am not able to get 1 background change,that is the message.

Its suppose to show a new background whenever i receive a Sms.

Tried changing the file to tpcutil.dll,and it works except for the message.

any1 have any solutions?

i am using motorola mpx200 for yr info.Thks!

0

Share this post


Link to post
Share on other sites

sup! im new on here and have the spv c500, and need some help, please! im trying to get some thems on to my phone, i can get the CAB files in the right place and then start to open them but when they start to install they stop and i get this message.....

"installation failed. the program or setting

cannot be installed because it does

not have adequate system permissions"

any clue how to sort this out

0

Share this post


Link to post
Share on other sites

This is the fix for Original 2002 right? Cause I've done this to a non orginal 2002 mpx200 and it didn't worked. Also the registry key doesn't have exactly the same name. It's {2F930BF0-6FE9-4a53-9E17-88E9247BAB48}.

Any work around for this?

0

Share this post


Link to post
Share on other sites

Hello, i know this is a very old topic, but i have a question about it.

I changed my registry using PHM Registry editor (cause it's freeware). But after i rboot my phone, the registry is back to normal, and my skins still don't work. Why doesn't the registry stay the way i edited it ?

0

Share this post


Link to post
Share on other sites
This is the fix for Original 2002 right? Cause I've done this to a non orginal 2002 mpx200 and it didn't worked. Also the registry key doesn't have exactly the same name. It's {2F930BF0-6FE9-4a53-9E17-88E9247BAB48}.

Any work around for this?

<{POST_SNAPBACK}>

Hi all, I know it's an olt topic but I experience the same issue Z3RatuL does..

tried with all the tips&tricks posted here, manually editing the Reg. , (with and without "windows" text), installed the Cab provided, but the counter on my homescreen STILL doesn't work....

I do, too, have a different String where the JMMS plugin was... could that do any difference?

...any ideas? thanks in advance and keep up the great work guys!

0

Share this post


Link to post
Share on other sites

Thanks for helping me fix the homescreen bug guys!!

One question:

I couldn't make up from the conversation whether anybody has gotten the mms counter to work after applying the registry hack...

Has anybody, and how do I do this on my phone?

0

Share this post


Link to post
Share on other sites

Hi everybody! I'm newbie here, also at the phone.

I've made this changes, but on my phone with TC(total comm.) 1 didn't find any Windowstpcutil.dll or tpcutil.dll where can i get it, to get my homescreens work?

(sorry for my bad english, 1 don't use it too much in hungary.)

tx. bye. kinsy.

i've found the tpcutil.dll file in the \windows dir but the registry target the \IPSM\windows dir and i can't copy this file.

Edited by kinsy
0

Share this post


Link to post
Share on other sites

Once you make the changes in the registry you should not need to do anything else.

Have you installed the Jmms application on your phone?

What is TC?

0

Share this post


Link to post
Share on other sites
,Sep 22 2005, 09:36]Once you make the changes in the registry you should not need to do anything else.

Have you installed the Jmms application on your phone?

What is TC?

<{POST_SNAPBACK}>

i make the changes in registry.

jmms is installed on the phone.

if i make a reboot, in the registry the value is jump back to jmmsplug.dll.

TC is total commander.

i view my phone with a plugin for ce devices.

tx. kinsy.

Edited by kinsy
0

Share this post


Link to post
Share on other sites
i make the changes in registry.

jmms is installed on the phone.

if i make a reboot, in the registry the value is jump back to jmmsplug.dll.

TC is total commander.

i view my phone with a plugin for ce devices.

tx. kinsy.

<{POST_SNAPBACK}>

Check your windows\startup dir, if there is a pvision.lnk if so remove that file from there, i guess this fixed the same problem for me but i still need to reapply skins every reboot :?:

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.