derpin7

Members
  • Content count

    9
  • Joined

  • Last visited


Community Reputation

1 Neutral

About derpin7

  • Rank
    Newbie

Previous Fields

  • Your Current Device(s) ZTE Open C
  • Your Twitter username derpin7

derpin7's Activity

  1. derpin7 added a post in a topic [DEV][ROM][8.8.] CyanogenMod 11 (Android 4.4.4) for ZTE Open C / Kis 3   

    i wonder if a diff between the following files wouldnt be useful? i know there will be a LOT of changes, but that was the upgrade path i took to repair.  if i was near my regular desktop and not wifi tethering off of my zte open c cm11 i would run it myself.
    Android_4.4_EU_P821E10V1.0.0B06_DL and FFOS_US_EBAY_P821A10V1.0.0B06_LOG_DL
    • 0
  2. derpin7 added a post in a topic [DEV][ROM][8.8.] CyanogenMod 11 (Android 4.4.4) for ZTE Open C / Kis 3   

    oh sweet jesus, i fixed the issue with my modem H / H+ / 3G whatever you want to call it..
     
    just a quick rundown of what i did to BREAK the modem and then what i did to FIX the modem:
     
    HOW I BROKE THE PHONE:
    TLDR: Flashed an EU Android image with the upgrade tool which only contained radio/modem for EU which only allowed me to work on US ATT Edge!! (UGH)
     
    The minute i unboxed my phone i immediately flashed it with the Open C upgrade tool from the 7z file "ZTE_Open_C.7z" that is floating around the forums ( http://www.hotukdeals.com/deals/zte-open-c-2014-unlocked-firefox-os-android-kitkat-for-38-99-sold-zte-uk-1960296?page=5), it contains the following image 
    STAY AWAY FROM THIS U.S. USERS: ZTE_Open_C.7z\Android_4.4_EU_P821E10V1.0.0B06_DL\ Immediately after i flashed this EU image to my US phone is when i could only connect to EDGE within the united states.
    so from that point onwards my RADIO/MODEM was HOSED (for US functions anyway). EDGE ONLY NO 3G!
    Sometime after that i found CM11 / CWM from KonSTAT (the CWM image saved my ASS!!)
     
     
    THE FIX:
    so here is what i did to fix the issue! i found the firefox help page with the link to the "Manual" Updates:
    https://developer.mozilla.org/en-US/Firefox_OS/Developer_phone_guide/ZTE_OPEN_C 
     
    Which directed me to the OPEN C UPGRADE TOOL HOMEPAGE:
    http://en.comebuy.com/developer-firefox-os-open-c.html
     
    which has the "unlocked" FFOS with AMERICAN modem/radio (konstat eluded to this in a previous post).
    http://down.comebuy.com/FFOS_US_EBAY_P821A10V1.0.0B06_LOG_DL.zip
    FFOS_US_EBAY_P821A10V1.0.0B06_LOG_DL after i flashed that, then i flashed CWM back onto the device by holding power + down vol for bootloader and pushing the recovery to flash over FASTBOOT: 
    fastboot flash recovery recovery-cwm6050-kis3.img THEN From Konstats amazing CWM i flashed to 
    EU_FFOS+to+Android.zip which ran the appropriate scripts to convert FFOS to ANDROID --  cwm also gave me the option to avoid a reflash of the recovery / install root!!, after a reboot, SURE ENOUGH H+ 3G WHATEVER was BACK!!!!.
     
    after that i booted back into recovery and flashed:
    cm-11-20140817-UNOFFICIAL-KonstaKANG-kis3.zip sure enough, everything was working on boot!
     
    thanks so much konstat.
     
    hope this helps some of the other unlucky souls ive seen on the internet namely: https://www.straighttalkwirelessforum.com/viewtopic.php?f=6792&t=1265501
    • 1
  3. derpin7 added a post in a topic [DEV][ROM][8.8.] CyanogenMod 11 (Android 4.4.4) for ZTE Open C / Kis 3   

    well the IMEI is there the IMEI SV is set to 00, can you check if your zte open c with cm11 is showing IMEI SV 00?  i dont know how i would find out the SV number ?
    • 0
  4. derpin7 added a post in a topic [DEV][ROM][8.8.] CyanogenMod 11 (Android 4.4.4) for ZTE Open C / Kis 3   

    ok i think i found the issue, imei sv: 00
     
     
    http://www.modaco.com/topic/337340-update-zte-imei-flash-tool-for-imei-all-0-machine/ <-- how do i find my old IMEI SV number ?
     

     
    ^^-see attached post!!! jeez! maybe after i fix this though i can have sweet sweet cm11 / bluetooth / and 3g!!!!!
    • 0
  5. derpin7 added a post in a topic [DEV][ROM][8.8.] CyanogenMod 11 (Android 4.4.4) for ZTE Open C / Kis 3   

    h
     
    I guess in regards to the norway build, i was thinking it must be the newest version because of the "ro.build.display.id=ZTE_KIS_III_V5.0" v5.0 specifcally.   its the only v5.0 on the page i can find.  i guess that might be some internal-numbering-system ?

    when you say B06 firmware, you are referring to "ZTE_Open_C.7z\Android_4.4_EU_P821E10V1.0.0B06_DL" im assuming ? (the ZTE_Open_C.7z) ro.build.display.id=ZTE_KIS_III_V1.0
    ro.build.inner.version=GEN_EU_P821E10V1.0.0B06... right ;)? 

    ok, so how can you explain the RIL proprietaries in just a little more detail, im sorry im knew to messing with the internals this deep.
     
    thank you very much for your help, do you have a bitcoin address so i can tip you ?
     
      ro.build.display.id=ZTE_KIS_III_V5.0
    • 0
  6. derpin7 added a post in a topic [DEV][ROM][8.8.] CyanogenMod 11 (Android 4.4.4) for ZTE Open C / Kis 3   

    any idea where this came from ? \2014081409055370.zip\Norway Kis 3 SD card upgrading instruction & software package(ZTE Norway AS)-256880B0374ZTE_KIS_III_V5.0 ??????
    • 0
  7. derpin7 added a post in a topic [DEV][ROM][8.8.] CyanogenMod 11 (Android 4.4.4) for ZTE Open C / Kis 3   

    ok, im going to try updating to this ZTE Kis 3 Ver 5.0 http://download.ztedevices.com/UpLoadFiles/product/567/4778/soft/2014081409055370.zip at this link.  then flash cyanogenmod and see what the hell happens! because the link build you had me flash, actually flashed a "B01" not a "B10" ( ro.build.display.id=ZTE_KIS_III_V3.0
    ro.build.inner.version=GEN_EU_P821E10V1.0.0B10) ..????
     
    am i correct in assuming that the last 3 digits of the build number in android is the modem ver ?
    • 0
  8. derpin7 added a post in a topic [DEV][ROM][8.8.] CyanogenMod 11 (Android 4.4.4) for ZTE Open C / Kis 3   

    still no dice :(  let me ask you a question when i do a CWM backup and restore does that restore the radio/modem stuff as well ???
    • 0
  9. derpin7 added a post in a topic [DEV][ROM][8.8.] CyanogenMod 11 (Android 4.4.4) for ZTE Open C / Kis 3   

    EDIT: Just FYI im in the USA and i think this might have something to do with 850mhz stuff
     
    Just FYI, thank you for this awesome rom, everything works out of the box except for one little (important!) detail!  on my phone when im running your CM11 build i cannot connect to 3g services, only EDGE...
     
    but when i flash this build (looks like its based on ZTE Kis 3?): 
        https://www.dropbox.com/s/vh6x3qkk4kunma0/ZTE_Open_C.7z   3g works out of the box, but bluetooth wont connect to my car stereo.   when i flash your build (CM11) BLUETOOTH works out of the box but i cant connect over 3g only EDGE    ALSO, i have double checked APN / DATA settings on both and they are identical.     is there anyway to pull the radio out of the 7z file i posted above and slap it into CM11 ?   thank you for your time on this project!   btw this is where i found instructions with the ZTE_OPEN_C.7Z file posted above: http://www.hotukdeals.com/deals/zte-open-c-2014-unlocked-firefox-os-android-kitkat-for-38-99-sold-zte-uk-1960296?page=5            
    • 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.