redhawkuk

Members
  • Content count

    163
  • Joined

  • Last visited


Community Reputation

11 Good

About redhawkuk

  • Rank
    Enthusiast

Previous Fields

  • Your Current Device(s) ZTE Racer debranded Three UK

redhawkuk's Activity

  1. redhawkuk added a post in a topic raceroms.co.uk   

    The website isn't down it doesn't exist any more I believe the site owner decided to quit.
    A warning would had been nice so I could archive some of the useful ROMs.
     
    I don't suppose anyone has already bagged the whole lot on their hard drive??
     
     
    Richard S.
    • 0
  2. redhawkuk added a topic in General LG Discussion   

    LG Optimus L70 answering calls problematic??
    Sorry if this isn't the correct forum but I can't find one dedicated to the L70 and I need urgent info.
     
    A friend of mine overseas has purchased an LG Optimus L70 on Cricket (AIO) and for the most part it has been okay, however answering calls doesn't always work and as a consequence they go to voice mail.
    From what I've been told if calls are answered indoors then swiping the screen works but while answering outdoors he has limited success.
    He had previously owned the ZTE Prelude which worked correctly in both situations so I very much doubt he's doing something wrong on his part.
     
    As far I can tell the L70 runs Android Kitkat, it has a capacitive touch screen with toughened gorilla glass which seems pretty standard by many handset manufactures.
    Perhaps this is an LG firmware / software issue but after doing some searching online I cannot find anyone else suffering from the same problems with regards to the L70.
     
    Has anyone heard of this problem or know what could be causing it??
     
    Is there way to prevent calls going to voice mail or to change no answer ring count threshold??
     
    And finally can anyone recommend a free Google Play app to change the way calls can be answered on Kitkat instead of the default swipe method??
     
    Richard S.
    • 0 replies
    • 1908 views
  3. redhawkuk added a post in a topic Help Wifi Problem   

    What version of Android are you running??
     
    If you have installed any apps recently before it started crashing then try remove them.
     
    Richard S.
    • 0
  4. redhawkuk added a post in a topic My ZTE Racer doesn't release the headphones   

    You have a faulty headphone socket the phone thinks you're using a headset which it why the microphone doesn't work.
    Try inserting and removing a 3.5mm stereo jack into the headphones socket and see if you can get the switch to deactivate itself.
    If that doesn't work then try electrolube contact cleaning fluid and that too fails then you may have a dry solder joint on the board.
     
    Richard S.
    • 0
  5. redhawkuk added a post in a topic I revived my brick... but there are some problems.   

    The boot animation in Android 2.2.2 should be easy to change although I have never personally done this myself.
    The file is stored in /system/media/bootanimation.zip you need to either delete it or replace with something better.
    Normally the system partition is read-only so a 3rd party tool like Root Explorer would be required to enable read/write access.


    Richard S.
    • 0
  6. redhawkuk added a post in a topic I revived my brick... but there are some problems.   

    Which version of Android are you running??

    Richard S.
    • 0
  7. redhawkuk added a post in a topic OpenVPN on Android 2.1+??   

    Actually it's a little more complicated than not supporting OpenVPN it would appear ZTE haven't bothered to compile iptables 'filter' support into the Kernel.
    This is used by many 3rd party apps (i.e. proxy, firewalls etc) for re-routing network traffic to a middle man and then routing it back.
    If you're using the stock ROM for Android 2.1 then your apps must support proxy networking internally otherwise network traffic continues it's normal way.
    So far SandroB seems to be the only browser capable of proxy connections but HTTP only and not Socks so communications between phone and servers are not encrypted.

    The only way to get iptables working properly is by flashing a Cyanogenmod based ROM I'm not even sure if it's possible to re-compile Android 2.1 with ipchains anyway and I doubt there would be much call for it either.
    Ironically CM actually has OpenVPN support built in but for the love of God I cannot figure out how to import my certificates.

    I did find a much better solution one that only requires a Linux box capable of ssh login something like a shell account or a Raspberry Pi running Raspbian would do.
    On my CM phone I am using a program called SSH Tunnel - https://play.google....d=org.sshtunnel you fill in the login details for your Linux box and once the app is enabled you have instant (TCP only) encrypted networking. :)

    Richard S.
    • 0
  8. redhawkuk added a topic in ZTE Racer - ROMs & ROM customisation   

    Problems with iptables 'filter' and config.gz ??
    I have 2 Android phones, one has Cyangenmod Gingerbread the other the rooted Three UK Stock 2.1 ROM.
    I've been trying to install DroidWall on my Android 2.1 phone but every time I try to enable it I get an error message:

    iptables v1.4.10: can't initialize iptables table `filter': Table does not exist (do you need to insmod?)
    Perhaps iptables or your kernel needs to be upgraded.

    I've compared my 2 phones both have the same module loaded ar6000 (atheros wifi firmware??) so that can't be the reason for iptables failing.
    After some searching on several Linux forums I found references to /boot/config.gz but the only config file I could in my phone was /proc/config.gz

    By using "zcat /proc/config.gz | grep NETFILTER" on both phones there appears to be many differences:

    Android 2.1
    # CONFIG_NETFILTER is not set

    Android 2.3
    CONFIG_NETFILTER=y
    # CONFIG_NETFILTER_DEBUG is not set
    CONFIG_NETFILTER_ADVANCED=y
    CONFIG_NETFILTER_NETLINK=y
    CONFIG_NETFILTER_NETLINK_QUEUE=y
    CONFIG_NETFILTER_NETLINK_LOG=y
    # CONFIG_NETFILTER_TPROXY is not set
    CONFIG_NETFILTER_XTABLES=y
    CONFIG_NETFILTER_XT_TARGET_CLASSIFY=y
    CONFIG_NETFILTER_XT_TARGET_CONNMARK=y
    # CONFIG_NETFILTER_XT_TARGET_DSCP is not set
    # CONFIG_NETFILTER_XT_TARGET_HL is not set
    CONFIG_NETFILTER_XT_TARGET_MARK=y
    CONFIG_NETFILTER_XT_TARGET_NFLOG=y
    CONFIG_NETFILTER_XT_TARGET_NFQUEUE=y
    # CONFIG_NETFILTER_XT_TARGET_RATEEST is not set
    CONFIG_NETFILTER_XT_TARGET_TCPMSS=y
    # CONFIG_NETFILTER_XT_TARGET_TCPOPTSTRIP is not set
    # CONFIG_NETFILTER_XT_MATCH_CLUSTER is not set
    CONFIG_NETFILTER_XT_MATCH_COMMENT=y
    # CONFIG_NETFILTER_XT_MATCH_CONNBYTES is not set
    CONFIG_NETFILTER_XT_MATCH_CONNLIMIT=y
    CONFIG_NETFILTER_XT_MATCH_CONNMARK=y
    CONFIG_NETFILTER_XT_MATCH_CONNTRACK=y
    # CONFIG_NETFILTER_XT_MATCH_DCCP is not set
    # CONFIG_NETFILTER_XT_MATCH_DSCP is not set
    # CONFIG_NETFILTER_XT_MATCH_ESP is not set
    CONFIG_NETFILTER_XT_MATCH_HASHLIMIT=y
    CONFIG_NETFILTER_XT_MATCH_HELPER=y
    CONFIG_NETFILTER_XT_MATCH_HL=y
    CONFIG_NETFILTER_XT_MATCH_IPRANGE=y
    CONFIG_NETFILTER_XT_MATCH_LENGTH=y
    CONFIG_NETFILTER_XT_MATCH_LIMIT=y
    CONFIG_NETFILTER_XT_MATCH_MAC=y
    CONFIG_NETFILTER_XT_MATCH_MARK=y
    CONFIG_NETFILTER_XT_MATCH_MULTIPORT=y
    CONFIG_NETFILTER_XT_MATCH_OWNER=y
    CONFIG_NETFILTER_XT_MATCH_POLICY=y
    CONFIG_NETFILTER_XT_MATCH_PKTTYPE=y
    CONFIG_NETFILTER_XT_MATCH_QUOTA=y
    # CONFIG_NETFILTER_XT_MATCH_RATEEST is not set
    # CONFIG_NETFILTER_XT_MATCH_REALM is not set
    # CONFIG_NETFILTER_XT_MATCH_RECENT is not set
    # CONFIG_NETFILTER_XT_MATCH_SCTP is not set
    CONFIG_NETFILTER_XT_MATCH_STATE=y
    CONFIG_NETFILTER_XT_MATCH_STATISTIC=y
    CONFIG_NETFILTER_XT_MATCH_STRING=y
    # CONFIG_NETFILTER_XT_MATCH_TCPMSS is not set
    CONFIG_NETFILTER_XT_MATCH_TIME=y
    CONFIG_NETFILTER_XT_MATCH_U32=y
    # CONFIG_NETFILTER_XT_MATCH_OSF is not set

    Is this the reason why iptables isn't working properly on Android 2.1??

    From what I understand /proc isn't a proper folder stuff gets populated and copied over when the phone boots so how does one tweak the contents of config.gz??

    Richard S.
    • 0 replies
    • 1066 views
  9. redhawkuk added a topic in ZTE Racer - Racer.MoDaCo.com   

    OpenVPN on Android 2.1+??
    I was wondering has anyone had experience with OpenVPN on Android??

    So far I have managed to configure my Linux box to run as a server and my Android phone as a client using the following guidance - http://vpnblog.info/android-openvpn-strongvpn.html although there was some issues I had to fix myself.
    t connects fine, I have an IP address which I can PING and ifconfig clearly shows I have working tun0 interface with an IP address of 10.8.0.5.
    My problem is that none of my applications will connect via VPN they're still using the wifi network, obviously I cannot disable wifi otherwise my VPN won't work.

    Am I missing something here?? how can I make the VPN my default network for connecting applications??

    I had a quick look on Google Play for some possible solutions but alas I am still stumped with this problem.

    Richard S.
    • 2 replies
    • 1027 views
  10. redhawkuk added a post in a topic [DEV][ROM] RacerMod 1.7 [19/04/2013] CyanogenMod 7.2 port with 2.6.35.7 kernel & CWM Recovery 5.0.2.8   

    Does the digital compass work for Racer gen1?? this has always been a sticking point for me not to move away to CM7 based ROMs.

    Richard S.
    • 0
  11. redhawkuk added a post in a topic I can't boot my RacerII   

    You should still have fastboot capability even if your phone appears to be bricked.
    I'm not familiar with the Racer II but I'm sure there are some instructions on how to install CWM via fastboot.


    Richard S.
    • 0
  12. redhawkuk added a post in a topic Adobe Flash Player 11.1.115.20 for ZTE Racer   

    error 404

    Richard S.
    • 0
  13. redhawkuk added a post in a topic Tethering in infrastructure mode   

    What ROM are you using on your Racer??

    If it's Cyangenmod based then try - https://play.google.com/store/apps/details?id=com.googlecode.android.wifi.tether (with Blade profile to enable WPA2 encryption).

    Richard S.
    • 0
  14. redhawkuk added a post in a topic Back key stoped working   

    Actually no it doesn't, according to Google when a key is used to wake the handset this key if defined as WAKE will be registered however if defined as "WAKE_DROPPED" the key is ignored but wakes up anyway.
    That's really useful to know but at the same time pointless since Android phones as far as I'm aware can only wake up with the power button.

    Does any know whether it is possible to wake the phone from sleep via CALL / END_CALL or is this a limitation within the Kernel??

    Richard S.
    • 0
  15. redhawkuk added a post in a topic Back key stoped working   

    Just out of curiosity does "WAKE_DROPPED" assigned to a key refer to the fact that pressing it won't wake up the phone from sleep but "WAKE" will??

    I'm wondering if it was possible to wake up the phone from sleep via the Call / Call Cancel button instead of pressing the power button.

    Richard S.
    • 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.