Jump to content


Photo

8380 screen disappears

- - - - -

  • Please log in to reply
3 replies to this topic

#1
sagan

sagan

    Newbie

  • Members
  • Pip
  • 14 posts
Is my 8380's screen dead. I flip it open and it displays my screen as usual.. within seconds however it gets all messed up. The colors change, there's ghosting, and then a black streak appears and takes over the entire screen.

Flipping to the phone open hard stops this sometimes.

I opened the entire phone up but I'm not sure what connector i need to reattach to make sure it's ok. it seems like the video cable isn't on right.

Any tips or ideas?
patrick

  • 0

#2
nassersyed2

nassersyed2

    Newbie

  • Members
  • Pip
  • 49 posts
  • Gender:Male
  • Location:Sugar Land, TX USA
  • Devices:Samsung i600

Is my 8380's screen dead.  I flip it open and it displays my screen as usual.. within seconds however it gets all messed up.  The colors change, there's ghosting, and then a black streak appears and takes over the entire screen.

Flipping to the phone open hard stops this sometimes.

I opened the entire phone up but I'm not sure what connector i need to reattach to make sure it's ok.  it seems like the video cable isn't on right.

Any tips or ideas?
patrick

<{POST_SNAPBACK}>



whoa, sounds serious, contact vendor or where you got it from

or just contact mio and ask their support team

  • 0

#3
sagan

sagan

    Newbie

  • Members
  • Pip
  • 14 posts

whoa, sounds serious, contact vendor or where you got it from

or just contact mio and ask their support team

<{POST_SNAPBACK}>



i bought it in HK, so i don't think i'll be getting service... what is mio's service email?

  • 0

#4
sagan

sagan

    Newbie

  • Members
  • Pip
  • 14 posts
i found the root cause i think. the ribbon cable connection from the cpu board to the screen board.

I flipped around the ribbon cable so that the screen connector went to the cpu board and the cpu board connector to the screen board.

That made the screen work but now the phone is stuck on the blue mio startup screen.

any ideas????

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users