Jump to content


Photo

Solution to adding t9 languages to SPV C500

- - - - -

  • Please log in to reply
71 replies to this topic

#61
BramvanSchagen

BramvanSchagen

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:QTEK 9100
Hi,

I am new here and have already a question :

on my QTEK 9100 with WM5 English I want to install a Dutch T9.
Downloaded an registry editor and the t9languages.zip.
But... my registray HKLM\T9 Input Method\etc does not exist.
And I do not have a T9 selection menu.
Am I missing something ?

Thanks, Bram

  • 0

#62
Rothariger

Rothariger

    Enthusiast

  • Members
  • PipPipPip
  • 198 posts
  • Gender:Male
  • Location:Buenos Aires, Argentina
  • Devices:HTC One
  • Twitter:@Rothariger
Hello i have the same problem as FJatle, its configured fine, but when i write it makes a sound and does anything...

any solution?

  • 0

#63
Wosonj

Wosonj

    Newbie

  • Members
  • Pip
  • 2 posts
Anyone succeeded with WM6 OS phone? I tried it with Czech and Norwegian with my HP IPAQ 514 and had no luck. 

The verison of the dll files found here seem to be the same as the built-in English dll, I managed to be able to choose the new languages, n
vertheless i only heard beeping when trying to type.
Moreover, sometimes I was not able to type properly with English T9 (inability to enter space or letters being pressed twice randomly) and sometimes even with classic method (space did not work). Everythin
 turned fine again when i reverted the registry changes.

Some hints in case somebody wants to continue from where I finished:
 - Copy the files directly to Windows directory (Go to Menu -> Options and uncheck Hide hidden files to see hidden and system file
)
 - Set Read-only, Hidden and System attribs to new DDLs (see what other DLLs have). If this is not set, some applications won't start (messaging) and T9 About page will display confirmation that you want to run insecure file.
 - There is a file T9ImeRes.Dll.0409.mui - I tried to play with it for a while (e.g. copy it with new language ID) and this seems to have no effect. I looked inside and it seems to be some HP specific file according to the messages.
 - I could not find any other useful registry keys (when searched for "T9" and "0409")
 - T9Ime.dll seems to have no impact, as it is assigned to probably all languages in registry.
 - Always restart the phone when changing the registry, the changes seem to be visible (e.g. language is offered), but strange things happen
 - By setting the correct attributes, I managed the new DLLs to be offered in T9 About DLL listing. Unfor
unately this did not help, but it is probably a good success indicat
r (Settings 9-9-1-3 to check)

I tried also "T9 Config Utility 1.0", which does not seem to work either.

  • 0

#64
Anonymaus

Anonymaus

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:HP iPaq 514

Anyone succeeded with WM6 OS phone? I tried it with Czech and Norwegian with my HP IPAQ 514 and had no luck.


Hi there!

I'm trying the same thing for my 514 too. With italian language file. I didn't even get as far as having the .dll being loaded (only german, english, french appear in the about). I'm starting to belive that the T9 software has some kind of security measure to make it impossible to load "unofficial" T9 language files. Rather by checking if a DLL comes from the ROM or if it has the right certificate.

However, seeing that you were able to make the app load the dll lets me reconsider. I think, I'll keep trying, although I'm running out of ideas.

Cheers!

PS: Yes, I've set the .dll and the .mui attributes to +s +h +r -a, just like the other files are.
PPS: Did anyone succeede in copying existing t9xxx.dll-files from a WM6 device (preferably smartphone)? I'd really like to compare it to the files that float around the net.

BTW: Some poor guy had the idea to ask HP for help on that:
http://forums1.itrc....hreadId=1150643

Edited by Anonymaus, 07 August 2007 - 07:38 PM.

  • 0

#65
Etienne MONS

Etienne MONS

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:IPAQ 514
Hello Anonymaus,

I am also trying a new Ipaq 514 with only one language file.
I only get the English dll.
I saw from your post that you have the language Dll's for German and French as well.

Do you think that you could send to me the French file (code 040C )

Thank you many times !

Etienne MONS ([email protected])

  • 0

#66
grisly

grisly

    Newbie

  • Members
  • Pip
  • 1 posts
Hello

I'm french

Could you put in a image of the registre HLM for the T9 language.
Anything language

I 'm sure , i'm a "nut" ;)

Thanck you :wub:

Edited by grisly, 09 September 2007 - 07:56 PM.

  • 0

#67
Sanddaa

Sanddaa

    Newbie

  • Members
  • Pip
  • 1 posts
Hi to all forum members. I recently got a smartphone, wich doesn't have croatian T9 input. Colud you post that language here, please. If anyone colud find it?

  • 0

#68
StartPoint

StartPoint

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:SPV C600

Just in case anyone is reading here regarding Windows Mobile 5

I managed to get Spanish t9 working on the C600 using the C500 spanish t9 file as posted above and the following entries:


HKLM\MUI\Available (Added string 040a with value "Spanish")

HKLM\T9 Input Method\MUI\Languages (Added ",040a" to end of value data list)

HKLM\T9 Input Method\LDBs (Added string 040a with value "\Storage Card\t9\T9SpanishLdb.dll)


I made the folder "t9" on my storage card and put the spanish t9 file there, as you can see the language code for that spanish is 040a (traditional sort)

hope this helps anyone looking



I'm not sure if anyone will be reading this as it's been a long time since it was posted - but this worked perfectly after a few frustrating mistakes of forgetting ".dll" etc.

I'm now a fully integrated Spaniard with a UK SPV C600,

Thank you!

  • 0

#69
awarner

awarner

    Staff Team Leader

  • Admin Team
  • PipPipPipPipPipPip
  • 18,499 posts
  • Gender:Male
  • Location:Southampton
  • Interests:Life the universe and everything in it :)

    Lumia 925 one hell of a camera phone
  • Devices:Lumia 925 a real phone at last
  • Twitter:@ashwarner
Good to hear you got it working :)

  • 0
Twitter me @ashwarner

Windows Phone 7 Expert.
Windows Phone Business Specialist



#70
GDi

GDi

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:ipaq 514

...
BTW: Some poor guy had the idea to ask HP for help on that:
http://forums1.itrc....hreadId=1150643


Hello. I am the poor guy that asked HP for help :D

does anybody know here how to install additional T9 languages on my IPAQ 514? I am still interested in getting an answer as all I got at the other forum did not work :)

thanks!

  • 0

#71
alcalina

alcalina

    Newbie

  • Members
  • Pip
  • 48 posts
i´m having trouble to install T9 Portuguese in smt5600(c500) with windows mobile 6.1
the name appear, but when I choose, I only beep error

  • 0

#72
TdW

TdW

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:null
I used a cab file to instal t9 (dutch) for my Imate SPL wm6.1
Way easier! I also couldn't find HKLM\T9 Input Method\ like the other dutch guy mentioned. link for cab files:

http://melgurth.ovh....?page=downloads

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users