Jump to content


Photo

C500/SMT5600 Disassembly & Dust Fix Instructions

- - - - -

  • Please log in to reply
46 replies to this topic

#41
specialized

specialized

    Newbie

  • Members
  • Pip
  • 46 posts
  • Gender:Not Telling

I forget something....................I can turn it on when i take the 4 screws out from the phone.... and when i put them again in the phone it turn off again ....why the screws turn it off ....do you think that there is a part is not in the correct place????? please help me


It sounds like the phone internal components are not positioned correctly with the case. Try making sure everything is aligned properly.

  • 0

#42
specialized

specialized

    Newbie

  • Members
  • Pip
  • 46 posts
  • Gender:Not Telling

Hi, I know it's been a while since you posted on this, but I've got same dust problems.
would you be able to email me some tips and larger image of back cover - I am worried about damaging my (unwarranteed) 5600,

Thank you very much,
CK
[email protected]


The tip has already been posted in the thread:

You can try using a flash light to look through the hole to pinpoint the tabs. Its forward towards the power button.


Please find the larger image of the back cover here: http://www.digimissi...s/detailed2.jpg

  • 0

#43
specialized

specialized

    Newbie

  • Members
  • Pip
  • 46 posts
  • Gender:Not Telling

I too have the same problem of the white screen, just like yours mine just went white one day. I have tried opening up my phone, but i dont know what the connecter is supposed to look like, if anyone could explain it in a little more detail that would be great.

THANKS


This has been discussed in a previous post in this thread:

It sounds like you have a loose LCD ribbon. Behind the LCD screen there is a connector for the ribbon. Flip up the dark grey tab on the connector to loosen the ribbon. Push the ribbon back in, close the tab to secure the ribbon.

If you choose to open your phone please do so carefully.


Please find an image of the connector here: http://www.digimissi...s/detailed1.jpg

  • 0

#44
jipushiitmge

jipushiitmge

    Newbie

  • Members
  • Pip
  • 4 posts
  • Devices:Audiovox 5600
Thanks a lot. I just did it - good instruction!

Hopefully everything will be fine, time will tell.

  • 0

#45
glinja

glinja

    Newbie

  • Members
  • Pip
  • 38 posts
  • Devices:c550
well ive done it, thankyou, luckily im based in a car plant, and they use 3m tape, so coming by some was easy!!.
Took me about half an hour, but most of that was trying to fix the volume button on the earpiece, which i still cant do, as the contact has snapped....
all i need now is the registry values to alter the volume, and its all good :)

  • 0

#46
mndgz

mndgz

    Newbie

  • Members
  • Pip
  • 26 posts
  • Gender:Male
  • Location:co. Gaillimh
  • Interests:HTC Sensation, HTC Sensation XL, HTC EVO 3D, Motorola Xoom
  • Devices:HTC One X HTC Vivid HTC EVO 3D
  • Twitter:@mndgz
tried them instructions on my SPV C500 just after few hours after getting it..it wasnt new hence had a good bit of dust in it..so i thought, what the hey, lets try that.
Reassembled the phone, all connections intact, and guess what... WHITE SCREEN (keypad lights up too) :D
so i was wondering, has anyone come across any solution to that yet? Please let me know, your help will be appreciated.

Edited by mndgz, 06 September 2006 - 04:57 AM.

  • 0

#47
candyman11

candyman11

    Newbie

  • Members
  • Pip
  • 6 posts
  • Devices:audiovox smt 5600
Just wanted to say thank you for the dust fix repair tip! Great forum too :-D

Although I have a problem now that i tried to disassemble the phone again.. (it was harder the second time since I used double-sided tape)

After putting it back together, the LCD backlight does not function anymore :-( I do not know if I broke something on the PCB or if it's the loose LCD ribbon (which causes the white LCD display as I have followed above)

Can anybody help me with this problem ? I would really appreciate it!

And for tips taking the phone apart, Be VERY careful! :-P

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users