Jump to content


Photo

Gameboy emulator for SPV - ALPHA code

- - - - -

  • This topic is locked This topic is locked
236 replies to this topic

#221
awarner

awarner

    Staff Team Leader

  • Admin Team
  • PipPipPipPipPipPip
  • 18,476 posts
  • Gender:Male
  • Location:Southampton
  • Interests:Life the universe and everything in it :)

    Lumia 925 one hell of a camera phone
  • Devices:Lumia 925 a real phone at last
  • Twitter:@ashwarner
Spacemonkey
Sorry to be a pain but still no joy withthe new versions ;)
The latest I can get to work is the first multi-rom version.
PS I also have the DK update now, could this be a reason?

  • 0
Twitter me @ashwarner

Windows Phone 7 Expert.
Windows Phone Business Specialist



#222
emsoftsys

emsoftsys

    Newbie

  • Members
  • Pip
  • 35 posts
  • Location:Manchester
Unlocked phone, loaded software and rom file to strorage card, created a shortcut but when trying to run I just get a screen with the title bar 'GnuBoy 0.91a' and underneath this I get the name of the file 'romfile.gbc'. I have tried this with several roms but get the same result every time. :cry:

Can anybody offer any help please, my sons mithering me to get this sorted (it's not for me - honest)

Thanks

Adrian

  • 0

#223
spacemonkey

spacemonkey

    just some guy, you know...

  • MoDaCo Gold
  • PipPipPipPipPipPip
  • 1,628 posts
  • Location:London, New Zealand
  • Interests:Technology, Toys
  • Devices:HTC Diamond
awarner: what symptom do you get? Title bar with no roms listed? I got this once on DK patch and got similar with the taskmanager app... Non my DK patch has settled down and everything is happy. Make sure you change your location and language in the Regional Settings area... once you get away from any DK settings it gets happier.

emsoftsys. You've just put one rom in there calle romfile.gbc I presume. The new version takes multiple roms. When the list comes up it's listing the single one you have. If you press down on the joystick it should highlight that file. If you had more than one gb or gbc file it'd go up and down through the list. Press the center button of the joystick to select and load the rom.

  • 0
Like a monkey ready to be shot off into space. Spacemonkey. Ready to sacrifice himself for the greater good.

owned: SPV, E200, C500, C600, Wizard, Hermes

smartphone software by me : http://www.surrealservices.co.uk

#224
emsoftsys

emsoftsys

    Newbie

  • Members
  • Pip
  • 35 posts
  • Location:Manchester
Spacemonkey, thanks for that, tried it but the program crashes and goes back to the 'programs' screen?

Scratch that, got it working with another rom ;)

I'm up and running now whey hey!!!!!!!!!!

Kudos spacemonkey

  • 0

#225
awarner

awarner

    Staff Team Leader

  • Admin Team
  • PipPipPipPipPipPip
  • 18,476 posts
  • Gender:Male
  • Location:Southampton
  • Interests:Life the universe and everything in it :)

    Lumia 925 one hell of a camera phone
  • Devices:Lumia 925 a real phone at last
  • Twitter:@ashwarner

awarner: what symptom do you get?  Title bar with no roms listed? I got this once on DK patch and got similar with the taskmanager app...  Non my DK patch has settled down and everything is happy.  Make sure you change your location and language in the Regional Settings area... once you get away from any DK settings it gets happier.


Title bar with no roms listed and my regional settings are
Language US and locale English (UK)
on another note task manager just hangs when I try and load it
(no title screen at all)
Have to hold down the hangup button so the phone locks to get out of it.

  • 0
Twitter me @ashwarner

Windows Phone 7 Expert.
Windows Phone Business Specialist



#226
spacecowboy6982

spacecowboy6982

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,358 posts
  • Location:Edinburgh, UK
  • Interests:.::Everything and Anything::.
  • Devices:SPV C600
Hell yeah - Gnoboy is back 2 its best - From 1 Space Cadete to another Monkey - it kicks ass !!!

SpAcE cOwBoY

  • 0
.::Orange.Branded.Shoes::.
-------------------------------------------------------
.::C600:SanDisk:MiniSD-1Gb:De-Cert::.
-------------------------------------------------------
.::Glad:To:Be:Back:@:MoDaCo::.
-------------------------------------------------------

#227
yzbob

yzbob

    Regular

  • Members
  • PipPip
  • 100 posts
wondered if u have any thoughts on this strange problem?

i can use the emulator no problem and runs as it should.(thanks for the excellent piece of software) but after x times using it, it stops working and when i try to load it, it kicks me back to the home screen.

then it gets weird: after this i can no longer run any uncertified apps such as notbad or task manager.

however if i switch off, switch on. i can use my unsigned apps again no problem. but the gameboy emulator no longer works. same symptoms as above.

if i then delete the emulator from the phone and put a new copy of it on the phone everything is sweet for x amount of reboots or plays on any games until the random problem happens again??

any possible ideas ?

not really that bothered about finding a solution, just thought i'd throw it in here for discussion.

  • 0

#228
akarno

akarno

    Enthusiast

  • Members
  • PipPipPip
  • 245 posts
  • Location:London

wondered if u have any thoughts on this strange problem?

i can use the emulator no problem and runs as it should.(thanks for the excellent piece of software)  but after x times using it, it stops working and when i try to load it, it kicks me back to the home screen.

then it gets weird: after this i can no longer run any uncertified apps such as notbad or task manager. 

however if i switch off, switch on. i can use my unsigned apps again no problem. but the gameboy emulator no longer works. same symptoms as above.

if i then delete the emulator from the phone and put a new copy of it on the phone everything is sweet for x amount of reboots or plays on any games until the random problem happens again??

any possible ideas ?

not really that bothered about finding a solution,  just thought i'd throw it in here for discussion.


Something happened to me today that may give a clue.

First thing to say is that I have used the Gameboy emulator a lot and have never had a problem.

Today I downloaded the new version of DoomSPV. When I copied it to the phone I forgot to power my USB hub. As a result the file when on the phone corrupted. As a result I got problems similar to yours only much worse. When I reload Doom everything was fine. It might be worth reloading the gameboy program from the web site as it may have come down to your PC corrupted.

  • 0

#229
awarner

awarner

    Staff Team Leader

  • Admin Team
  • PipPipPipPipPipPip
  • 18,476 posts
  • Gender:Male
  • Location:Southampton
  • Interests:Life the universe and everything in it :)

    Lumia 925 one hell of a camera phone
  • Devices:Lumia 925 a real phone at last
  • Twitter:@ashwarner
The hiding posts bugs here ;)

  • 0
Twitter me @ashwarner

Windows Phone 7 Expert.
Windows Phone Business Specialist



#230
Monolithix

Monolithix

    Hardcore

  • MoDaCo Gold
  • PipPipPipPipPipPip
  • 8,783 posts
Yeah i noticed that, tried the add 5 to the end of the url value tirck though.

£ posts and no new page showing up is a bit crap though...:/

  • 0

I still exist


#231
chris_rothwell

chris_rothwell

    Newbie

  • Members
  • Pip
  • 1 posts
i have copied the file on to spv but it says access denied, its not digitally signed with a trusted certificate.

what do i do

thanks :oops:

  • 0

#232
meaks

meaks

    Enthusiast

  • Members
  • PipPipPip
  • 215 posts
  • Location:Wrexham
You have to unlock your phone so that you can run un-signed apps.
The guide to do this is here...

http://www.modaco.co...opic.php?t=1992

  • 0

#233
pjc

pjc

    Regular

  • Members
  • PipPip
  • 59 posts
  • Location:Portsmouth
SpaceMonkey - you are possibly the only person who can help me!!!

I am playing Zelda Links Awakening DX GameBoy Colour ROM. I got as far as having my picture taken and when it asked if I would like to print a copy I foolishly said yes! My game is now hung. I assume it is trying to print to the GameBoy Colour printer. Is there anyway you can roll back my .sav/.000 files to where I was before I said print?

Please help it took me bloody ages to get this far!

  • 0
-=-
P J C

#234
dava

dava

    Newbie

  • Members
  • Pip
  • 40 posts
pjc - I had the same problem with Zelda; just delete the .000 file and then load to your last save - sorted...

dava

  • 0

#235
pjc

pjc

    Regular

  • Members
  • PipPip
  • 59 posts
  • Location:Portsmouth
dava - Problem now sorted, and I only needed to redo a small amount I had already completed.

Thanks Very much for the help.

(and its nice to know im not the only one who tried to print!!!!)

  • 0
-=-
P J C

#236
benjymous

benjymous

    Enthusiast

  • Members
  • PipPipPip
  • 200 posts
  • Location:Cambridge, UK
  • Devices:Sony Ericsson X10 Mini
  • Twitter:@benjymous
I'm not sure if this is a bug or not, but it wasn't immediately obvious

When the game is running, the home and back keys are disabled so you can't quickly get out of the game (you need to bring up the pause menu with the record button, and then exit from there)

Took me a while to work this out (perhaps editing the first post to link to the page with instructions, rather than straight to the exe would be a good idea :) )

  • 0
Help me! I'm turning into a grapefruit!

#237
spacemonkey

spacemonkey

    just some guy, you know...

  • MoDaCo Gold
  • PipPipPipPipPipPip
  • 1,628 posts
  • Location:London, New Zealand
  • Interests:Technology, Toys
  • Devices:HTC Diamond
Yeah, there is a page with instructions etc. This thread is obsolete kindof check out this one instead:

http://www.modaco.co...opic.php?t=3631

(Paul, do you want to lock this thread?)

  • 0
Like a monkey ready to be shot off into space. Spacemonkey. Ready to sacrifice himself for the greater good.

owned: SPV, E200, C500, C600, Wizard, Hermes

smartphone software by me : http://www.surrealservices.co.uk




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users