Jump to content


Photo

ARRGH Bluetooth GPS woes

- - - - -

  • Please log in to reply
9 replies to this topic

#1
roboldham

roboldham

    Newbie

  • Members
  • Pip
  • 7 posts
  • Devices:Orangge SPV m5000
Hi folks

I am having a perplexing and annoying problem trying to get a (non TOM TOM) bluetooth GPS unit to pipe data into my Orange m5000 on a desired COM port.

The Bluetooth unit is just fine and connects sweetly to my Dell Axim running PocketPC - you just connect with "Bluetooth SPP" and off you go on COM Port 7 - no problems in TomTom or MemoryMap or whatever.

Now - try doing the same on the SPV - no way.

I have paired the device no problem, selected the "Serial Port" checkbox after pairing and have tried assigning a COM Port and have tried using it without.

The only COM ports it lets me map to are COM0, COM4 and COM8

Now is it just coincidence that TomTom and Memorymap do not have any of these options available? WTF?!

I have run GPSDash as a diagnostic as its got a good output of raw data feed and it lets me map to COM4 or COM8 (but not COM0) and it locks with the sig and all is sweet - so the GPS is fine and the Bluetooth stack is fine in the m5000.

So WHATS THE FRIGGIN DEAL with not being able to use COM0, 4 and 8 in other applications that I want to use?

By the way, I borrowed a friends TomTom specific BT GPS and it worked fine in TomTom but noting else - I believe it's locked to COM0 or something odd like that.

Please help anyone?

TIA

R

  • 0

#2
MuppetUK

MuppetUK

    Newbie

  • Members
  • Pip
  • 10 posts
Identical problem here, TomTom is quite happy to showup all sorts of other bloody com ports but since I can only assign COM 0, 4 or 8 to the Bluetooth GPS TomTom won't list any of those 3.

Bloody frustrating when I've gotten the BT GPS to work fine on a Nokia.

  • 0

#3
roboldham

roboldham

    Newbie

  • Members
  • Pip
  • 7 posts
  • Devices:Orangge SPV m5000

Identical problem here, TomTom is quite happy to showup all sorts of other bloody com ports but since I can only assign COM 0, 4 or 8 to the Bluetooth GPS TomTom won't list any of those 3.

Bloody frustrating when I've gotten the BT GPS to work fine on a Nokia.

<{POST_SNAPBACK}>


I have since found a solution of sorts - I can get the non TomTom bluetooth GPS to work with TomTom by using one method (will post this in a moment) but ONLY with TomTom

For use of MemoryMap or other apps using sensible COM ports I have resorted to having to disable one or both of the IR ports (COM2 and 3) and using a virtual COM port router called Franson GPS Gate - I will post this method in a mo too, brb!

  • 0

#4
roboldham

roboldham

    Newbie

  • Members
  • Pip
  • 7 posts
  • Devices:Orangge SPV m5000
Here is the TomTom only solution that is stable and does not require you to disable COM ports:

STEP 1 : INSTALL TOMTOM5
You do this by copying the CAB files from the CDROM (eg F:\PocketPC) to the JasJar and launch one by one from there with the explorer of the JasJar.
You can install voices the same manner by copying the CAB files to the Jasjar (eg from F:\Voice on the CDROM)

STEP 2 : UPGRADE TO V5.1 (THIS IS NOT ESSENTIAL, ONLY DO IT IF YOU HAVE A NON-HOKY COPY OF TT 5)
http://www.htcclub.n...e/ppcupd510.rar
Extract and copy the files to a folder on the JasJar and install them from there.

STEP 3 : ACTIVATE THE GPS CONTROL PANEL
Fire up a registry editor (eg http://www.freewarep...tryeditor.shtml )
Go to: HKEY_LOCAL_MASCHINE\ControlPanel\GPS Settings
Delete the DWORD marked "hide"
Add a DWORD called "Group" and give it the value of "2" (dec)
The GPS panel will now show up in your connection settings.

STEP 4 : INSTALL TOMTOM5
1. Establish a bond with your GPS and select the checkbox for serial access.
2. In BT, select the OUTGOING port to 8.
3. In the GPS control panel, select the GPS program to 0 and make sure that the hardware one, is set to None.
4. Start TT5 and the GPS settings, select another bluetooth GPS, and you will see COM 0 free. Select COM 0 and close TT5.
5. At the GPS control panel again, now select COM 8 (before we set it up at 0).
6. At BT: select OUTGOING port to 0.
7. Back again to GPS control panel and select NONE.
8. Finally start TT5 and it should connect automatically. Wait for a couple of seconds and click the GPS settings and you should see it has connected.

REMAINING PROBLEM
TomTom will only connect to the BT GPS when the Phone is switched on.
If you want to use your integrated car phone and just use the JasJar as GPS, you need to switch the Phone antenna off on the JasJar and the Bluetooth radio on (for the GPS connection). This worked perfectly before with TT3 and my i-mate PDA2K but now I am forced to activate the phone radio on the JasJar meaning that I can not use my car phone anymore !
I think it is a TT problem as I am able to connect to the GPS with other software without the phone radio switched on.

  • 0

#5
roboldham

roboldham

    Newbie

  • Members
  • Pip
  • 7 posts
  • Devices:Orangge SPV m5000
the Franson forum where I posted my solution for non TomTom applications using sensible ports is currently down - will post when itis back up and I can copy n paste it over

R

  • 0

#6
roboldham

roboldham

    Newbie

  • Members
  • Pip
  • 7 posts
  • Devices:Orangge SPV m5000

  • 0

#7
MuppetUK

MuppetUK

    Newbie

  • Members
  • Pip
  • 10 posts
The 1st guide doesn't work for me, not had e-mail for software to try that 2nd guide.

When I go to the last step, it doesn;t refresh into any old setting, it just sits there saying no GPS Device :)

  • 0

#8
mattgod69

mattgod69

    Regular

  • Members
  • PipPip
  • 76 posts

The 1st guide doesn't work for me, not had e-mail for software to try that 2nd guide.

When I go to the last step, it doesn;t refresh into any old setting, it just sits there saying no GPS Device :)

<{POST_SNAPBACK}>


This worked for me. Great post. It must have taken hours to work it out! Did not really understand the car phone issue, can you please explain. Also, has anyone tried using the PLUS features??

  • 0

#9
Stabilo

Stabilo

    Regular

  • Members
  • PipPip
  • 124 posts
  • Location:Sheffield
  • Devices:MDA Vario, M600 & M2000

Here is the TomTom only solution that is stable and does not require you to disable COM ports:

STEP 1 : INSTALL TOMTOM5
You do this by copying the CAB files from the CDROM (eg F:\PocketPC) to the JasJar and launch one by one from there with the explorer of the JasJar.
You can install voices the same manner by copying the CAB files to the Jasjar (eg from F:\Voice on the CDROM)

STEP 2 : UPGRADE TO V5.1 (THIS IS NOT ESSENTIAL, ONLY DO IT IF YOU HAVE A NON-HOKY COPY OF TT 5)
http://www.htcclub.n...e/ppcupd510.rar
Extract and copy the files to a folder on the JasJar and install them from there.

STEP 3 : ACTIVATE THE GPS CONTROL PANEL
Fire up a registry editor (eg http://www.freewarep...tryeditor.shtml )
Go to: HKEY_LOCAL_MASCHINE\ControlPanel\GPS Settings
Delete the DWORD marked "hide"
Add a DWORD called "Group" and give it the value of "2" (dec)
The GPS panel will now show up in your connection settings.

STEP 4 : INSTALL TOMTOM5
1. Establish a bond with your GPS and select the checkbox for serial access.
2. In BT, select the OUTGOING port to 8.
3. In the GPS control panel, select the GPS program to 0 and make sure that the hardware one, is set to None.
4. Start TT5 and the GPS settings, select another bluetooth GPS, and you will see COM 0 free. Select COM 0 and close TT5.
5. At the GPS control panel again, now select COM 8 (before we set it up at 0).
6. At BT: select OUTGOING port to 0.
7. Back again to GPS control panel and select NONE.
8. Finally start TT5 and it should connect automatically. Wait for a couple of seconds and click the GPS settings and you should see it has connected.

REMAINING PROBLEM
TomTom will only connect to the BT GPS when the Phone is switched on.
If you want to use your integrated car phone and just use the JasJar as GPS, you need to switch the Phone antenna off on the JasJar and the Bluetooth radio on (for the GPS connection). This worked perfectly before with TT3 and my i-mate PDA2K but now I am forced to activate the phone radio on the JasJar meaning that I can not use my car phone anymore !
I think it is a TT problem as I am able to connect to the GPS with other software without the phone radio switched on.


Very comprehensive guide, thanks.

Does the DWORD marked 'hide' only appear after the 5.1 upgrade?

When I try the upgrade it runs through a few thinhs and then the s/w crashes. I will try on another PC but any idea why the upgrade fails?

  • 0
Stabilo

Current holding:

T-Mobile MDA
Orange M600 & M2000
Motorola V66 & V535
Siemens A65
Nokia Communicator

#10
crd3000

crd3000

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:XDA exec
You roboldham are a little angel :))


I got it working on my XDA exec after 7 months of trying to get it to find my BT GPS bluetooth unit!

And it's all down to your directions :))

Thanks ever so much,

Caz


[quote name='roboldham' date='Dec 17 2005, 18:48' post='698004']
Here is the TomTom only solution that is stable and does not require you to disable COM ports:

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users