Jump to content


Photo

Tornado PowerControl

* * * * * 1 votes

  • Please log in to reply
182 replies to this topic

#61
merwin

merwin

    Enthusiast

  • Members
  • PipPipPip
  • 181 posts
  • Devices:T-Mobile SDA (USA)

Thanks for the response, I just thought that four times a second sounded like alot but your probably right about it being almost nothing. If you create a way of showing how many mhz the phone is running at in the top bar, please make this optional as I've allready got enough icons there :-)


LOL. I'll try to get that working so i can clutter your bar a little more

  • 0

#62
jcostantino

jcostantino

    Regular

  • Members
  • PipPip
  • 115 posts
  • Location:Sunrise, FL - USA
  • Devices:T-Mo MDA Vario
I hate to put a dumb question here since I'm usually fairly good at figuring things out...

How do I edit the shortcut? If I use File Manager to create a shortcut in windows/startup it makes one but there is no way to edit the arguments to add the "hide" flag. I can view it in Iexplore but can't edit it. Do I need to use a text editor on the phone? Do you have a suggestion on which one to use? The only thing I have to create text on the phone is SmartPhone Notes and that won't do me any good.

BTW: Thanks a TON for this app! The only thing I could suggest would be to be able to chose a custom top speed. My phone is stable above 240 mhz and I may as well get as much juice out of it as possible. The speed-sensitive CPU adjustments are fantastic! It's great to be able to offset the battery cost of overclocking with the savings of underclocking. It's a shame this wasn't implemented from the start, at least now it feels like a whole new phone so it's sort of like an early Christmas!

Also, it would be great to be able to have a notification icon in the top bar to give speed feedback. Maybe something as simple as a dot that changed between shades of red, yellow, and green to signify the CPU speed?

  • 0

#63
Bokkiej

Bokkiej

    Newbie

  • Members
  • Pip
  • 7 posts
  • Devices:SPV C550
Seems like a nice prog (especially the automatic under/overclocking), but the CF 2.0 in your link doesn't work on my SPV C550 and the one I've googled (http://www.microsoft...&DisplayLang=en) also doesn't work on Windows Mobile 2003SE for smartphones. How do you think that I'd still be able to use your new version?

  • 0

#64
merwin

merwin

    Enthusiast

  • Members
  • PipPipPip
  • 181 posts
  • Devices:T-Mobile SDA (USA)

Seems like a nice prog (especially the automatic under/overclocking), but the CF 2.0 in your link doesn't work on my SPV C550 and the one I've googled (http://www.microsoft...&DisplayLang=en) also doesn't work on Windows Mobile 2003SE for smartphones. How do you think that I'd still be able to use your new version?


The main issue here is that this software isn't compatible with your phone. It says that it's only compatible with the TORNADO platform, which shipped with WM5. I'm not exactly sure what platform the C550 falls under, but it's not TORNADO :-)

  • 0

#65
Bokkiej

Bokkiej

    Newbie

  • Members
  • Pip
  • 7 posts
  • Devices:SPV C550

The main issue here is that this software isn't compatible with your phone. It says that it's only compatible with the TORNADO platform, which shipped with WM5. I'm not exactly sure what platform the C550 falls under, but it's not TORNADO :-)


I know, but 1.4 does work with my phone and the features of 2.0 seem nice so it was worth a try :)

  • 0

#66
merwin

merwin

    Enthusiast

  • Members
  • PipPipPip
  • 181 posts
  • Devices:T-Mobile SDA (USA)

I know, but 1.4 does work with my phone and the features of 2.0 seem nice so it was worth a try :)


sorry... I'm only continuing development in .net 2.0 as they are not really compatible with each other.

  • 0

#67
Pa9an

Pa9an

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:8310

Try the latest version (1.45). Some things have changed regarding the control of the display. Remember that this latest version requires Compact Framework 2.0 (read the release notes for a direct download to the 2mb file). CF2 can be installed directly to the storage card, so it won't take up space on your phone.

How did you folks manage to get CF2 installed to the storage card??
I've downloaded the SP1 from the link in the 1st post - altthough when I try to install it, it gives me the choice of Device vs Storage Card, but seems to install to the Device regardless...and fails as I don't have the 5.5mb space left there... ;)
Any idea? :)

  • 0

#68
Sartre

Sartre

    Newbie

  • Members
  • Pip
  • 5 posts
  • Devices:QTek 8310

How did you folks manage to get CF2 installed to the storage card??
I've downloaded the SP1 from the link in the 1st post - altthough when I try to install it, it gives me the choice of Device vs Storage Card, but seems to install to the Device regardless...and fails as I don't have the 5.5mb space left there... ;)
Any idea? :)


Try freeing up the needed space on your device, then when the install has finished and your device is reset you'll notice that most of CF2 actually is installed on your storage card, and most of the 5.5mb it uses under installation is available again for use in your device..

  • 0

#69
Pa9an

Pa9an

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:8310

Try freeing up the needed space on your device, then when the install has finished and your device is reset you'll notice that most of CF2 actually is installed on your storage card, and most of the 5.5mb it uses under installation is available again for use in your device..

That worked! Thanks a mill for the hint! :)

  • 0

#70
merwin

merwin

    Enthusiast

  • Members
  • PipPipPip
  • 181 posts
  • Devices:T-Mobile SDA (USA)
Just a note on the status of the project...
In an internal development build, I have added a status bar icon as well as making the Slow/Normal/Fast of the automatic mode have configurable speeds.

What's next? The next thing on my plate is adding direct CPU changing, along the lines of OmapClock... this will allow the CPU to be changed without having to launch OMAPClock, allowing CPU changing without any lag.

Right now I'm in overseas in Asia, so the next version might be a couple of weeks away.

  • 0

#71
Seth Cold

Seth Cold

    Addict

  • Members
  • PipPipPipPipPip
  • 575 posts
  • Location:Medellin, Colombia
  • Devices:Samsung Galaxy S Captivate
  • Twitter:@coldonline
i second that...240mhz is better for skype :)
thanx merwin for all your efforts!!

  • 0
Viva el DIM el poderoso!!
Follow me on twitter: http://twitter.com/coldonline
IMPROVEMENTWEAR.COM

#72
Anton Oprya

Anton Oprya

    Newbie

  • Members
  • Pip
  • 11 posts
  • Devices:Qtek 8310
I have some problems with TPC:
- on first launch with keys trim hide TPC works correctly, but next launch makes TPC not hide and display mode doesn’t change (dim/bright)
- on running TPC other programs minimize more quickly than specified in device settings
P.S. Enabled automatic mode

  • 0

#73
merwin

merwin

    Enthusiast

  • Members
  • PipPipPip
  • 181 posts
  • Devices:T-Mobile SDA (USA)

I have some problems with TPC:
- on first launch with keys trim hide TPC works correctly, but next launch makes TPC not hide and display mode doesnít change (dim/bright)
- on running TPC other programs minimize more quickly than specified in device settings
P.S. Enabled automatic mode


If TPC is already running, it will not take any command line parameters such as hide and dim. That is only for the first run.

I am aware of the minimize problem and am working on it. It does not happen every time, but it is very annoying :-) I think it is not a hard fix.

  • 0

#74
Anton Oprya

Anton Oprya

    Newbie

  • Members
  • Pip
  • 11 posts
  • Devices:Qtek 8310

If TPC is already running, it will not take any command line parameters such as hide and dim. That is only for the first run.

MMM..Before I used v1.3 and TPC hadn't this problem :)

I am aware of the minimize problem and am working on it. It does not happen every time, but it is very annoying :-) I think it is not a hard fix.

Thanks.

  • 0

#75
merwin

merwin

    Enthusiast

  • Members
  • PipPipPip
  • 181 posts
  • Devices:T-Mobile SDA (USA)

MMM..Before I used v1.3 and TPC hadn't this problem :)

Thanks.


You are correct. v1.3 did not behave like that. The reason I chose to remove that behavior is because windows mobile is not designed to run multiple copies of the same application. I had implemented a hack to provide this. It actually takes more time to load the app than to just switch to the app and let you press the '1' key to toggle the brightness :-)

  • 0

#76
eole73

eole73

    Newbie

  • Members
  • Pip
  • 46 posts
  • Devices:Qtek 8300

You are correct. v1.3 did not behave like that. The reason I chose to remove that behavior is because windows mobile is not designed to run multiple copies of the same application. I had implemented a hack to provide this. It actually takes more time to load the app than to just switch to the app and let you press the '1' key to toggle the brightness :-)


Hello every body, I have tried the 2.0 version and my phone is reseting when the light goes completly off, I am guessing that the 116 Mhz is not enough to run the phone.
Is possible to put the different CPU values as users parameters.
Thanks for the good work.

  • 0

#77
Wombleuk

Wombleuk

    Enthusiast

  • Members
  • PipPipPip
  • 212 posts
  • Devices:V1415
Hi,
I can't install CF2.
First time, it wouldn't let me choose the storage card for installation, but I'd already clicked action after pushing the joystick over without realising it - and I got an error - not enough free space.
I've tried deleting everything I can off the device, but it doesn't free up enough space (Windows has 59Mb ! Any idea how to free up all the language files and bloat I don't need?).
I've tried installing it to my storage card, which has 250Mb free, but I get the same error as installing it to the device.
I've copied it onto my SD card and clicked on it from within explorer and I still get the same error.

Help !

  • 0

#78
Anton Oprya

Anton Oprya

    Newbie

  • Members
  • Pip
  • 11 posts
  • Devices:Qtek 8310

You are correct. v1.3 did not behave like that. The reason I chose to remove that behavior is because windows mobile is not designed to run multiple copies of the same application. I had implemented a hack to provide this. It actually takes more time to load the app than to just switch to the app and let you press the '1' key to toggle the brightness :-)

It's a pity. In TPC 1.3 this option is more suitable

  • 0

#79
merwin

merwin

    Enthusiast

  • Members
  • PipPipPip
  • 181 posts
  • Devices:T-Mobile SDA (USA)

Hello every body, I have tried the 2.0 version and my phone is reseting when the light goes completly off, I am guessing that the 116 Mhz is not enough to run the phone.
Is possible to put the different CPU values as users parameters.
Thanks for the good work.


The latest version (2.0 Beat 2) allows for configurable auto-cpu speeds. I have also fixed the bug where the frontmost app would minimize when the screen went dim. And finally, I added an optional icon in the notification bar of the CPU speed.

I still haven't added 240mhz support. I might add it in the next version by having users who wish to have the support for it add a registry value. That would prove that they know what they are doing, and that they have probably already tested 240mhz on their phone. For some phones, it causes your phone to reboot. And since Automatic mode goes to the highest value almost immediately, it could cause an endless reboot cycle if TPC is set to AutoRun.

  • 0

#80
eole73

eole73

    Newbie

  • Members
  • Pip
  • 46 posts
  • Devices:Qtek 8300

The latest version (2.0 Beat 2) allows for configurable auto-cpu speeds. I have also fixed the bug where the frontmost app would minimize when the screen went dim. And finally, I added an optional icon in the notification bar of the CPU speed.

I still haven't added 240mhz support. I might add it in the next version by having users who wish to have the support for it add a registry value. That would prove that they know what they are doing, and that they have probably already tested 240mhz on their phone. For some phones, it causes your phone to reboot. And since Automatic mode goes to the highest value almost immediately, it could cause an endless reboot cycle if TPC is set to AutoRun.


Hi, I have installed the beta 2 and the CF2 SP1 twice on my SD card. The beta 2 won't start, I have always the same message : CF2 not found.
Thanks

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users