Jump to content


Photo

SDA II can't call properly

- - - - -

  • Please log in to reply
3 replies to this topic

#1
GarethHarrison

GarethHarrison

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:SDA II
Hi,

I'm hoping that some knowledgeable person on this forum can help me!!

I switched from the SPV E200 to a T-Mobile SDA II back in November, and right from the start was having problems with calling from it.

What happens is that sometimes I try to call a number, and the phone says it's calling, but there's no dialing tone, and the only way to get it away from saying that it's calling is to turn the phone off and on again. This is now happening a few times a day.

Also, I've also found that sometimes I get through but all I can hear is the sound from the mouthpiece, and not the caller at the other end, although they can hear me.

What I have noticed is that usually this happens when I've moved from one area to another (usually a few miles in the car etc) Could this be related? If I stay in one location, I don't usually have a problem.

I complained to Dial-a-Phone (who I bought it from) back in January and they got me to sent it for repair (which took 2 months!!) and the repairers then sent it back to the manufacturer to get the main board repaired and checked. However, I've had it back about a month, and this last week it's started doing it again - three times today.

I called D-A-P again today and they're saying I need to take it up with the repairers, but if they say it's not worth repairing, then it's tough because I don't have their additional insurance policy (but surely the fact that it's faulty should mean its covered by normal consumer laws?!)

Has anyone heard of similar issues with the SDA II? Is this a known fault? I know it's not my SIM card because I used it in a friend's phone for the 2 months the SDA was being repaired. I can't get any information from T-Mobile because I didn't buy the handset from them - though I wish now that I had never been near Dial-a-Phone with the grief I'm getting.

  • 0

#2
tsg20

tsg20

    Newbie

  • Members
  • Pip
  • 10 posts
  • Devices:htc wizard
My girlfriend's SDA II has a similar problem - except that if she waits a minute or so, it allows her to actually make the call. Does anyone have any ideas about this?

  • 0

#3
tkog2004

tkog2004

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:SDA II
Mine's the same, had to restart mine today 4 times so far, the 'calling' issue along with being unable to access profiles, change ringtone etc? worth trying to reflash, or a waste of time?

  • 0

#4
pierre

pierre

    Diehard

  • Members
  • PipPipPipPip
  • 439 posts
  • Interests:Canary> Tanager> Typhoon> Hurricane> Magician> Wizard> Universal> i600> Hermes> Samsung i600> TouchPro
  • Devices:HTC TouchPro
Same issue here with my SPV C550. One colleague got the same problem as well.

I was wondering if changing the ROM could fix it, but this can also be hardware related I suppose.

It's extremely boring!

  • 0
Sun is shining, weather is sweet.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users