Jump to content


Photo

I-Mate SP5 (Tornado) Disassembly

* * * * * 1 votes

  • Please log in to reply
30 replies to this topic

#21
Felixretama

Felixretama

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:sp5
Hello

Iīm just writing to ask you how can I remove the small ribbon which connects the Keypad to the mainboard.
I opened My SP5 (before reading your doc.) and I broke the small ribbon. I can buy a new one but what really concerns me is that I canīt remove it, Itīs simple impossible, It seems to be welded to the mainboard.
Do you have any suggestion?

Thanks a lot!

P.D. If anyone can answer my question please send me a mail to [email protected]

  • 0

#22
tboy2000

tboy2000

    Newbie

  • Members
  • Pip
  • 24 posts
  • Devices:sp5
I have the Vodafone V1240 version with the grey keypad. I really want to change it to a black keypad as I much prefer the look of the Qtek 8310 or iMate SP 5. I now know how to open the phone. All I would like to know now is where can I get a replacement black keypad please? Many thanks!

  • 0

#23
tboy2000

tboy2000

    Newbie

  • Members
  • Pip
  • 24 posts
  • Devices:sp5
Oops! Repeated post. Please delete.

Edited by tboy2000, 15 October 2006 - 02:58 PM.

  • 0

#24
tboy2000

tboy2000

    Newbie

  • Members
  • Pip
  • 24 posts
  • Devices:sp5
Oops! Repeated post. Please delete.

Edited by tboy2000, 15 October 2006 - 02:58 PM.

  • 0

#25
tboy2000

tboy2000

    Newbie

  • Members
  • Pip
  • 24 posts
  • Devices:sp5
Oops! Repeated post. Please delete.

Edited by tboy2000, 15 October 2006 - 02:58 PM.

  • 0

#26
daz306td

daz306td

    Regular

  • Members
  • PipPip
  • 67 posts
  • Gender:Male
  • Devices:Samsung i900
The perfect guide! thank you! Did you say you had images taken during the dismantlin? Could you post the images please? how did you remove the ribbon cable without breaking it??

  • 0
Omina i900 (i900XXHJ6/ACHJ2 PHONE: i900BUHJ1)

#27
jbmatson

jbmatson

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:Imate sp5
Hi guys,

I've had a problem with my sp5 for the last couple of months where the joystick was slowly becoming unusable. It would hardly ever work in the up direction at all, and wasn't great in the down direction either. I had tried cleaning the joystick from the outside, but that made little difference.

Tonight I tried following your disassembly instructions, and then cleaned the joystick and the keypad and put it all back together. Now my joystick works beautifully, but only half the buttons on my keypad work! ;)

From memory, the Home, back, dial, hang up, 3, 4, 7, 8, * and # buttons all don't work.

The disassembly and reassembly process all went fine. I didn't damage the keypad ribbon cable and I have checked several times that it is connected to the mainboard correctly.

The buttons all click nicely and their action feels and sounds like they should be working ok.

Can anyone suggest anything I can do to fix this?
Thanks,
James

Edited by jbmatson, 21 February 2007 - 11:26 AM.

  • 0

#28
jbmatson

jbmatson

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:Imate sp5
Well... I didn't get any replies so I went ahead and bought a replacement keypad membrane off eBay.
I got it in the mail today, and did the swap and the phone is working fine now.

I did notice one difference between the old keypad and the new one. My old one was missing the thin clear plastic rectangle covering the back of the ribbon cable on the other side of the connector. I must have knocked it off when I was doing the assembly. So, if anyone else is going to try this process they might want to be careful about that part!

Thanks anyway,
James


Hi guys,

I've had a problem with my sp5 for the last couple of months where the joystick was slowly becoming unusable. It would hardly ever work in the up direction at all, and wasn't great in the down direction either. I had tried cleaning the joystick from the outside, but that made little difference.

Tonight I tried following your disassembly instructions, and then cleaned the joystick and the keypad and put it all back together. Now my joystick works beautifully, but only half the buttons on my keypad work! ;)

From memory, the Home, back, dial, hang up, 3, 4, 7, 8, * and # buttons all don't work.

The disassembly and reassembly process all went fine. I didn't damage the keypad ribbon cable and I have checked several times that it is connected to the mainboard correctly.

The buttons all click nicely and their action feels and sounds like they should be working ok.

Can anyone suggest anything I can do to fix this?
Thanks,
James


  • 0

#29
Savage_Gizmo

Savage_Gizmo

    Newbie

  • Members
  • Pip
  • 11 posts
  • Devices:v1240
when i was trying to pull my mainbord from the housing i was literally trying to wrench it off until i thought of peeling off the 'void' sticker and there was another screw underneath it, doh. i just thought it was worth mentioning if anyone else was stumped why their mainboard wasn't coming away. oh and this was on a voda v1240

  • 0

#30
conan_troutman

conan_troutman

    Addict

  • Members
  • PipPipPipPipPip
  • 837 posts
  • Gender:Male
  • Location:Halifax
  • Devices:Qtek 8310 with latest Rom
any one know where the lil battery that keeps the date and time ticking over when main is removed is sittuated and how I can replace it.

this is getting really annoying for me and several user that should I switch my SD card I have to reset the date and time

  • 0

#31
chintusingh

chintusingh

    Newbie

  • Members
  • Pip
  • 9 posts
This is an awesome step by step guide. I just opened my i-mate sp5 to clean the 2 key and it took me about 1/2 hr start to end :-)

Thanks a lot for these steps.

Vikram :(

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users