Jump to content


Photo

Stop activesync synching every x minutes?

- - - - -

  • Please log in to reply
18 replies to this topic

#1
_Belial

_Belial

    Newbie

  • Members
  • Pip
  • 49 posts
  • Devices:c500 + MDA Vario
I'm sure in a previous version of activesync there was an option to synch manually only. But now on 4.2 i can't seem to have that luxury and it's drivin me mad that even if i switch my phone off when connected to usb, every 5 minutes or so something will happen that makes it wake up and want to synch!

Is there a p hone or activesync option somewhere i'm missing to disable this madness?

Thanks in advance

  • 0
Posted Image

Posted Image

#2
M@rkC

M@rkC

    Enthusiast

  • Members
  • PipPipPip
  • 194 posts
  • Gender:Male
  • Location:Bristol, UK
  • Interests:Most things mobile.....
  • Devices:T-Mobile HTC HD2

I'm sure in a previous version of activesync there was an option to synch manually only. But now on 4.2 i can't seem to have that luxury and it's drivin me mad that even if i switch my phone off when connected to usb, every 5 minutes or so something will happen that makes it wake up and want to synch!

Is there a p hone or activesync option somewhere i'm missing to disable this madness?

Thanks in advance

There's a "phone ActiveSync" option :rolleyes:

Go to Start, Programs, ActiveSync. Select the Menu soft button, then the Schedule option - set both values in the drop-down box to "Manually" and make sure "Use above settings when roaming" is also ticked - that stops it doing any push email type stuff unless you tell it to!

HTH, Mark.

  • 0
A wise man speaks when he has something to say; A fool speaks when he has to say something

#3
_Belial

_Belial

    Newbie

  • Members
  • Pip
  • 49 posts
  • Devices:c500 + MDA Vario
Thanks Mark,

But my scheduled option is greyed out?

  • 0
Posted Image

Posted Image

#4
_Belial

_Belial

    Newbie

  • Members
  • Pip
  • 49 posts
  • Devices:c500 + MDA Vario
Ah i had to setup a dummy server then i got access to schedule, then deleted the dummy server, marvellous, thanks Mark.

When you refer to the "battery patch" are you talking about the dummy server fix to set ActiveSync to only synch manually?

Even with the latest BIOS, you'll still want to set ActiveSync to only synch manually. Otherwise, ACtiveSync will turn on at regular intervals and potentially drain your battery. I don't know for sure if this is the cause of your problem, but try setting ActiveSync to manual and see if it relieves some of the problem:

Open Activesync on your PDA. To gain access to the feature that will allow you to set it to a manual schedule you need to first set up a dummy server - if you tap Menu, you'll see the second item is "Schedule" but it is grayed out and you can't access it. Setting up a dummy server simply lets you gain access to this option (you will never use this dummy server and will delete it after you change ActiveSync to a manual schedule).

From the Menu popup menu, tap Add Server Source. Type in 1.1.1.1 in the server address box, then tap Next. Type any kind of foolishness in the username, password and domain boxes. Tap Next > Finish.

Now tap Menu > Schedule. Tap the down arrow on "Peak times" and change to "Manual". Tap the down arrow on "Off-peak times" and change to "Manual." Tap OK at the top right-hand side of screen.

Now delete the dummy server settings you just set up:

Tap Menu > Options > Delete button > Tap Yes to delete the server settings. You are done. Now ActiveSync should only come on when you turn it on. Whenever you use ActiveSync, it is a good idea to turn it off when you are done using it. You can tap the memory icon on your Start page, then tap the Running Programs tab. Tap ActiveSync (if it shows in the Running Programs List) and Stop.


  • 0
Posted Image

Posted Image

#5
M@rkC

M@rkC

    Enthusiast

  • Members
  • PipPipPip
  • 194 posts
  • Gender:Male
  • Location:Bristol, UK
  • Interests:Most things mobile.....
  • Devices:T-Mobile HTC HD2

Ah i had to setup a dummy server then i got access to schedule, then deleted the dummy server, marvellous, thanks Mark.

I was just about to post that!! Yeah, that's the problem - if you're not using Exchange/push email, there's no access to the schedule, hence the need to create the dummy Exchange server entry....the "default schedule" is apparently set in ROM (at 5 or 10 minutes :( ), so I'm quite surprised that more people aren't getting hacked off with this happening.....maybe they've all got Push email enabled - or unlimited data packages, more likely :rolleyes:

Glad you got it sorted.

Cheers,

Mark.

  • 0
A wise man speaks when he has something to say; A fool speaks when he has to say something

#6
_Belial

_Belial

    Newbie

  • Members
  • Pip
  • 49 posts
  • Devices:c500 + MDA Vario
Damn,

Doesnt seem to be wokring, silly thing is still coming back on every 5 mins :rolleyes:

  • 0
Posted Image

Posted Image

#7
nsm

nsm

    Newbie

  • Members
  • Pip
  • 37 posts
  • Devices:MDA Vario II

Damn,

Doesnt seem to be wokring, silly thing is still coming back on every 5 mins :rolleyes:


Hi - actually I get this too, around every 5 minutes and it does start to get quite annoying.
Anyone else know why this happens?

  • 0

#8
rammy121

rammy121

    Regular

  • Members
  • PipPip
  • 63 posts
i've got the exact same problem!! it's really annoying!! i'm using mnotes and there's a lot of contacts it trundles through, takes aaagggggeeeeessss !!!

Hi - actually I get this too, around every 5 minutes and it does start to get quite annoying.
Anyone else know why this happens?


  • 0

#9
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,222 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien
I don't have AS installed now (Vista here i'm afraid) but IIRC there is an option 'sync continously while connected' on the desktop, in Tools-Options if my memory serves me correctly...

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#10
romimaso

romimaso

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:Samsung BlackJack

I don't have AS installed now (Vista here i'm afraid) but IIRC there is an option 'sync continously while connected' on the desktop, in Tools-Options if my memory serves me correctly...

P


Hi Paul,

unfortunately this doesn't help with ActiveSync always running on the device--it only stops ActiveSync from running continuously while connected to the computer. Has anyone else had any luck figuring out how to stop AS from running on the actual HTC? Is there a registry hack out there?

Thanks

  • 0

#11
chezchas9

chezchas9

    Newbie

  • Members
  • Pip
  • 6 posts
  • Devices:HTC TyTN II
ActiveSync starts on my TyTN II every time I turn on the phone (Comm. Manager > then click the phone icon). Can I stop this? It's really annoying because I turn my phone off and on quite often depending on where I am and what I'm doing. As it is, I have to kill active sync about ten times a day. I only sync once each evening and I do that manually by starting ActiveSync and selecting "Menu > Connect Via Bluetooth". That's really the only time I want ActiveStink to start. Otherwise I just want it to sit down and shut up.

Note: I've already set the Schedule to Manual as suggested elsewhere in this thread (using the trick of setting up a dummy Exchange Server and then deleting it). That does stop ActiveSync from starting on its own every few minutes (what a relief -- and thank you to those posters), but ActiveSync still starts every time I start the phone. (Why oh why, Microsoft, would you think I want ActiveSync to startup when I start the phone? -- I'm just trying to talk on the phone for crimeny sakes -- and I don't have push email -- end rant -- deep breath -- remain calm.)

Thanks for any help the amazing experts on this forum can offer!

If there's no way to actually stop ActiveSync from starting every time I start the phone, maybe there's a script out there that can somehow run automatically and kill it when it starts (unless I take some action to say, no, don't kill it this time because I am actually trying to sync now).

  • 0

#12
chezchas9

chezchas9

    Newbie

  • Members
  • Pip
  • 6 posts
  • Devices:HTC TyTN II

ActiveSync starts on my TyTN II every time I turn on the phone (Comm. Manager > then click the phone icon). Can I stop this? It's really annoying because I turn my phone off and on quite often depending on where I am and what I'm doing. As it is, I have to kill active sync about ten times a day. I only sync once each evening and I do that manually by starting ActiveSync and selecting "Menu > Connect Via Bluetooth". That's really the only time I want ActiveStink to start. Otherwise I just want it to sit down and shut up.

Note: I've already set the Schedule to Manual as suggested elsewhere in this thread (using the trick of setting up a dummy Exchange Server and then deleting it). That does stop ActiveSync from starting on its own every few minutes (what a relief -- and thank you to those posters), but ActiveSync still starts every time I start the phone. (Why oh why, Microsoft, would you think I want ActiveSync to startup when I start the phone? -- I'm just trying to talk on the phone for crimeny sakes -- and I don't have push email -- end rant -- deep breath -- remain calm.)

Thanks for any help the amazing experts on this forum can offer!

If there's no way to actually stop ActiveSync from starting every time I start the phone, maybe there's a script out there that can somehow run automatically and kill it when it starts (unless I take some action to say, no, don't kill it this time because I am actually trying to sync now).


Bump

  • 0

#13
chezchas9

chezchas9

    Newbie

  • Members
  • Pip
  • 6 posts
  • Devices:HTC TyTN II

ActiveSync starts on my TyTN II every time I turn on the phone (Comm. Manager > then click the phone icon). Can I stop this? It's really annoying because I turn my phone off and on quite often depending on where I am and what I'm doing. As it is, I have to kill active sync about ten times a day. I only sync once each evening and I do that manually by starting ActiveSync and selecting "Menu > Connect Via Bluetooth". That's really the only time I want ActiveStink to start. Otherwise I just want it to sit down and shut up.

Note: I've already set the Schedule to Manual as suggested elsewhere in this thread (using the trick of setting up a dummy Exchange Server and then deleting it). That does stop ActiveSync from starting on its own every few minutes (what a relief -- and thank you to those posters), but ActiveSync still starts every time I start the phone. (Why oh why, Microsoft, would you think I want ActiveSync to startup when I start the phone? -- I'm just trying to talk on the phone for crimeny sakes -- and I don't have push email -- end rant -- deep breath -- remain calm.)

Thanks for any help the amazing experts on this forum can offer!

If there's no way to actually stop ActiveSync from starting every time I start the phone, maybe there's a script out there that can somehow run automatically and kill it when it starts (unless I take some action to say, no, don't kill it this time because I am actually trying to sync now).


Bump

  • 0

#14
jimbouk

jimbouk

    Hardcore

  • MoDaCo Silver
  • PipPipPipPipPipPip
  • 2,721 posts
  • Location:London
  • Devices:HTC Diamond
Get a nokia.

If you dont want a wm device thats syncs with your pc/server and you just want a phone, then buy a phone.




If you dont have a unlimited data plan and dont need activesync then use one of the free data disconnect apps to stop your phone trying to connect.

  • 0
Touch HD runnign Dutty's latest rom

#15
chezchas9

chezchas9

    Newbie

  • Members
  • Pip
  • 6 posts
  • Devices:HTC TyTN II

Get a nokia.

If you dont want a wm device thats syncs with your pc/server and you just want a phone, then buy a phone.




If you dont have a unlimited data plan and dont need activesync then use one of the free data disconnect apps to stop your phone trying to connect.


Thank you for your reply, but I guess I haven't explained my situation very well. I do want more than just a phone -- I really like having a smart phone. I use many different apps on it (GPS, etc.) -- I also keep data on it that I use all the time (for example ListPro lists) -- but I only want to sync the data with my home computer when I'm at home next to my computer using bluetooth -- in fact, I cannot sync them via the phone connection so there's no reason for ActiveSync to start up automatically each time I turn on the phone (for example, go off "Flight Mode" using Comm Manager). I then have to stop activesync to keep it from draining my battery. Activesync also seems to start at other times (I think if the phone loses its connection and then reconnects). I've used the trick of preventing it from starting on a schedule (by turning off the schedule option) -- but that doesn't address the many times that activesync starts when the phone connection starts.

You mentioned, "use one of the free data disconnect apps to stop your phone trying to connect" -- can you please direct me to one of these? I've been searching for one. I do use "Kill ActivSync" on my PC, but I thought that app only works on a PC, not on a Windows Mobile device. If there is an equivalent program (or registry hack) for Windows Mobile, I'd really like to find it -- I'm pretty good at googling around to find things, but maybe I'm just missing something obvious here. The ideal program would be one that prevented ActiveSync from starting on my TyTN II except for when I manually start it.

Thanks for your help!

  • 0

#16
jimbouk

jimbouk

    Hardcore

  • MoDaCo Silver
  • PipPipPipPipPipPip
  • 2,721 posts
  • Location:London
  • Devices:HTC Diamond
Activesync over USb (ie not OTA to an exchange server) isnt going to use much battery when disconnected.

There are various data disconnect apps around on xda developers and I think I even saw one in this forum.

  • 0
Touch HD runnign Dutty's latest rom

#17
chezchas9

chezchas9

    Newbie

  • Members
  • Pip
  • 6 posts
  • Devices:HTC TyTN II
Anyone found a way to prevent ActiveSync from starting each time the phone is turned on (via Comm Manager)? I can prevent it from starting on my computer by using Kill ActiveSync, but I still have the probelm on my TyTN II -- every time I click on the phone icon in Comm Manager to turn on the phone, not only does the phone start, but ActiveSync starts as well, and then I need to manually terminate ActiveSync.

Maybe people who don't have a task manager, don't realize that this is happening to them as well. I described this to a friend who has a TyTN and he said no way it was happening to him. I asked him to check his active tasks and, sure enough, ActiveSync, was running. Then he tested it a few times, by turning on his phone via Comm Manager, and, what do you know, it was happening on his phone as well. Could some more users TyTN and TyTN II users check to see if they have ActiveSync running in active tasks even though they didn't start it manually? If so, it probably started automatically when you turned on the phone (via Comm Manager).

Any applet or registry fix for this would be greatly appreciated!

  • 0

#18
WearTheFoxHat

WearTheFoxHat

    I've gone all droid!

  • Moderator Team
  • PipPipPipPipPipPip
  • 1,213 posts
  • Gender:Male
  • Location:Right Here, Right Now!
  • Devices:Galaxy Note II, Moto XOOM 3G
  • Twitter:@TomJJarvis
I cant find the document which refers to it, as I used it on my old PDA as it kept waking the device and killing the battery.

You have to go into activesyn settings on the PDA, and remove the exchange server sync settings. Then it should stop it autoloading.

  • 0
Orange regrets to inform you that their network will be going down in 1 hours time for all users apart from yourself. This is because nothing would go down on you, not even a network!

#19
Neil5459

Neil5459

    NeilM

  • Members
  • PipPipPipPipPipPip
  • 1,485 posts
  • Gender:Male
  • Location:Saffron Walden, Essex
  • Devices:HTC Titan, iPad 2 3G
  • Twitter:@Neilmell

Maybe people who don't have a task manager, don't realize that this is happening to them as well. I described this to a friend who has a TyTN and he said no way it was happening to him. I asked him to check his active tasks and, sure enough, ActiveSync, was running. Then he tested it a few times, by turning on his phone via Comm Manager, and, what do you know, it was happening on his phone as well. Could some more users TyTN and TyTN II users check to see if they have ActiveSync running in active tasks even though they didn't start it manually? If so, it probably started automatically when you turned on the phone (via Comm Manager).


That is the whole point- A/S is transparent to the user. It is a small program that sits in the background managing communications. It's part of the OS and will always load automatically. WM5 and WM6 need to have it always on, which is why it autostarts even after terminating manually.

Everyone with these devices has this. It is benign. I know you mentioned elsewhere that you don't like it principally because it shows up in your on-screen task manager/list, but I think you have to live with this, or find a Task Manager that has an option to hide apps from display.

  • 0
NeilM: Site Moderator and Reviewer on SmartphoneGurus

Posted ImagePosted Image

Windows Mobile Specialist Certification





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users