Jump to content


Photo

RUU on Vista: It can be done... the ultimate guide!

* * * * * 4 votes

  • Please log in to reply
93 replies to this topic

#21
Lorand

Lorand

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:Qtek 9100
Hello :P


Many thanks for this topic, great !

But I have a little problem.
If I uncheck the "Allow USB Connections" (Step 3), I can't see the section "Mobile devices" in my Device Manager (Sept 5) :rolleyes:


Thanks for your help :D

  • 0

#22
hooya

hooya

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:XV6700
I registered for this forum just for this tutorial. Thank you so much for those of you that did the research to make this possible!

  • 0

#23
haythams

haythams

    Newbie

  • Members
  • Pip
  • 4 posts
  • Devices:IMATE PDA2K
thanx alot for this value added topic i've implemnted the steps and it was working fine but sudenly its not working even my PPC icon is vot listed in my computer when i connect the device alret sound is annoincing that my device is connected and even the connection arrows still cyrcling and WMDC screen appears confermiong connection established but after a little while gives me error ? after some search i discovered this in the device manager
Posted Image

thanx a lot for ur concerns

  • 0

#24
fabrr

fabrr

    Newbie

  • Members
  • Pip
  • 1 posts
try with differet devices
universal,trinity, hermes OK
prophet and wizard it does't work

many thanks :rolleyes:

  • 0

#25
charly_mx

charly_mx

    Newbie

  • Members
  • Pip
  • 15 posts
  • Devices:Cingular 8125
I cant make it work. My RUU just crashes >(

  • 0

#26
Shuflie

Shuflie

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,294 posts
  • Gender:Male
  • Location:Belfast
  • Devices:HTC One X
  • Twitter:@Shuflie
For those having problems don't forget step 0 , haythams seems to have missed it anyhow.

PUT YOUR PHONE INTO BOOTLOADER MODE BEFORE STARTING

  • 0
Posted Image

#27
YLA G

YLA G

    Newbie

  • Members
  • Pip
  • 18 posts
  • Devices:Qtek 8310

I cant make it work. My RUU just crashes >(


same here

and i started in bootloader in step 0 :rolleyes:

  • 0

#28
Gremlin256

Gremlin256

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:Motorola Q

Before starting: Your device needs to be connected to the PC, and in BOOTLOADER mode.


I am a noob. Could someone please tell me how to put the phone in bootloader mode?? Thanks.

Reason I am asking i have a Q with Vista Ultimate. When I try to update the drivers with the drivers from this page, Vista says drivers are not for the OS.

Edited by Gremlin256, 17 July 2007 - 04:46 PM.

  • 0

#29
dan13l

dan13l

    Regular

  • Members
  • PipPip
  • 98 posts

I am a noob. Could someone please tell me how to put the phone in bootloader mode?? Thanks.

Reason I am asking i have a Q with Vista Ultimate. When I try to update the drivers with the drivers from this page, Vista says drivers are not for the OS.


I found that using a very specific version of the update executable worked for me. I posted about it on another forum, will try to find the link. But basically, I tried lots of different version of the file, and only one very specific one worked (ie didn't crash).

  • 0

#30
beckershoff

beckershoff

    Newbie

  • Members
  • Pip
  • 18 posts

i do believe this works for a 32-bit system but not the 64bit.. is there a usb driver for 64bit.. i found one on xda.. heres the link: http://forum.xda-dev...ista 64bit mtty but the drive gives an error code 39 stating it cant install it

Hi, I've got the same problem with my vista 64bit :)
I don't have any 32bit windows installed,I've only got 64bit vista and OSX (I''ve got a macbook).
Is there any other way to update my rom?(except of course installing a 32bit windows version :P)
And has anyone succed in updating wm6 trough a memory card?(tried already renaming RUU_signed.nbh to TRINIMG.nbh like described on Wiki Trinity SDCardFlashing but i didn't worked ;))

Thanx in advance for any help or tips!

  • 0

#31
Gremlin256

Gremlin256

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:Motorola Q

I found that using a very specific version of the update executable worked for me. I posted about it on another forum, will try to find the link. But basically, I tried lots of different version of the file, and only one very specific one worked (ie didn't crash).


Thanks Dan. If you could find the link I would really apprciate it. Thanks :)

  • 0

#32
solaris1

solaris1

    Newbie

  • Members
  • Pip
  • 1 posts
:) :P Very nicely done- Thanks!

  • 0

#33
gwassef

gwassef

    Newbie

  • Members
  • Pip
  • 1 posts

Strange...I get the same response with 1 ROM, but with another, it works fine.

me 2 got the same problem and i do not know what we should do ???

  • 0

#34
AMADO

AMADO

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:i-mate jamin
i'm using windows vista ultmate but when i put my mobile in bootloader my pc dont establish a connectionso that icant step 2
when i did without bootloader no thing changed & still coudnt upgrade any new room

  • 0

#35
Neil5459

Neil5459

    NeilM

  • Members
  • PipPipPipPipPipPip
  • 1,485 posts
  • Gender:Male
  • Location:Saffron Walden, Essex
  • Devices:HTC Titan, iPad 2 3G
  • Twitter:@Neilmell
Just found this thread :) I used the same topic as was posted on XDA Devs when updating my P3600 over Win Vista Home Premium, and following the instructions to the letter, the update worked OK. I had alredy updated WMDC to V6.1 which didn't allow native RUU updates as has been suggested by some users.

After the ROM update, one thing that drove me to distraction was that WMDC would not create a partnership with the newly flashed P3600. Most of teh time, it didn't even acknowledge the USB connection, and when it did, it got no further than 'Attemping to connect' reagrdless of whether RNDIS or Simple connections were enabled on the P3600 (USB to PC)

Eventually I decided to go in to Device Manager (on one of the occasions when at least the device was showing as connecting) and delete the HTC USB Device entry. I then ran Windows Update which proceeded to tell me an updated driver was available. It then downloaded and installed the Vista HTC USB driver, and from that point all went well again, and WMDC ran properly.

So, in my case at least, the spoofed ActiveSync Driver needed to be replaced by the genuine article to allow a partnership to be set up and run. Presumably I'll need to rerun the whole process again next time I update the ROM, unless MS get off their *rses and fix the problem properly.

  • 0
NeilM: Site Moderator and Reviewer on SmartphoneGurus

Posted ImagePosted Image

Windows Mobile Specialist Certification


#36
PRiME2007

PRiME2007

    Newbie

  • Members
  • Pip
  • 1 posts
Driver won't install over top of the Windows Mobile-based device under the Portable Devices section in Device Manager.


Just wondering perhaps this doesn't work on Vista Home edition? or something. I just don't get it how my pc is different to every other pc out there yet my device works fine but can't use RUU. MS really made a big mistake on mobile phones in Vista. Yet no choice in OS since I want DX10 features.

  • 0

#37
agiek

agiek

    Newbie

  • Members
  • Pip
  • 1 posts
hello all,

i follow your step by step upgrade process. and it work properly and successfully ;) :wub: . but the problem is after it upgraded, my dopod 577w still in "red green blue" mode (bootloader), and can not make anything with this device now. try to turn it off and turn on again, but the device straight go to (bootloader). i really confuse about it... need suggestion.... :D :D

thanks b4

  • 0

#38
bikkk

bikkk

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:...
thank for innovation

  • 0

#39
quickarrow

quickarrow

    Newbie

  • Members
  • Pip
  • 1 posts

i do believe this works for a 32-bit system but not the 64bit.. is there a usb driver for 64bit.. i found one on xda.. heres the link: http://forum.xda-dev...ista 64bit mtty but the drive gives an error code 39 stating it cant install it


Thank you very much it worked on my vista 32bits.... take care....!!!

  • 0

#40
creepytallguy

creepytallguy

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:XV6600
my phone lives! i luv u man....

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users