Jump to content


Photo

HELP - I think my c550 is dead

- - - - -

  • Please log in to reply
4 replies to this topic

#1
paulhbartlett

paulhbartlett

    Newbie

  • Members
  • Pip
  • 16 posts
  • Devices:C550
I made the stupid mistake of dropping my c550 on the floor and treading on it by accident at the gym tonight. I think the joystick has been pushed in and damaged the internals. When I switch it on I just get a white screen, with the signal and BT LED's flashing but can't do anything. I have tried active sync'ing it but nothing.

It's unlocked on Vodaphone so I haven't back up'd my contacts in a while. Is there anyway to get the contacts off this phone???

  • 0

#2
FerretAD

FerretAD

    Newbie

  • Members
  • Pip
  • 37 posts
  • Location:Lincolnshire, UK
  • Devices:Orange SPV M600 w/WM6
If your contacts were stored on your phone and not on the SIM, then the only contacts you will have is the contacts from the last sync.

  • 0
Posted Image

#3
paulhbartlett

paulhbartlett

    Newbie

  • Members
  • Pip
  • 16 posts
  • Devices:C550
Which was ages ago....... ;)

Just reading other threads about white screens, is it possible that just the screen is damaged???

  • 0

#4
FerretAD

FerretAD

    Newbie

  • Members
  • Pip
  • 37 posts
  • Location:Lincolnshire, UK
  • Devices:Orange SPV M600 w/WM6
It could be, so your best bet is to turn the phone off completely, turn it back on, leaving it for 5-10mins to start up fully, then type in your PIN then press the left soft-ket to accept the PIN (if you have a PIN), then try sync'ing again.

Failing that, its then a more serious problem, not just a broken screen.

Correct me if i'm wrong, but doesn't the C550 only have 1 ribbon for the screen ? So I don't think it will be just a slipped ribbon.

  • 0
Posted Image

#5
paulhbartlett

paulhbartlett

    Newbie

  • Members
  • Pip
  • 16 posts
  • Devices:C550
I am pretty sure its more than just the screen as if I try and ring the phone, the line rings but the phone does nothing ;)

I just need to get my contacts off as I have bought a c600

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users