Jump to content


Photo

SPV C500 and Orange simcard problem.

- - - - -

  • Please log in to reply
10 replies to this topic

#1
joe194b

joe194b

    Newbie

  • Members
  • Pip
  • 12 posts
  • Location:UK
  • Devices:SPV M700
I've just taken a new contract out with orange (Dolphin30 + SPV M700) and everything works fine but the wife doesn't like the M700 so i've put the simcard in the old C500. I can make/receive calls and receive text but i can't send text.

When i try to send a text i get the message "Your SMS message has not been sent because the SIM is not valid". Orange have sent a replacement simcard but it's still the same. I rang orange again but they are not interested because it works in the M700.

I've tried the simcard in the following phones.

Nokia 6310i - works
Nokia 6230i - works
3x SPV C500 - won't send text
2x SPV C600 - won't send text
SPV M700 - works

It looks like the simcard won't work with the SPV C series. I've flashed the firmware to the latest by orange uk and tried a hard reset but still no joy.

Has anyone else come across this problem?

Any help appreciated.

regards Joe

  • 0

#2
skiboot

skiboot

    Newbie

  • Members
  • Pip
  • 2 posts

I've just taken a new contract out with orange (Dolphin30 + SPV M700) and everything works fine but the wife doesn't like the M700 so i've put the simcard in the old C500. I can make/receive calls and receive text but i can't send text.

When i try to send a text i get the message "Your SMS message has not been sent because the SIM is not valid". Orange have sent a replacement simcard but it's still the same. I rang orange again but they are not interested because it works in the M700.

I've tried the simcard in the following phones.

Nokia 6310i - works
Nokia 6230i - works
3x SPV C500 - won't send text
2x SPV C600 - won't send text
SPV M700 - works

It looks like the simcard won't work with the SPV C series. I've flashed the firmware to the latest by orange uk and tried a hard reset but still no joy.

Has anyone else come across this problem?

Any help appreciated.

regards Joe



Hi Joe, have just come across your problem, I too have had to resort to my old spv C500 and am getting the same fault that you had.
Did you resolve the fault, if so I would be greatful for your input.

Regards Greg H.

  • 0

#3
joe194b

joe194b

    Newbie

  • Members
  • Pip
  • 12 posts
  • Location:UK
  • Devices:SPV M700
Gregg,

Sorry for the late reply. Unfortunatley no joy at all :D While playing around with it i also discovered that the Sim Manager can't access the sim card either.

As the wife still doesn't like the M700 we are now using an old Nokia 6310i ;)

regards
Joe

  • 0

#4
rekall

rekall

    Regular

  • Members
  • PipPip
  • 91 posts
  • Devices:Samsung i200, Orange M700
Bugger am getting the same problem. Got upgraded to the M700 but like using my C600 at the weekends and on holidays when I dont need the features of the M700. Voice and data calls work, text do not - comes up with the same 'SIM is not valid' error.

Really annoying as this worked when I had a M3100... ;)

  • 0

#5
colincliff

colincliff

    Newbie

  • MoDaCo Silver
  • Pip
  • 31 posts
  • Devices:O2 IQ
I've go this problem too, although i am using a new orange contract sim with an unlocked Imate sp5.
Seems like Orange have put some kind of lock on using the phone with different roms

I am going to try putting an orange rom on my sp5 to see if it helps

  • 0

#6
joe194b

joe194b

    Newbie

  • Members
  • Pip
  • 12 posts
  • Location:UK
  • Devices:SPV M700
My C500 is on the latest official rom and still no go. I've tried the Imate roms and they don't work either. I got a new PAYG simcard from Orange and that doesn't work either. I'm thinking that Orange have changed the software on the simcard which in tern has made it incompatible with the C500.

On a another note i tried the simcard on a C600 with the built in sim manager software and it worked fine so C600 owners could try updating to the latest offical orange rom to see if that fixes the problem but that doesn't help my C500 problem.

regards Joe

PS. The M700 is an awesome phone and i would recommend one to anybody that loves cool gadgets

Edited by joe194b, 23 May 2007 - 06:53 PM.

  • 0

#7
joe194b

joe194b

    Newbie

  • Members
  • Pip
  • 12 posts
  • Location:UK
  • Devices:SPV M700
I tried a hacked version of WM5 on it and it didn't work. I've sold the phone now and this has been replaced with a Nokia 6300 which the wife loves and i have to admit is very impressive. I'm now on a mission to find a good sim only contract for my Trinity.

regards Joe

  • 0

#8
joe194b

joe194b

    Newbie

  • Members
  • Pip
  • 12 posts
  • Location:UK
  • Devices:SPV M700
I think i've found the answer to the problem although i can't try this as i no longer own a C500.

Orange use two types of simcard profile 15 and profile 30...

Profile 15 = GSM
Profile 30 = GSM/3G

Both types of simcard will work in GSM & 3G handsets but some GSM handsets are not compatible with profile 30 simcards.

So a quick call to orange cs requesting a profile 15 simcard should sort the problem out.

hope this helps someone


regards Joe

  • 0

#9
joppadoni

joppadoni

    Newbie

  • Members
  • Pip
  • 1 posts
hi guys not quite true about the profiling.

orange sim profiles update and change as and when required really

for instance think profile 39 is the current 3g profile, and 20 or something for gsm.

the issue is that your using a 3g sim in the handset, some profiles are unaffected however.

i am investigating this at the moment and will have sim manufactures updated asap.

fast fix is to use a gsm sim in the handset.

hope this helps.

:D

Edited by joppadoni, 20 March 2008 - 04:11 PM.

  • 0

#10
nicollow

nicollow

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:null
Hi, I had this problem too and now its all sorted thanks to a nice Orange girl in Glasgow. The problem is that the new Orange SIM cards are 3G and the SPV C500 are not 3G compatible, or thats what the girl said. She phoned up Orange at get them to send a 2.5G card out (?!). It looked difrerent (purple rather than black and orange). I put in and now it works a treat. I sent my other SIM back to Orange and they didnt even charge me. Nice...

  • 0

#11
fraktal

fraktal

    Regular

  • Members
  • PipPip
  • 89 posts
  • Location:Loughborough, UK
  • Devices:M3100
I have the same problem (here's the xda-dev thread). I came to the same conclusion. From what I hear orange is pretty good at sending new SIMs out.

Maybe a mod could sticky this, or add it to AWarner's stickied thread because it seems to be a common problem.

Edited by fraktal, 19 July 2008 - 08:55 AM.

  • 0
Posted Image




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users