Jump to content


Photo

Backlight won't turn off!

- - - - -

  • Please log in to reply
61 replies to this topic

#21
jporch316

jporch316

    Enthusiast

  • Members
  • PipPipPip
  • 258 posts
  • Location:Pontypridd
  • Devices:Diamond Tattoo Optimus
Hey

I Presume the 30 is refrring to seconds before backlight dims - Using PHM registry editor i didint need to unlock phone to alter the value - after installing core media player the value was set on 4 miliion odd!

  • 0

#22
Griff_FFOC

Griff_FFOC

    Addict

  • Members
  • PipPipPipPipPip
  • 501 posts
  • Location:Sunderland
  • Devices:SPV C600/E650
I'm getting a slightly different issue, but it could be the same solution.

Current Power settings:
Backlight timeout on Batt - 15 seconds
Display time out on Batt - 1 minute.

Now, it seems that if I lock the devce holding the red key down, it dims and switches the screen off in seconds, which is fine. But if I leave it unlocked, the screen dims in the correct time scale (actually 10 seconds instead of 15 but that's fine) , but it seems the display takes, well, it's getting on for 5 minutes now and it's still only dimmed.

So far i've installed:
Facade,
MS Live Search,
Smart2Go,
Resco Trial Suite

The current value of display in HKCU/CONTROL PANEL/POWER is 4294967295.

Is this value correct, or does it need changing to something else?
If it needs changing it may be a prob if it needs app unlocking as the cab I got from http://spvunlock.rd.francetelecom.com/ won't run on my E650 for some reason.

  • 0

#23
Dster

Dster

    Regular

  • Members
  • PipPip
  • 51 posts
The registry hack worked for me.

But, after a while, and without installing any new software, it changed back to 0.

Has anyone else had to do the registry hack multiple times without installing new software?

  • 0

#24
Griff_FFOC

Griff_FFOC

    Addict

  • Members
  • PipPipPipPipPip
  • 501 posts
  • Location:Sunderland
  • Devices:SPV C600/E650
Well, I ran "Clear storage" before the phone went back and now it switches the screen off fine without having to lock the phone.
Will have to check this issue after installing each software to see what was the culprit for me.

  • 0

#25
jporch316

jporch316

    Enthusiast

  • Members
  • PipPipPip
  • 258 posts
  • Location:Pontypridd
  • Devices:Diamond Tattoo Optimus
Griff

HKCU/CONTROL PANEL/POWER is 4294967295 is what mine was set at after installing TCPMP - thats the value I changed back to 30

Jporch

  • 0

#26
Griff_FFOC

Griff_FFOC

    Addict

  • Members
  • PipPipPipPipPip
  • 501 posts
  • Location:Sunderland
  • Devices:SPV C600/E650
It seems Smart2Go messes with the display turning off too.

  • 0

#27
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,227 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien
Now why can't software developers just manage the backlight properly!

IIRC TomTom used to cause this too if it didn't exit cleanly.

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#28
kegia20

kegia20

    Newbie

  • Members
  • Pip
  • 11 posts
  • Devices:HTC S710
after changing registry string value to 30, if i open tomtom, the value goes back to a very high value (453807 for example).. solutions?

  • 0

#29
abowen500

abowen500

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:null

after changing registry string value to 30, if i open tomtom, the value goes back to a very high value (453807 for example).. solutions?


Hey gang,

I've had success with creating the Dispay value as a DWORD. I think a string value is contributing to your problems. My Vox is configured for the backlight to remain on for only 10 seconds but the screen is on indefinitely for GPS use. The screen and backlight both turn off in under 10 seconds when I lock the device.

  • 0

#30
El Matarife

El Matarife

    Newbie

  • Members
  • Pip
  • 21 posts
  • Devices:T-Mobile G2, SPV E650

Great tip. I had the same problem after installing tomtom 5.2 on my SPV E650 and was searching for a solution.

I have some feedback too: Using MobileRegistryEditor.exe (version 1.1) I was able to make the setting change without needing any application unlock.
Maybe that's because my Dutch SPV E650 doesn't have an application lock, or maybe that's just because of how MobileRegistryEditor.exe works. Anyway, solution tested and working great.


I also just used MobileRegistryEditor.exe v1.1 on my UK Orange SPV E650 to correct the HKCU/CONTROL PANEL/POWER value to 30.

The app worked like a dream and connected to the phone first time. I did not have to application unlock anything.

I got my phone as an upgrade direct from Orange, I'm wondering if only phones purchased from Orange shops have the locked "Access Denied" problem?

My last smartphone was also an upgrade and I never found an app I couldn't install on it - hence I've yet to need to go through the app unlock procedure (which thereby remains a mystery to me!).

  • 0

#31
El Matarife

El Matarife

    Newbie

  • Members
  • Pip
  • 21 posts
  • Devices:T-Mobile G2, SPV E650
Righto, as is the way with software I spoke too soon...

Altering the registry value has caused a strange side-effect:

After the specified time delay has lapsed, and just before the backlight dims, the phone's display now reverts to the home screen. So if you're pausing for a moment while using any app (say typing a text), before the screen dims it jumps back to the home screen. You then have to press the back up button to return to what you were doing before.

Anyone else had this?

This is annoying.

  • 0

#32
Griff_FFOC

Griff_FFOC

    Addict

  • Members
  • PipPipPipPipPip
  • 501 posts
  • Location:Sunderland
  • Devices:SPV C600/E650
Maybe a silly question, but have you tried altering the "Timeout" in the "Start >> Settings >> HomeScreen" page? Or is it doing something it shouldn't?

  • 0

#33
kegia20

kegia20

    Newbie

  • Members
  • Pip
  • 11 posts
  • Devices:HTC S710
nobody can help me? I told that i changed the value in power -> Display to 30..but my light turns completely off only if i block the keypad.. :rolleyes:

  • 0

#34
El Matarife

El Matarife

    Newbie

  • Members
  • Pip
  • 21 posts
  • Devices:T-Mobile G2, SPV E650

Maybe a silly question, but have you tried altering the "Timeout" in the "Start >> Settings >> HomeScreen" page? Or is it doing something it shouldn't?


Yes, you were right. The homescreen thing actually had nothing to do with editing the POWER value in the registry.

I had managed to alter a completely unrelated setting without realising.

D'oh!

All working now.

  • 0

#35
nehvada

nehvada

    Regular

  • Members
  • PipPip
  • 82 posts
  • Location:Düsseldorf
  • Devices:Acer Liquid and iPhone 3Gs

Hey gang,

I've had success with creating the Dispay value as a DWORD. I think a string value is contributing to your problems. My Vox is configured for the backlight to remain on for only 10 seconds but the screen is on indefinitely for GPS use. The screen and backlight both turn off in under 10 seconds when I lock the device.


that worked perfect for me, thanx!

the display value was originally there and changed to 4billionsomething. but quite funny after a hard reset this value disappeared, but the timeout still was messed up. so i created this value as dword and bingo! :rolleyes:

  • 0

#36
colonel_butt

colonel_butt

    Regular

  • Members
  • PipPip
  • 119 posts
  • Devices:HTC Touch, Samsung i600 & Q1
The bug about the backlight not turning off is not due to any particular program. I just fiddled with the power settings and then it stuck on. The code is forgetting to reset the backlight. This should be fixed in the next firmware release.

  • 0

#37
Blaufeld

Blaufeld

    Newbie

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Location:Grosseto, Tuscany - Italy
  • Devices:HTC S710

Great tip. I had the same problem after installing tomtom 5.2 on my SPV E650 and was searching for a solution.


SAME exact prob after installing TT5.2 on my S710 - and the solution worked great, too! :rolleyes:

  • 0
"A biker is a man that think of the road
not as a way to reach a place,
but as a long moment to reach himself."

#38
b0x

b0x

    Regular

  • Members
  • PipPip
  • 77 posts
  • Location:North London
  • Interests:Tech
Just here to say thanks.

I had both the timeout and the backlight problem as betaplayer had changed it to 453807.

Extra thanks to Griff_FFOC for pointing out the obvious, it's not a very well worded section of the phone and i'd altered it without realising!

  • 0

#39
LechuckE650

LechuckE650

    Newbie

  • Members
  • Pip
  • 12 posts
  • Devices:HTC Touch Diamond

you have to change a registry key i think it is HKCU/CONTROL PANEL/POWER then values and change it to 30 or 60. this is a knowm bug on vox (see www.smartphonefrance.fr for further info)



This forum is great. Only been a member for a day but you guys have helped me out twice so far. This backlight bug was really doing my head in.

Cheeeeeeeers :rolleyes:

  • 0

#40
Carlos Fandango

Carlos Fandango

    Newbie

  • Members
  • Pip
  • 5 posts
  • Devices:SPV c500
This bug has been an issue for me for a number if days now. Glad I checked up on this before doing a reset.

What's the best reg editor to use which doesn't require copying to the sd card using a card reader?

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users