Jump to content


Photo

SMT5600 unlocked, Vodafone SIM doesn't work

- - - - -

  • Please log in to reply
3 replies to this topic

#1
Mechanicaldan

Mechanicaldan

    Newbie

  • Members
  • Pip
  • 40 posts
  • Location:Aberdeen
  • Devices:v1415 aka Vox
Hi,

I've been using my unlocked SMT5600 in the USA on Cingular for almost 2 years. It was originally an AT&T phone. I've just moved to Scotland and I now have a Vodafone SIM that I've been trying to use with it. The Cingular SIM will pick up the O2, and Orange networks and works just fine for making local and international calls, but that SIM will be cancelled soon. When I install the Vodafone SIM, the phone boots fine, but searches for a network and never finds one.

The phone is both network and application unlocked. What am I doing wrong? Any help is greatly appreciated, as I love this phone. I'm kind of lost without it.

Cheers,

Dan

Edited by Mechanicaldan, 07 May 2007 - 11:53 AM.

  • 0

#2
everton2004

everton2004

    Diehard

  • Members
  • PipPipPipPip
  • 375 posts
  • Location:Merseyside, UK.
  • Devices:Xperia X1 (WinMo 6.5)

Hi,

I've been using my unlocked SMT5600 in the USA on Cingular for almost 2 years. It was originally an AT&T phone. I've just moved to Scotland and I now have a Vodafone SIM that I've been trying to use with it. The Cingular SIM will pick up the O2, and Orange networks and works just fine for making local and international calls, but that SIM will be cancelled soon. When I install the Vodafone SIM, the phone boots fine, but searches for a network and never finds one.

The phone is both network and application unlocked. What am I doing wrong? Any help is greatly appreciated, as I love this phone. I'm kind of lost without it.

Cheers,

Dan


Could be wrong but AFAIK, Vodafone UK use the GSM900 band and I did a quick Google search on the SMT5600 and it looks like it does not support this band. Anyone else here confirm this?

  • 0
Gadgets:

SonyEricsson Xperia, HP iPaq 614c, MDA Vario II, Moto MPX220


#3
damonb10

damonb10

    Newbie

  • Members
  • Pip
  • 9 posts
  • Devices:SMT 5600

Could be wrong but AFAIK, Vodafone UK use the GSM900 band and I did a quick Google search on the SMT5600 and it looks like it does not support this band. Anyone else here confirm this?


You are correct. The SMT5600 is GSM 850/1900. No support for 900.

  • 0

#4
Mechanicaldan

Mechanicaldan

    Newbie

  • Members
  • Pip
  • 40 posts
  • Location:Aberdeen
  • Devices:v1415 aka Vox
I was wondering about that. Damn. Hmm, I guess it's finally time to upgrade to a Vox, or maybe a Treo 750. I better make sure I get a quad band phone this time. :rolleyes:

Thanks for the responses.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users