Jump to content


Photo

Prophet - Anybody else had USB/charge port problems?

- - - - -

  • Please log in to reply
2 replies to this topic

#1
carlosp_uk

carlosp_uk

    Regular

  • Members
  • PipPip
  • 104 posts
Hi there

I've had my prophet (M600) for only 9-10 months and now it has stopped charging; in fact the miniUSB port is completely non-functional, it won't charge or sync. I had taken good care of the phone so naturally I have returned it to HTC Europe for a warranty repair.

Unfortunately, HTC are refusing to repair it under warranty as they are claiming it was mis-treated. As I know this not to be true, I was wondering...

...has anybody else had problems with the USB port on the prophet (M600) failing to work, or breaking? I have heard similar stories on this board in the past and thought that if I could gather a little anecdotal evidence it might support my claim.

Yours gratefully, in advance,


Carlos

  • 0

#2
PaulF

PaulF

    Regular

  • Members
  • PipPip
  • 115 posts
  • Location:Hampshire, UK
  • Devices:SPV M600

Hi there

I've had my prophet (M600) for only 9-10 months and now it has stopped charging; in fact the miniUSB port is completely non-functional, it won't charge or sync. I had taken good care of the phone so naturally I have returned it to HTC Europe for a warranty repair.

Unfortunately, HTC are refusing to repair it under warranty as they are claiming it was mis-treated. As I know this not to be true, I was wondering...

...has anybody else had problems with the USB port on the prophet (M600) failing to work, or breaking? I have heard similar stories on this board in the past and thought that if I could gather a little anecdotal evidence it might support my claim.

Yours gratefully, in advance,
Carlos


Yep, mine broke recently - not sure what happened or when it did, but suddenly Active Sync stopped working. After three reinstalls of the software, I noticed that the plastic lug in the centre of the socket on the phone had vanished (presumably broken off), and left the metal wires behind. 2 of these had got bent, and so no longer connected with the USB plug properly (luckily I could still charge it, and only lost data connectivity).

I phoned Orange, and managed to get them to replace it under warranty (it was about 9 months old).

They brought me out a new phone the following day.

Good luck!

  • 0

#3
wh_hsn

wh_hsn

    Newbie

  • Members
  • Pip
  • 5 posts
  • Devices:JamIn
Hi,

I also have a problem with my USB, please see here:

http://www.modaco.co...t=0#entry822769

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users