Jump to content


Photo

Paul's guide to... backing up, rebuilding and restoring your SPV M700 ROM

* * * * * 2 votes

  • Please log in to reply
28 replies to this topic

#21
balu06

balu06

    Newbie

  • Members
  • Pip
  • 1 posts
Hi
have a Problem to save my ROM.

Please help me.

Error:

after imgfstodump part02.raw > Cannot map file part02.raw

Greetings

Balu

  • 0

#22
linxbox

linxbox

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:SPV M700
My SPV M700 has developed a fault with the GPS :wub:

The trouble is, I've flashed the ROM to WM6 and therefore need to flash it back again before returning it. Stupidly I didn't backup the ROM beforehand and so am now a little scuppered ;)

Can anyone help me by providing an image of their original Orange WM5 ROM or something very similar to it?

Thanks

  • 0

#23
Reddall

Reddall

    Newbie

  • Members
  • Pip
  • 1 posts
Hi and thanks for the ROM backup Procedure! I followed it to the letter (I think) and I have one observation and one question.

1. Obs - when I split the file the bit was named '06_Uknown.nb' rather than '06_os.nb' so I went ahead and substituted 'unknown' wherever it said 'os'. Should thisi be OK?

2. Question - after I merged it all back I re-flashed the SPV M700 and it looks much the same as before BUT I after some thought I wondered why it hadn't adopted the splash screens from the donor ROM since as far as I could (mis)understand we only changed the OS part of the donor ROM? Am I right or completely misunderstanding what I am doing here. For this dumped ROM to be just like the original Orange ROM shouldn't I be building in all the other bits from the original to overwrite the donor??

  • 0

#24
eaglesteve

eaglesteve

    Newbie

  • Members
  • Pip
  • 5 posts
  • Devices:Dopod U1000
Hi, all of you who have gone through step 2 should be able to answer my question.

I try to follow the procedure to backup my WM6 ROM on my Athena/Dopod U1000.

In step two, my value for Part02 is 0xZZZZZZ.  At command prompt, when I typed in pdcread -w -d FLASHDR -p Part02 0 0xZZZZZZ, I got the following error message:

ERROR: ITTFFSGetInfo = the device is not ready for use.
WARNING: using default 512 bytes for sectorisize
Hexdump TFFSToStdot (0x0, 0xZZZZZZ)
ERROR: ITReadDisk: outbug==NULL
- The device is not ready for use.

My question is why am I getting this message.  

If I put the device into bootloader mode before executing the above command, then I don' t get the above message, but nothing seesm to be happening.  When I look into the ROM directory with file explorer, I don't find any Part02.raw there.

What am I doing wrong?

Edited by eaglesteve, 04 November 2007 - 06:15 AM.

  • 0

#25
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,254 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien
Er, 0xZZZZZZ is not a valid value!

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#26
Rob_Quads

Rob_Quads

    Enthusiast

  • Members
  • PipPipPip
  • 168 posts
Thanks for the brilliant walkthough.

I have tried following all the instructions and appear to have rebuild a copy of my Orange ROM - producing a RUU_signed.nbh sized 56,561,646 bytes but I am having a problem checking it works with the phone. When i run the ROMUpdateUtility.exe utility it makes the M700 go into a bootloader? mode - the rainbow screen BUT when this happens the Update software is saying that the phone has been disconnected and ends. To get the phoneback I have to pull the battery on the phone.

FOLLOWUP

The problem was due to having an SD card in on the first reboot - without it reboots fine and works as expected...BUT

I am now having a problem sending any SMS messages - both using my restored WM5 and WM6 roms (I have tried running the UK customisation but it still does not work)

Edited by Rob_Quads, 04 January 2008 - 04:24 PM.

  • 0

#27
Rob_Quads

Rob_Quads

    Enthusiast

  • Members
  • PipPipPip
  • 168 posts
I need to return my phone back to factory. I have a backup of the orange WM5 rom to install but it still has the non-factory bootloader on it. Is there a way to get back the orange bootloader?

Cheers

Rob

  • 0

#28
eaglesteve

eaglesteve

    Newbie

  • Members
  • Pip
  • 5 posts
  • Devices:Dopod U1000

Er, 0xZZZZZZ is not a valid value!

P



I know zzzzzz is not a valid value, just using it to represent what I saw on the screen from previous step.  This is what I had :


79.92 M (0.4fec000) TRUEFFS

|          3.06M (0X30fc00) Part00

|           3.44 (0X370000) part01

|          66.38 (0X4260000) Part02



I do not see from the output a line that says FLASHDR.  I saw only values for TRUEFFS.  My device has been unlocked using Olipro's Athena Unlocker before, so wonder if this would make a differenct.



Therefore what I typed in was pdcread -w -d FLASHDR -p Part02 0 0X4260000.



Any idea why I did not see the FLASHDR?

  • 0

#29
cedexya

cedexya

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:Eten M700
Good Job, Congratulations Paul.
This procedure worked perfectly for the Eten M700 Glofish ...
1) 'pdocread-w-d FLASHDR-p Part02 0 0x0000000 Part02.raw'
2) 'imgfstodump part02.raw'
but in this dump I don't have all the necessary information, like the registry of the WM6 or the programs pre-installed by Eten and I need it because my purpose to back up the WM6 is available in Brazilian Portuguese that is being asked for a lot of people and after ACER having bought the Eten Corp is not being possible to achieve, they are not giving support and can only be achieved the English ROM.
My idea was to use the ROM in English and replace the entire dump with the version in Portuguese, but it will miss the registry and applications, any suggestions?
Thanks in advance!

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users