Jump to content


Photo

Charging problem? Red LED flash

- - - - -

  • Please log in to reply
5 replies to this topic

#1
dav2287

dav2287

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:s620
When i try to charge my dash, the red LED at the top of the phone briefly blinks red and then nothing else happens. I cannot get the phone to power on, either.
Does anyone know what this means?

  • 0

#2
rope

rope

    Newbie

  • Members
  • Pip
  • 28 posts
  • Devices:O2 XDA Cosmo (=Excalibur)

When i try to charge my dash, the red LED at the top of the phone briefly blinks red and then nothing else happens. I cannot get the phone to power on, either.
Does anyone know what this means?


I think there are two possibilities:
1. (I don't hope for you) the "BIOS" is broken and the phone therefore cannot boot
2. the battery is broken

  • 0

#3
dropofdreams

dropofdreams

    Newbie

  • Members
  • Pip
  • 28 posts
  • Devices:Faraday, Excalibur
Not that it helps, but I'm gonna bet on the Battery being dead...actually, you know what, I'm gonna test it now.. BRB
Okay...Back. my test was not conclusive..I figured that perhaps if i took the battery out of the unit itself and then plugged it in, I might just get the same results as what you have reported. However, the end result of this was nothing. The light didnt light up at or nor was the unit able to power on despite bing plugged in. My next test, I placed it in my microwave and turned it on high for 15 seconds and though the rubberized casing was a bit gooey, I stilll wasn't able to get anything...So maybe it is a bios error...

  • 0

#4
rope

rope

    Newbie

  • Members
  • Pip
  • 28 posts
  • Devices:O2 XDA Cosmo (=Excalibur)

My next test, I placed it in my microwave and turned it on high for 15 seconds and though the rubberized casing was a bit gooey, I stilll wasn't able to get anything...


:rolleyes: :D why do you do such stupid things?
Did you hope to repair a broken soldering point? :P

I could not at least imagine what this would be good for...

  • 0

#5
dav2287

dav2287

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:s620
Replaced the battery, and now it works!!!

hooray!!! thanks guys!

  • 0

#6
dropofdreams

dropofdreams

    Newbie

  • Members
  • Pip
  • 28 posts
  • Devices:Faraday, Excalibur
Almost 2 years later, I come back to say that I was just kidding...

Edited by dropofdreams, 22 January 2009 - 07:00 AM.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users