Jump to content


Photo

SPV E650 de-Brand + Fix Pack 0.5

* * * * * 3 votes

  • Please log in to reply
366 replies to this topic

#1
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,222 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien
Update: Orange app unlock no longer required!

The HTC Vox derivatives are great devices, and it's no secret that i'm a fan.

I was lucky enough to have a pre production HTC S710 for a while and when the device was released, I was first in the queue to splash out my hard earned on a production unit. I know that many readers also own a HTC Vox based device, particularly the SPV E650 variant from Orange.

While the E650 has been generally well received, there has been overwhelming feedback from the community that the device has 2 faults. Firstly the ugly, half-baked and non-removable Orange customisation (colour scheme, icons, start menu layout etc) and secondly the problem with installing software on the device that would cause it to hang.

Ever since this feedback came to light, I have maintained that when I got hold of a SPV E650, I would do my best to provide a fix for these issues. I'm therefore proud to present the MoDaCo SPV E650 de-Brand + Fix Pack 0.5.

Firstly, an apology - this pack has been a while coming, and there is a very simple reason - I only got a E650 last Friday. Despite repeated assurances from Orange that they were doing their best to get me a handset (and an Orange Samsung i600 for that matter), nothing has materialised. It seems that unless you're writing for a broadsheet and can get something in print, you're low down the pecking order. Go figure! As I know members are desperate for this package, I bought a SIM free unit in order that I could deliver as promised.

So, what does the de-Brand and Fix Pack do? Changes include but are not limited to...
  • Reset of icons to default Windows style
  • Reset of icon layout to a more traditional Windows layout
  • Reset of colour scheme and home scheme to default Windows style
  • Reset of icons in call related screens to default Windows style
  • Reset of Camera dialogues to grey
  • Reset of Security policies to match that of the HTC S710
  • Fix install bug (installs hang when keyboard is out or input is not in XT9 mode)
  • Fix TomTom device ID bug (TomTom reports changed device ID after Orange app unlock)
...it's a very extensive tweak! I'm proud to say that the CAB file to install the tweak is my most advanced yet, however due to the fact that absolutely everything has been accomplished using registry tweaks, shortcut tweaks and one small compressed file update, it comes in at under 60k!! :rolleyes:

Installation Instructions

To install, carry out the following steps. Please note that this pack is intended ONLY for UK SPV E650s. Installation on other devices may produce unexpected results.
  • Hard reset device (using the 'Clear Storage' option on the Start Menu, or by tapping the power key from off while holding the two soft keys, then pressing 'Green'). This step is highly recommended, although nothing terrible should (theoretically) happen if you do not hard reset before install.
  • Install the PREP CAB by copying to your device and launching using File Explorer: Attached File  MoDaCo_SPV_E650_de_Brand___Fix_Pack.PREP.CAB   1.25KB   4454 downloads
  • Install the MAIN CAB by copying to your device and launching using File Explorer (be patient, after clicking it takes a short while to get going!): Attached File  MoDaCo_SPV_E650_de_Brand___Fix_Pack_0.5.CAB   55.5KB   4266 downloads
  • Reset (power off / on) your device when prompted - This step is essential.
It's as simple as that :P

I've included some before / after screenshots below. Please note that this pack has performed as intended in my testing, however if you find some remaining branding or continue to have install problems, please let me know so I can provide an update.

FINALLY, I would ask that if you find this pack useful (or indeed not), you reply in this topic. Doing so will make it easier for me to show Orange that they really should try and furnish MoDaCo with the devices they promise.

Thanks and enjoy! :D

P

PS This pack does not have an uninstall option - you can reverse it's effects my hard resetting again.

PPS I have also attached below a Pack to fix, but not de-Brand, for those that like the Orange icons, or perhaps don't want to do the app unlock (it shouldn't be required for the fix only).

Attached File  MoDaCo_SPV_E650_Fix_Pack_0.5.CAB   48.69KB   1331 downloads

Attached File  homebefore.PNG   47.65KB   1337 downloads Attached File  startbefore.png   20.09KB   999 downloads Attached File  historybefore.png   4.32KB   806 downloads Attached File  camerabefore.png   4.55KB   854 downloads

Attached File  homeafter.png   53.27KB   1346 downloads Attached File  startafter.png   29.57KB   1098 downloads Attached File  historyafter.png   13.7KB   952 downloads Attached File  cameraafter.png   4.09KB   994 downloads


  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#2
Electronic Punk

Electronic Punk

    Regular

  • MoDaCo Silver
  • PipPip
  • 129 posts
I wonder how long Orange worked on that grey theme.

  • 0

#3
chucky.egg

chucky.egg

    Did I say that out loud?

  • MoDaCo Silver
  • PipPipPipPipPipPip
  • 4,724 posts
  • Location:Kent, England
  • Interests:Sleeping
  • Devices:Desire S
  • Twitter:@chucky_egg
How stuningly ugly is that Orange theme?!

  • 0

#4
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,222 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien
It doesn't exactly show WM6 in it's best light...

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#5
DuNcAn SPv E650

DuNcAn SPv E650

    Newbie

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Location:Netherlands
  • Devices:SPv e200, SPv C500, SPv E650
Woohoo!!!!!!!!!!!!!!!!!!!!! FINALLY!

Downloaded, installed, followed the instructions...
It freaking works ! :rolleyes: From the looks of it Paul did a COMPLETE de-brand. No bugs or errors. I'll report back as soon as I stumble upon something.

  • 0

Don't forget to read the small print


#6
moham_i

moham_i

    Regular

  • Members
  • PipPip
  • 51 posts
ur a legend!

this is the last thing i needed!

  • 0

#7
DuNcAn SPv E650

DuNcAn SPv E650

    Newbie

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Location:Netherlands
  • Devices:SPv e200, SPv C500, SPv E650
Ok, after installing the SPV E650 de-Brand it looks like the security was back on. Wasn't able to copy to and from the Windows folder. Not sure if others will encounter this problem, but it can be fixed by running the application unlocker again.

  • 0

Don't forget to read the small print


#8
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,222 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien
Will amend initial post to that effect.

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#9
DuNcAn SPv E650

DuNcAn SPv E650

    Newbie

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Location:Netherlands
  • Devices:SPv e200, SPv C500, SPv E650
Oh... on the Orange matter...
Not sure whether or not this is the right place for the post, but I trust the moderaters to move it if not.

Spoke with Orange (Netherlands) customer support and data/technical support more than once about a.o. the hanging of the spinning wheel after the application unlock, and the missing case which, according to the item's list, should be in the box. They kept telling me there are NO known issues with the SPV E650.
Today, finally, I was promised they'd take it up with the right people at Orange and they'd report back after evaluation. Funny thing is... they told me to check the forums on the net related to the SPV E650 :P
People... DO take up the phone and call Orange about these things. I was compensated financially for the missing case :D And DO nag/whine/beg/plead about the bug when installing programs on the SPV E650. This is the only way to make some people over there get their heads outta their... uhmmm... you know :rolleyes:

  • 0

Don't forget to read the small print


#10
lsainsbury

lsainsbury

    Newbie

  • Members
  • Pip
  • 28 posts
Pitty there's no MSN Messenger on the de-brand!!

  • 0

#11
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,222 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien
Although it would be relatively straightforward to add from another Vox ROM, i'm pretty sure it would not be legal to do so, else I would :rolleyes:

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#12
gbshahaq

gbshahaq

    Newbie

  • Members
  • Pip
  • 9 posts
  • Devices:SPV C600 / Orange E650
great job Paul - followed instructions and now have a much nicer looking phone....
:rolleyes:

  • 0

#13
wired84

wired84

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:SPV E650
Brilliant, thank you, although it did say 'the program you have installed my not display correctly as it was designed for a previous version of windows mobile' but it seemed to have worked, I didnt do the full clear storage I just installed as is, seems to have worked perfectly and the security patch is still working as it was before can delete and change icons in the windows directory, got the HTC mobile theme provided by looby! Also got google maps working with bluetoothgps also all thanks to this site

Cheers

  • 0

#14
awm

awm

    Newbie

  • Members
  • Pip
  • 7 posts
  • Devices:SPV C600, E650

FINALLY, I would ask that if you find this pack useful (or indeed not), you reply in this topic. Doing so will make it easier for me to show Orange that they really should try and furnish MoDaCo with the devices they promise.


Fantastic - thanks a million Paul! (Thanks also for the prompt via email)

Installed fine without a hard reset - looks great!, I've yet to test the install fix, will let you know how it goes.

Thanks again.

A.

  • 0

#15
Prof. Yaffle

Prof. Yaffle

    Regular

  • Members
  • PipPip
  • 78 posts
  • Gender:Male
Thanks Paul. I thought I'd chance it without a hard reset and it installed fine. The only problem I have found is when I tried to run Tomtom. It asked me to activate the map and now comes up with a different product code. Was working okay before though.

  • 0

#16
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,222 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien

It asked me to activate the map and now comes up with a different product code. Was working okay before though.

That makes no sense at all! :rolleyes:

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#17
paholman

paholman

    Diehard

  • Members
  • PipPipPipPip
  • 408 posts
Hi Paul,

Thank you for creating this. The De-Brand works a treat.
Enhancement suggestion: If restart is mandatory, would you be able to force a restart via the cab?

Regarding the Installer problem, I read this and immediately installed as per the instructions as I'd spent hours trying to work out this install problem.

I followed the instructions, above, but the 1st program I tried to install "card_cache", same spinning wheel problem :rolleyes:

Edited by paholman, 11 June 2007 - 01:03 PM.

  • 0

#18
Prof. Yaffle

Prof. Yaffle

    Regular

  • Members
  • PipPip
  • 78 posts
  • Gender:Male

That makes no sense at all! :rolleyes:

P


Nore to me. Definitely been working ok since I got the phone. I've checked TTCode.com and it has 2 device codes listed (one for my C600 previously and one for my E650). The one listed for my E650 is entirely different to the one it comes up with now. Could be a very odd coincidence I suppose but I've not installed anything for 3 weeks or so.

  • 0

#19
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,222 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien

Enhancement suggestion: If restart is mandatory, would you be able to force a restart via the cab?

Yes, although i'm not sure how this is done. If I work it out, then i'll add it :rolleyes:

Regarding the Installer problem, I read this and immediately installed as per the instructions as I'd spent hours trying to work out this install problem.

I followed the instructions, above, but the 1st program I tried to install "card_cache", same spinning wheel problem

Strange as i've installed a whole bunch of apps (Opera, Resco etc.) and not had the problem. Did you re-unlock with the O tool after install? If so, could you try without that step (I didn't do that)?

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#20
Prof. Yaffle

Prof. Yaffle

    Regular

  • Members
  • PipPip
  • 78 posts
  • Gender:Male

Nore to me. Definitely been working ok since I got the phone. I've checked TTCode.com and it has 2 device codes listed (one for my C600 previously and one for my E650). The one listed for my E650 is entirely different to the one it comes up with now. Could be a very odd coincidence I suppose but I've not installed anything for 3 weeks or so.


Hmmmm.... something odd is going on. I've just checked the IMEI number on the box and also on the sticker on the back of the phone and when I check it on the phone itself I seem to have gained two extra digits (01) on the end. Is that even possible?

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users