Jump to content


Photo

Continuous reboots...

- - - - -

  • Please log in to reply
23 replies to this topic

#1
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,222 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien
Has anyone seen a strange problem where on a soft reset, the device continually reboots until the microSD is popped out?

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#2
Confucious

Confucious

    Peanut Brain

  • MoDaCo Gold
  • PipPipPipPipPipPip
  • 6,635 posts
  • Gender:Male
  • Location:Surrey, England
  • Devices:iPhone 5
  • Twitter:@Confuciousmobil
Have you tried the card on another device? Could it hve some dodgy s/ware or just be corrupt? Tried a different card in the same device?

  • 0
He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.

#3
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,222 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien
Not sure which of those it is really. It did the same in my Vox sometimes, but was fine in my Trinity :S

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#4
Confucious

Confucious

    Peanut Brain

  • MoDaCo Gold
  • PipPipPipPipPipPip
  • 6,635 posts
  • Gender:Male
  • Location:Surrey, England
  • Devices:iPhone 5
  • Twitter:@Confuciousmobil
Have you tried a different card in the Atlas? If that works it soumnds like a dodgy card - got much on it? can you format it?

  • 0
He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.

#5
BurningMOnk

BurningMOnk

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:null

Have you tried a different card in the Atlas? If that works it soumnds like a dodgy card - got much on it? can you format it?


I've been having the same problem with the TMobile Wing. Boot up will loop until the card is popped out. I have nothing configured to startup from the microSD card. On the main memory I've installed Spb Mobile Shell and Wisbar Advance. I can't figure out what the OS is calling up from the microSD card to make it reboot every time. I've factory reset the phone a bunch of time to find out what program or process is causing this, but no luck. I've been reading about how bad the Wing is with memory. Not sure if this is any connection with the boot loop.

Also, I've tried your pagepool and it does help a lot. I've set mine to 6mb. That in conjunction with over-clocking. If they don't come out with a fix soon, I might get rid of this Wing. HTC Kaiser is right around the corner.

  • 0

#6
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,222 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien
I think I figured out the reboot problem, or at least it seems to have fixed it on mine!

Install the attached CAB on your device, reboot, and let me know if it's fixed it! I applied it a more long winded / manual way, but this should work!

P

[Edit: Continue reading below...]

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#7
BurningMOnk

BurningMOnk

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:null

I think I figured out the reboot problem, or at least it seems to have fixed it on mine!

Install the attached CAB on your device, reboot, and let me know if it's fixed it! I applied it a more long winded / manual way, but this should work!

P



Hey Paul,

I tried your patch and it still reboot loops. What gives? So what do you think the problem is? A certain app? SD card? the OS itself? Thanks for your efforts.

  • 0

#8
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,222 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien
I think it's the DLL that gets installed to update the SD driver causing problems.

Try using a file explorer (Total Commander or Resco) to rename \Windows\omap850_sdhc.dll to omap850_sdhc.dll.old and reboot.

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#9
BurningMOnk

BurningMOnk

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:null

I think it's the DLL that gets installed to update the SD driver causing problems.

Try using a file explorer (Total Commander or Resco) to rename \Windows\omap850_sdhc.dll to omap850_sdhc.dll.old and reboot.

P


Hey Paul,

I tried it and it worked like a charm. You're a genius! Good work.

But how did all this happen? Was it a particular application? The OS? Cause it was working ok until I started installing apps. Anyhow, good job.

  • 0

#10
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,222 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien
I'm not 100% sure because yes, it seems to break once you've installed some apps with no pattern to which apps.

During the extended_rom setup a different omap850_sdhc.dll is which seems to have an issue... renaming the new version restores the ROM one.

Very odd.

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#11
spambob

spambob

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:MDA
Oh man I was scared **** less when I changed the file to .old
I rebooted and crossed my fingers hoping I didn't just brick my new Wing since there still isn't an offical ROM. However I wasn't to worried as I still have my old MDA (waiting to sell it).

Looking at TC at the new and old version I noticed.
OMAP850_SHC.dll (43.5k)
versus
omap850_sdhc.dll.old (50.5k)

Paul! you're a genius. How did you know that .dll was the one that affected the continous reboot?
Who knows which app I installed broke it... but my 2GB Adata Micro SD card now boots fine.

Thanks =)

Device Info:
Tmobile Wing
ROM version: 4.10.531.3.WWE
ROM Date: 03/15/07
Radio version: 02.83.90
Protocol version: 4.1.13.37
ExtROM version: 4.10.531.103
Model No: HERA110

Applications Installed:
HTC Touch Home Plugin
The EquinoXe Wizard reTOUCHed dialer
HTC Audio Manager
By Boto XDA-Developers HTC Touch Home Plugin
Burr Oak Software pTravelAlarm
SunsiaSoft Pocket WakeUp
PPCSoft pcShutXP
LogMeIn Inc Remote Control
Finster869 WM6_RDP
mfrazz CommManager 8button
BatteryStatus
IM+
RARLAB
Total Commander
AIM


I'm not 100% sure because yes, it seems to break once you've installed some apps with no pattern to which apps.

During the extended_rom setup a different omap850_sdhc.dll is which seems to have an issue... renaming the new version restores the ROM one.

Very odd.

P


Edited by spambob, 29 June 2007 - 06:47 AM.

  • 0

#12
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,222 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien
So far as I can work out, it's not one app in particular.

I figured it out when I say a new version of the driver being installed in Extended ROM. Thought i'd try restoring the old version and, hey presto, problem solved :)

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#13
sskarlatos

sskarlatos

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:T-Mobile Wing, X51v

So far as I can work out, it's not one app in particular.

I figured it out when I say a new version of the driver being installed in Extended ROM. Thought i'd try restoring the old version and, hey presto, problem solved :)

P


Paul,

You are the man, this just started happening to me today. I tried multiple things to no avail until I found your post.

This and the page pool, great work. Thanks again.

Stephen Skarlatos
My Digital Life

  • 0

#14
tommysrocket

tommysrocket

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:null
Hello

Tried to rename my OMAP850_SDHC.dll but it doesnt work. I tried with TotalCommander and with Resco Explorer. I use a PDA Viet WM6 ROM on my HTC Herald (like TMOB Wing)

Regards, Tommy

  • 0

#15
T_Webb

T_Webb

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:T- MObile Dash
Would it be possible to have one of y'all send me the newly created omap850_sdhc.dll file once the old file is renamed to omap850_sdhc.dll.old and the device rebooted?

I'm trying to fix the issue on my Dash but the file is in ROM and I cannot edit it. If I get the file from someone here I will add it to the windows folder and change the registry to reflect the new file.

Any help is greatly appreciated.

  • 0

#16
kraftey

kraftey

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:T-mobile Wing
When I do a soft reset on my Wing it reboots and gets to the windows mobile splash then reboots again and starts up fine the next time around. Should I try the same fix?

  • 0

#17
T_Webb

T_Webb

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:T- MObile Dash

When I do a soft reset on my Wing it reboots and gets to the windows mobile splash then reboots again and starts up fine the next time around. Should I try the same fix?


Yes you should or you can remove your card wait for the phone to boot normally then put the card back in.

  • 0

#18
wizgnome

wizgnome

    Regular

  • MoDaCo Silver
  • PipPip
  • 65 posts
  • Gender:Male
  • Location:Delft, NL
  • Devices:Samsung Galaxy SII
  • Twitter:@wizgnome
I have the HTC S710, and it started having the same problem.

I found that putting the phone in flight mode when booting allowed it to start with the sd-card inserted. But today it will only boot if I remove the SD card.

In my S710, I only have omap850_sdhc_mux.dll and that file is in rom and I can't copy or rename it - I tried using total Commander.

Is this the same fie? Can it be deleted? but what would replace it?


Mike

  • 0

#19
webstas

webstas

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:Tmobile Dash

I have the HTC S710, and it started having the same problem.

I found that putting the phone in flight mode when booting allowed it to start with the sd-card inserted. But today it will only boot if I remove the SD card.

In my S710, I only have omap850_sdhc_mux.dll and that file is in rom and I can't copy or rename it - I tried using total Commander.

Is this the same fie? Can it be deleted? but what would replace it?


Mike


Im having the same problem, i have tried killing allmost every process to see if its a process holding the omap850_sdhc_mux.dll up, but its not. Paul please help us! ;)

  • 0

#20
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,222 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien
I don't have a S710 to hand to investigate i'm afraid!

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users