Jump to content


Photo

Treo 750 (WM6) - Wireless Synchronization Issues

- - - - -

  • Please log in to reply
17 replies to this topic

#1
Cabuzzi

Cabuzzi

    Newbie

  • Members
  • Pip
  • 23 posts
  • Devices:Treo 750 (WM6)
Hey everyone. This is my first post here at the MoDaCo (nice site, BTW....), so I really tried to find the best place for this post.... hope I got it right.

Basically, I'm trying to get my new Treo 750 to sync over wireless with my Exchange server. I run the Exchange server from my own house, on it's own domain. I've upgraded the Treo 750 to WM6. I previously did not try wireless sync on WM5. My Exchange server is 2003 SP2.

I've tried connecting via SSL only to get a message about the certificate not being valid. After fighting and fighting with trying to get the cert on the phone, I finally gave up and disabled SSL on the device in an attempt to connect.... via any means possible.

What I first thought was success has turned into another problem. The policy from the domain controller made me set a device password. It was at that point that I knew I was getting somewhere. Now, when I hit "sync", I actually it checking for changes. At the bottom of the screen, it'll run through each step: Contacts, Calendar, Email and Tasks.

Let me see if I can describe this..... It'll briefly pause at say 0/80 for my Inbox, then count till it hits the 80 and move on to the next item in the synchronization list. This cycle happens every 30 seconds or so.

When I go to look in my Inbox, it's empty. The only thing I see is at the bottom: "Outlook E-mail 0 Items". Same with Contacts, Calendar, etc...

Now here's the kicker. If I send myself a test email from an outside account... say, Gmail, the sync app will show "Email 0/81", then tick up to 81 and move on to the next item. However, nothing is downloaded. I can pull up a list of all the personalized folders I've created for my mailstore, and they're all there. I can "subscribe" to them, yet they remain empty as well.

I'm completely at a loss. I don't know what else to do at this point, and it's proving to be a difficult thing to search for. Any advice you can give would be very much appreciated....

  • 0

#2
Cabuzzi

Cabuzzi

    Newbie

  • Members
  • Pip
  • 23 posts
  • Devices:Treo 750 (WM6)
Here's a little update....

This sync thing is happening pretty much non-stop. It'll rotate through the 4 steps (email, contacts, calendar, Tasks), wait about 10 seconds, then start it all over.

I've noticed that no other net apps work while this is happening. I actually have to go into ActiveSync and hit stop. After that, net applications (IM, PIE, Opera, etc...) work just fine.

  • 0

#3
ga41

ga41

    Newbie

  • Members
  • Pip
  • 26 posts
  • Devices:Palm treo 750v

Here's a little update....

This sync thing is happening pretty much non-stop. It'll rotate through the 4 steps (email, contacts, calendar, Tasks), wait about 10 seconds, then start it all over.

I've noticed that no other net apps work while this is happening. I actually have to go into ActiveSync and hit stop. After that, net applications (IM, PIE, Opera, etc...) work just fine.



I cant really help you and the treo forum here is pretty sparse. Try posting at http://forum.xda-developers.com , http://forum.treonauts.com or http://discussion.treocentral.com . The xda people are pretty good so try there for sure.

  • 0

#4
andyhud

andyhud

    Regular

  • Members
  • PipPip
  • 91 posts

I cant really help you and the treo forum here is pretty sparse. Try posting at http://forum.xda-developers.com , http://forum.treonauts.com or http://discussion.treocentral.com . The xda people are pretty good so try there for sure.



hi mate, I got your message and from what your saying it seems a problem with the handheld and not the server. If you are getting a device policy down to the device (ie forcing you to set a password) then the comms with the server must be working.

The only true way to prove it would be to try another wm5/6 device and go through the same procedure... Thats what I would do certainly.

if you havent got another device, download the wm5 emulator from microsoft which is basically a pda on your pc.. make sure the pc isnt on the same network as your exchange server and give a direct outside connection to the internet and dont use the same connection that the exchange server uses...

Also.. turn up logging on exchange and check the event log.. you never know.. but my money is on the device at fault, and not exchange.

Cant help on why you arent getting the cert on your phone, if its a self sert from the server itself and Microsoft Certificate Authority, the phone may not allow/support them and you may need to buy one from a trusted provider. I went with www.godaddy.com as they are dirt cheap.

best of luck

Andy

  • 0
Andy
MCP, MCSE+ 2003 Messaging & Security, CCNA

#5
Cabuzzi

Cabuzzi

    Newbie

  • Members
  • Pip
  • 23 posts
  • Devices:Treo 750 (WM6)
Thanks for the reply! Excellent theory. I hadn't thought the fault might be with the device.

Unfortunately, I can't download the WM5 emulator because M$ has decided my work laptop is not "Genuine"..... even though we bought it from CDW. Geez.

However, I was able to find a WM6 emulator which suprisingly enough, didn't require validation to download. This should work pretty well, since I'm running WM6 on my phone. I'd still like to see if WM5 connects and syncs where WM6 does not, though...


hi mate, I got your message and from what your saying it seems a problem with the handheld and not the server. If you are getting a device policy down to the device (ie forcing you to set a password) then the comms with the server must be working.

The only true way to prove it would be to try another wm5/6 device and go through the same procedure... Thats what I would do certainly.

if you havent got another device, download the wm5 emulator from microsoft which is basically a pda on your pc.. make sure the pc isnt on the same network as your exchange server and give a direct outside connection to the internet and dont use the same connection that the exchange server uses...

Also.. turn up logging on exchange and check the event log.. you never know.. but my money is on the device at fault, and not exchange.

Cant help on why you arent getting the cert on your phone, if its a self sert from the server itself and Microsoft Certificate Authority, the phone may not allow/support them and you may need to buy one from a trusted provider. I went with www.godaddy.com as they are dirt cheap.

best of luck

Andy


  • 0

#6
Cabuzzi

Cabuzzi

    Newbie

  • Members
  • Pip
  • 23 posts
  • Devices:Treo 750 (WM6)

if you havent got another device, download the wm5 emulator from microsoft which is basically a pda on your pc.. make sure the pc isnt on the same network as your exchange server and give a direct outside connection to the internet and dont use the same connection that the exchange server uses...

I'm trying this, but having a difficulty getting the emulator to use my network connection. When I go to configure the network emulator, I get an error message when I try to select my machine's network card. I'm currently downloading the driver that the error message recommended....

Also.. turn up logging on exchange and check the event log.. you never know.. but my money is on the device at fault, and not exchange.

How do I do this?

Cant help on why you arent getting the cert on your phone, if its a self sert from the server itself and Microsoft Certificate Authority, the phone may not allow/support them and you may need to buy one from a trusted provider. I went with www.godaddy.com as they are dirt cheap.

I will try that tonight, but I should be able to sync w/o SSL first, right?

best of luck

Andy

Thanks, I need it. :)

  • 0

#7
Cabuzzi

Cabuzzi

    Newbie

  • Members
  • Pip
  • 23 posts
  • Devices:Treo 750 (WM6)
Oh yeah... I have an verbose log from the WM6 device, but don't know how much to post or what I'm looking for....

  • 0

#8
Cabuzzi

Cabuzzi

    Newbie

  • Members
  • Pip
  • 23 posts
  • Devices:Treo 750 (WM6)
Ok, I think I cleaned it up enough....

Attached Files


  • 0

#9
Cabuzzi

Cabuzzi

    Newbie

  • Members
  • Pip
  • 23 posts
  • Devices:Treo 750 (WM6)

make sure the pc isnt on the same network as your exchange server and give a direct outside connection to the internet and dont use the same connection that the exchange server uses...


Still no luck. I tried the link the error message provided. It installed all the way to 99% and just hung there. Cannot get emulator to bind with network card for external access....

See attached error message.

Attached Files


  • 0

#10
Cabuzzi

Cabuzzi

    Newbie

  • Members
  • Pip
  • 23 posts
  • Devices:Treo 750 (WM6)
@andy

The WM6 emulator is sweet, but I can't get a working connection.

I've resolved the issue of not being able to bind the emulator to my laptop's NIC, but as far as connecting goes, I don't know what to put in the WM6 settings to connect.

Can you provide some insight?

  • 0

#11
Cabuzzi

Cabuzzi

    Newbie

  • Members
  • Pip
  • 23 posts
  • Devices:Treo 750 (WM6)
Ok, I just figured out if I compose an email, it will send when I hit the "sync" button. However, I'm still getting no contacts, no email, no calendar information, and no tasks downloaded. The folder list IS however showing up (see attachment). This doesn't make any sense...

Attached Files


  • 0

#12
netsyd

netsyd

    Newbie

  • Members
  • Pip
  • 8 posts
  • Devices:Treo 750 WM6 + HTC SDA

I've tried connecting via SSL only to get a message about the certificate not being valid. After fighting and fighting with trying to get the cert on the phone, I finally gave up and disabled SSL on the device in an attempt to connect.... via any means possible.


Did you also disable the requirement for SSL on the exchange server? If not this will never work. Just because the device no longer requires SSL doesn't mean the exchange server isn't going to.

What I first thought was success has turned into another problem.


I think everything you said past this point is just "false positive"... you managed to get some kind of connection to the exchange server, but the data isn't actually getting to your device. You need to fix the SSL issue first.

You never said what the problem was getting the SSL cert onto your Treo... that might give us a place to start.

  • 0

#13
Cabuzzi

Cabuzzi

    Newbie

  • Members
  • Pip
  • 23 posts
  • Devices:Treo 750 (WM6)

Did you also disable the requirement for SSL on the exchange server? If not this will never work. Just because the device no longer requires SSL doesn't mean the exchange server isn't going to.

I certainly haven't gone through each and every folder and vdirectory, but I did check the usual suspects (Exchange, OMA, etc...). I will check again right now.

I think everything you said past this point is just "false positive"... you managed to get some kind of connection to the exchange server, but the data isn't actually getting to your device. You need to fix the SSL issue first.

You never said what the problem was getting the SSL cert onto your Treo... that might give us a place to start.

I have always used a self-signed certificate w/o issue. It's not working for WM6 (no surprise, I read about others having the problem). I also tried using a certificate from Comodo, and then using the "makecab" command to change it to a .cab file. I think put it on my website so I could install it using PIE. No luck. Still won't sync. I figured I would take care of the sync issue first, then go through Godaddy to get an SSL cert later.

  • 0

#14
Cabuzzi

Cabuzzi

    Newbie

  • Members
  • Pip
  • 23 posts
  • Devices:Treo 750 (WM6)
Just finished checking all the folders. No SSL required. And to think I was getting excited for a minute there.....

Oh yeah, I forgot to mention, OMA works just fine (w/o SSL).

  • 0

#15
netsyd

netsyd

    Newbie

  • Members
  • Pip
  • 8 posts
  • Devices:Treo 750 WM6 + HTC SDA

I certainly haven't gone through each and every folder and vdirectory, but I did check the usual suspects (Exchange, OMA, etc...). I will check again right now.
I have always used a self-signed certificate w/o issue. It's not working for WM6 (no surprise, I read about others having the problem). I also tried using a certificate from Comodo, and then using the "makecab" command to change it to a .cab file. I think put it on my website so I could install it using PIE. No luck. Still won't sync. I figured I would take care of the sync issue first, then go through Godaddy to get an SSL cert later.

You don't need to make a cab file .. just click the cert and it will install. If you run into permissions issues you may have to application unlock the phone (just google application unlock SDA).

Here's the steps I used. I've used this a few times and never had any problems:
http://justanothermo...ess-push-email/

  • 0

#16
Cabuzzi

Cabuzzi

    Newbie

  • Members
  • Pip
  • 23 posts
  • Devices:Treo 750 (WM6)

You don't need to make a cab file .. just click the cert and it will install. If you run into permissions issues you may have to application unlock the phone (just google application unlock SDA).

Here's the steps I used. I've used this a few times and never had any problems:
http://justanothermo...ess-push-email/


Thanks for the tip. I'd like to get it working over port 80 first, then I'll worry about the certificate. Thanks for the link. I think it's the only one out there I haven't read yet! :)

As for any updates, all I can say is I tried setting up sync with several different user accounts. Each time I got the same thing: folder list pulled down, the number of emails/calendar items/tasks/contacts to be sync'd showed up, but nothing ever comes down to the phone. The exact same thing happens in the emulator.

  • 0

#17
Cabuzzi

Cabuzzi

    Newbie

  • Members
  • Pip
  • 23 posts
  • Devices:Treo 750 (WM6)
I've going over and over my server's setup in my head. I figured I'd mention my spam filter. It runs on a separate PC that receives mail on port 25, then sends filtered mail to the Exchange server.

No change it could be causing the issue, is there? It's a Windows XP box running NoSpamToday!, which in turn runs several filters, to include SpamAssassin.

Edited by Cabuzzi, 21 August 2007 - 01:18 PM.

  • 0

#18
Cabuzzi

Cabuzzi

    Newbie

  • Members
  • Pip
  • 23 posts
  • Devices:Treo 750 (WM6)
Well, I figured it out. It turned out I DID have IIS configured correctly. The problem was my antivirus software, Avast Server Edition. Once I uninstalled it (disabling it didn't help), mail started flowing to my phone.

Hopefully this will help someone else.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users