Jump to content


Photo

Use MS VoiceCommand 1.6 instead of Cyberon's Voice dial?

- - - - -

  • Please log in to reply
1 reply to this topic

#1
vagelis

vagelis

    Regular

  • Members
  • PipPip
  • 63 posts
  • Gender:Male
  • Location:Pasadena, CA
  • Devices:Galaxy Nexus GSM - Infuse 4G
Greetings all,

In the past I have been able to use these steps to enable Microsoft's Voice command on any WM6 device I have used:



1. Cyberon's Voice Speed Dial software is embedded with the OS. The only way to disable it is to delete the shortcut in the \Windows\Start Menu as well as the SDDaemon.lnk file in the \Windows\Startup folder.

2. Install Microsoft Voice Command normally. You may be prompted with an erroneous error message saying it's going to install in Main Memory, which is fine. Just continue with the installation.

3. The installation will give you an error, because it has no buttons to reassign to Voice Command, since there are only two: camera and messaging. Igonre the error and reboot.

4. Lastly, you must modify this registry entry in order to use your Bluetooth headset with Voice Command:

HKEY_LOCAL_MACHINE\Software\OEM\VoiceCommand\

Path = "\Program Files\Voice Command\VoiceCmd.exe"NOTE: Create the entry if it does not exist. <----- THIS STEP DOES NOT WORK IN THE 503G, as when you press the bluetooth headset button, audio commands are still expected on the headset's mic.


Clearing out the traces of Voice Speed Dial

1. In these registry locations:

HKEY_LOCAL_MACHINE \ Software \ Microsoft \ Shell \ Extensions \ ContextMenus \ Contacts \ Main_ContextMenu

HKEY_LOCAL_MACHINE \ Software \ Microsoft \ Shell \ Extensions \ ContextMenus \ Contacts \ Main_Tools

HKEY_LOCAL_MACHINE \ Software \ Microsoft \ Shell \ Extensions \ ContextMenus \ Contacts \ Summary_ToolsRemove this key entirely: {2C0E9904-F32D-4f53-875F-479F5CA81E18}

2. In this registry location:

HKEY_LOCAL_MACHINE\ControlPanelRemove this key entirely: VoiceTagCPL

3. In this registry location:

HKEY_LOCAL_MACHINE\Software\OEM\VoiceCommandChange this value:

Path="\Program Files\Voice Command\VoiceCmd.exe"

(It probably points to SDDialer.exe now.)

4. In this folder: \Windows\Startup Remove this file: SDDaemon.lnk

5. Reassign the Voice button in Buttons applet under Settings to Voice Command.

Now, soft-reset your device and that should do it. Cyberon's Voice Speed Dial is out of the picture. That is, until you hard reset, then it all comes back.

ANY IDEAS ON MAKING THIS WORK WITH THE 503G? Perhaps the TechFaith Wireless group/Martha can chime in?
Thank you in advance.

  • 0

#2
JoshGrey

JoshGrey

    Regular

  • Members
  • PipPip
  • 120 posts

Greetings all,

In the past I have been able to use these steps to enable Microsoft's Voice command on any WM6 device I have used:
1. Cyberon's Voice Speed Dial software is embedded with the OS. The only way to disable it is to delete the shortcut in the \Windows\Start Menu as well as the SDDaemon.lnk file in the \Windows\Startup folder.

2. Install Microsoft Voice Command normally. You may be prompted with an erroneous error message saying it's going to install in Main Memory, which is fine. Just continue with the installation.

3. The installation will give you an error, because it has no buttons to reassign to Voice Command, since there are only two: camera and messaging. Igonre the error and reboot.

4. Lastly, you must modify this registry entry in order to use your Bluetooth headset with Voice Command:

HKEY_LOCAL_MACHINE\Software\OEM\VoiceCommand\

Path = "\Program Files\Voice Command\VoiceCmd.exe"NOTE: Create the entry if it does not exist. <----- THIS STEP DOES NOT WORK IN THE 503G, as when you press the bluetooth headset button, audio commands are still expected on the headset's mic.
Clearing out the traces of Voice Speed Dial

1. In these registry locations:

HKEY_LOCAL_MACHINE \ Software \ Microsoft \ Shell \ Extensions \ ContextMenus \ Contacts \ Main_ContextMenu

HKEY_LOCAL_MACHINE \ Software \ Microsoft \ Shell \ Extensions \ ContextMenus \ Contacts \ Main_Tools

HKEY_LOCAL_MACHINE \ Software \ Microsoft \ Shell \ Extensions \ ContextMenus \ Contacts \ Summary_ToolsRemove this key entirely: {2C0E9904-F32D-4f53-875F-479F5CA81E18}

2. In this registry location:

HKEY_LOCAL_MACHINE\ControlPanelRemove this key entirely: VoiceTagCPL

3. In this registry location:

HKEY_LOCAL_MACHINE\Software\OEM\VoiceCommandChange this value:

Path="\Program Files\Voice Command\VoiceCmd.exe"

(It probably points to SDDialer.exe now.)

4. In this folder: \Windows\Startup Remove this file: SDDaemon.lnk

5. Reassign the Voice button in Buttons applet under Settings to Voice Command.

Now, soft-reset your device and that should do it. Cyberon's Voice Speed Dial is out of the picture. That is, until you hard reset, then it all comes back.

ANY IDEAS ON MAKING THIS WORK WITH THE 503G? Perhaps the TechFaith Wireless group/Martha can chime in?
Thank you in advance.


MSFT Voice Command works on smartphones now...I know it's a stretch but can you tell me how I can set the Voice Button to the Speed Dial button?

Btw it looks as if the latest version of MVC does support commands from a bluetooth headset.

Thanks :(

  • 0
"There are those who make it happen, those who let it happen, and those who wonder what happened. Which one are ?

Wise Question




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users