Jump to content


Photo

Change default "File As" order for Contacts?

- - - - -

  • Please log in to reply
12 replies to this topic

#1
MisterOrange

MisterOrange

    Newbie

  • Members
  • Pip
  • 5 posts
By default, the "file as" order sets contacts as Last Name, First Name (e.g. "Smith, John"). However, I have all my contacts set as First Name Last Name (e.g. "John Smith"). I'm pretty sure there was a registry tweak to make "file as" default to First Last as opposed to Last, First. I just had to hard reset my phone, and now I can't find it.

It's not too bad since all of my contacts from Outlook are already formatted as First Last, but what really bugs me is because the phone is set to Last, First anytime I edit a contact on the phone, it reformats the file as setting to Last, First.

BTW, running WM6.

Thanks.

  • 0

#2
ricardo.bj

ricardo.bj

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:Samsung SGH-i607

By default, the "file as" order sets contacts as Last Name, First Name (e.g. "Smith, John"). However, I have all my contacts set as First Name Last Name (e.g. "John Smith"). I'm pretty sure there was a registry tweak to make "file as" default to First Last as opposed to Last, First. I just had to hard reset my phone, and now I can't find it.

It's not too bad since all of my contacts from Outlook are already formatted as First Last, but what really bugs me is because the phone is set to Last, First anytime I edit a contact on the phone, it reformats the file as setting to Last, First.

BTW, running WM6.

Thanks.


i am also running wm6 and outlook 2007 but do not have the problem you are experiencing. i did modify though the default file as in my outlook to be first last name. maybe that is something you need to look at and make sure it is properly set.

  • 0

#3
MisterOrange

MisterOrange

    Newbie

  • Members
  • Pip
  • 5 posts

i am also running wm6 and outlook 2007 but do not have the problem you are experiencing. i did modify though the default file as in my outlook to be first last name. maybe that is something you need to look at and make sure it is properly set.


Yeah, I checked that. Outlook is set to file contacts as "First Last".

Very odd.

Anyone have any other ideas? I still can't find that registry hack. Anyone remember this one?

  • 0

#4
dearsina

dearsina

    Enthusiast

  • Members
  • PipPipPip
  • 209 posts
  • Location:Marylebone, London
  • Interests:I've been around since the days of the SPV (now suffixed 'Classic'). I miss the 8+1 way joystick.
  • Devices:HTC Vox
Would be very useful if someone could find this. I hate the Lastname, Firstname nonsense.

  • 0

#5
Webreaper

Webreaper

    Addict

  • MoDaCo Silver
  • PipPipPipPipPip
  • 690 posts
  • Gender:Male
  • Location:London, UK
  • Devices:Samsung Galaxy S3
There's two parts to this solution. The way I solved it was:

1. Sync my device with my PC, so all my contacts are in Outlook on the PC.
2. Install the File-As sorter: http://www.pocketpcf...raj/FileAs.html
3. Process all your contacts in outlook to set them to 'First, Last'
4. Delete all the contacts from the mobile device.
5. Re-sync with the PC, so all the contacts get propagated back onto the device, set as First, Last

So that's got all your existing contacts listed correctly. Now you just need an option on the mobile device to be able to change new contacts to be listed as First, Last. To do this, install the attached CAB, and this will add a new option to your contacts menu 'File As: First, Last', which you can apply to each contact one-by-one.

Sorted. ;)

Attached Files


  • 0

#6
Webreaper

Webreaper

    Addict

  • MoDaCo Silver
  • PipPipPipPipPip
  • 690 posts
  • Gender:Male
  • Location:London, UK
  • Devices:Samsung Galaxy S3

There's two parts to this solution. The way I solved it was:

1. Sync my device with my PC, so all my contacts are in Outlook on the PC.
2. Install the File-As sorter: http://www.pocketpcf...raj/FileAs.html
3. Process all your contacts in outlook to set them to 'First, Last'
4. Delete all the contacts from the mobile device.
5. Re-sync with the PC, so all the contacts get propagated back onto the device, set as First, Last

So that's got all your existing contacts listed correctly. Now you just need an option on the mobile device to be able to change new contacts to be listed as First, Last. To do this, install the attached CAB, and this will add a new option to your contacts menu 'File As: First, Last', which you can apply to each contact one-by-one.

Sorted. ;)


Edit: Just realised, this is in the Smartphone forum. Not sure if the CAB will work on Smartphones, but the first part of the process will work - you might just have to do it periodically.

  • 0

#7
teefaf

teefaf

    Newbie

  • Members
  • Pip
  • 24 posts

Edit: Just realised, this is in the Smartphone forum. Not sure if the CAB will work on Smartphones, but the first part of the process will work - you might just have to do it periodically.



Dude, just wanted to say you are an absolute legend for posting this - many thanks indeed. When I run the CAB on my WM6/HTC Kaiser device, I get an 'installation was unsuccessful' message - any idea why this could be?

Cheers again!

  • 0

#8
bronksy

bronksy

    Diehard

  • Members
  • PipPipPipPip
  • 390 posts

Dude, just wanted to say you are an absolute legend for posting this - many thanks indeed. When I run the CAB on my WM6/HTC Kaiser device, I get an 'installation was unsuccessful' message - any idea why this could be?

Cheers again!



I cant get the cab to work on the Orange TyTN II..anyone else have any luck?

  • 0
My history of mobile communications
Posted Image

#9
madbandit

madbandit

    Newbie

  • Members
  • Pip
  • 37 posts
  • Location:Shrewsbury - UK
  • Devices:Orange SPV E650, C600, C500
installation is also unsuccessful on the Vox (well Orange E650) that is app unlocked...

anyone else got any ideas?

  • 0
Mater artium necessitas.

#10
bugmenot111

bugmenot111

    Newbie

  • Members
  • Pip
  • 38 posts
  • Location:Wongo
  • Devices:i900 OMNIA

There's two parts to this solution. The way I solved it was:

1. Sync my device with my PC, so all my contacts are in Outlook on the PC.
2. Install the File-As sorter: http://www.pocketpcf...raj/FileAs.html
3. Process all your contacts in outlook to set them to 'First, Last'
4. Delete all the contacts from the mobile device.
5. Re-sync with the PC, so all the contacts get propagated back onto the device, set as First, Last

Sorted. :D


Man, you are my hero.
Worked a charm!

P.S. I didnt have to do the steps 4 and 5. Outlook 2008 and WM6 seemed to synchronize this display by themselves.

  • 0

#11
ilseferreira

ilseferreira

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:HTC P3400
OK, so it's more than a year since MisterOrange posted the original question and it's the exact problem I'm experiencing... tried installing the .cab on my HTC P3400, but it was unsuccessful.

Outlook on my PC has been set to a default "File as" of "First Last" and what happens now is that everytime I add a contact on my phone, I sync with my PC as soon as I get home and manually change that one that is filed as "Last, First" to "First Last", which then syncs back to my phone. <_<

Did anything change in the last year that there is now something that would work for me too?

Waiting anxiously for light in the tunnel... B)

Thanks

  • 0

#12
zkyevolved

zkyevolved

    Regular

  • Members
  • PipPip
  • 78 posts
  • Location:Madrid
  • Devices:Sony Ericsson Xperia X1 6.5
Hey guys, I have office 2007, and it doesn't run. Does anyone else know a how to get through this?

  • 0

#13
Mad Martian

Mad Martian

    Newbie

  • Members
  • Pip
  • 8 posts
  • Devices:Motorola Q9h
Hey Webreaper, any chance you can tell us what registry tweak is needed so we can change the default without having to install the cab file? Once I change this, I never want to change it back, so I really don't need a menu option. I am having the same problem with contacts synced from gmail. They default to last name first, even though gmail is first name last, because the phone adds them as new contacts using it's default.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users