Jump to content


Photo

guide to play Duke Nukem 3D on your Kaiser (with keyboard)!

- - - - -

  • Please log in to reply
33 replies to this topic

#21
Harkadenn

Harkadenn

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:HTC Kaiser
I'm new to this forums

And I still cant managed to load the freaking game... sorry i havent sleep yet because i cant give up trying this to work.

My last hope is an answer directly from you.


Alright I already downloaded:

-dnukem3d zip
-spvDuke3D


I have them unizzped in the same directory but individual folders for each so it won't get all messy or confusing.

When I try to run the game from spvDuke3D folder and Duke's face icon, I get the error Duke3D.grp no found.

When I entered the readme there is a section telling me to get some files from the original game. I honestly don't have the game and I'm sure im not the only one, come on...

I thought that everything I needed was in this forum. But now another zip with original game data and I still can't find it.

OMG! don't tell me that I have to do all this process for Wolfenstein, Doom, and Quake?! :S

Why can't there be a nice done Cab including everything so you just unzipped and done?

I really need help :D

Thanks..

  • 0

#22
mikeeey

mikeeey

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,986 posts
  • Location:US, Washington, Everett
  • Devices:Nokia n82 (hacked)

I'm new to this forums

And I still cant managed to load the freaking game... sorry i havent sleep yet because i cant give up trying this to work.

My last hope is an answer directly from you.
Alright I already downloaded:

-dnukem3d zip
-spvDuke3D
I have them unizzped in the same directory but individual folders for each so it won't get all messy or confusing.

When I try to run the game from spvDuke3D folder and Duke's face icon, I get the error Duke3D.grp no found.

When I entered the readme there is a section telling me to get some files from the original game. I honestly don't have the game and I'm sure im not the only one, come on...

I thought that everything I needed was in this forum. But now another zip with original game data and I still can't find it.

OMG! don't tell me that I have to do all this process for Wolfenstein, Doom, and Quake?! :S

Why can't there be a nice done Cab including everything so you just unzipped and done?

I really need help :D

Thanks..

yeah, all ports are just strictly the port, not the entire game too.. so..yes, this goes for wolfenstein, doom, quake...etc..
youl have to download the shareware version, or get a copy of the full thing, or use google...
i cant provide the full version on this forum, as its the...payed..version.

  • 0
my signature is too long

#23
-JeeDee-

-JeeDee-

    Newbie

  • Members
  • Pip
  • 3 posts
  • Location:Groningen
  • Devices:TyTN II

yeah, all ports are just strictly the port, not the entire game too.. so..yes, this goes for wolfenstein, doom, quake...etc..
youl have to download the shareware version, or get a copy of the full thing, or use google...
i cant provide the full version on this forum, as its the...payed..version.


I found this on internet:
http://surfnet.dl.so...d/duke3dgrp.zip

not sure if it's ok to post it here, but it is the missing grp file, I had the same error.
Now trying to get it working!

  • 0

#24
mizi6667

mizi6667

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:TC Kaiser
hi,
the game don't run in landscape mode on my HTC kaiser.
i tryed up to 2hours, without any results.

i get these crash message:
""""""""""""""""""""""
GXOpenInput called.
System icons loaded.
Video driver set to windib

Duke Nukem 3D 0.4f
Smartphone port by :
Roozbeh GHolizadeh
www.spv3d.com

Prevent timer created.
Free Mem: 50408 Kbytes.
Screen Width 240
Screen Height 320
KB_Startup
CONFIG_ startups
Compiling configs
Compiling: 'game.con'.
Including: 'DEFS.CON'.
Including: 'USER.CON'.
Code Size:64840 bytes(1794 labels).
Control Startup
Initializing engine
Initializing timer
Timer handler created succesfully
Loading art header.
Reserved Cache Mem: 16384 Kbytes.
Checking sound inits.
Checking music inits.
Loading palette/lookups.
ExtEscape failed or no hi-res device.
Gapi surface seems to be ok.
Using GAPI from now on.
""""""""""""

what should i do?!

PLZ HELP ME!!

greetings

  • 0

#25
mikeeey

mikeeey

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,986 posts
  • Location:US, Washington, Everett
  • Devices:Nokia n82 (hacked)
If you're using the setup file I have provided, you're supposed to start it in portrait, and when you actually see the game start then you can open it in landscape.

  • 0
my signature is too long

#26
maxXxim

maxXxim

    Newbie

  • Members
  • Pip
  • 2 posts
hey, i can play duke nukem on my TyTn II, however only the 1st level (L.A meltdown) works fine
when i start a new game on the 3 other levels, it crash and thats what i get:
- when i load "lunar apocalypse" it says: Map E2L1.map not found!
- when i load "shrapnel city" it says: Map E3L1.map not found!
- when i load "birth" it says: Map E4L1.map not found!
where can i find those maps?

ive read somewhere how to fix the time delay but i cant find it anymore.
the problem i have is that when i shot, i get the shooting sound like 1 second after.

also when i play on landscape mode, a small picture of the keyboard is displayed in the middle of the bottom of the screen.
how can i get rid of it?

thanks

Edited by maxXxim, 20 July 2008 - 02:03 AM.

  • 0

#27
mikeeey

mikeeey

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,986 posts
  • Location:US, Washington, Everett
  • Devices:Nokia n82 (hacked)

hey, i can play duke nukem on my TyTn II, however only the 1st level (L.A meltdown) works fine
when i start a new game on the 3 other levels, it crash and thats what i get:
- when i load "lunar apocalypse" it says: Map E2L1.map not found!
- when i load "shrapnel city" it says: Map E3L1.map not found!
- when i load "birth" it says: Map E4L1.map not found!
where can i find those maps?

ive read somewhere how to fix the time delay but i cant find it anymore.
the problem i have is that when i shot, i get the shooting sound like 1 second after.

also when i play on landscape mode, a small picture of the keyboard is displayed in the middle of the bottom of the screen.
how can i get rid of it?

thanks

your first problem.. it sounds to me like you are using the shareware version. (shareware means only the first episode) You need the full version to play the rest.
actually i never took any time to try to fix the sound issue, as it didnt seem so bad for me, but ill look into it.

well i did notice that when you enabled Gapi the little keyboard thing did appear, but when gapi was disabled it wouldnt appear (or maybe it was the other way around?). Anyway, try enabling gapi and disabling it and your outcome of all the other settings will be different. I the cfg i have included it should be fine, just remember to run duke in portrait and when the splash screen comes up you then slide out your keyboard.

  • 0
my signature is too long

#28
fireblade63

fireblade63

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:SA,SUNG I750
@mikeeey

Did you get the game to run on the latest 6.1 ROMs on XDA without crashing?
Changing GAPI messes up the landscape mode and is unplayable as well
I'll keep checking this thread till something comes up

  • 0

#29
mikeeey

mikeeey

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,986 posts
  • Location:US, Washington, Everett
  • Devices:Nokia n82 (hacked)

@mikeeey

Did you get the game to run on the latest 6.1 ROMs on XDA without crashing?
Changing GAPI messes up the landscape mode and is unplayable as well
I'll keep checking this thread till something comes up

nope, and on xda and here on modaco you will here me repeat over and over how these new wm6.1 roms dont support quake, quake 2, or duke nukem, something they are missing, but no one knows what.
So im using dutty's 4/29 rom and it works fine, unfortunately I cant install the drivers with this rom.

You are right, changing GAPI does make it run, but makes it crash and unplayable.

  • 0
my signature is too long

#30
funem

funem

    Newbie

  • Members
  • Pip
  • 10 posts
Wheeeeeee,

I got this working on my WM 6.1 TyTnII by editing the DUKE3D.cfg like this

[Setup]
SetupVersion = "1.3D"
spvDuke3DVersion = "0.4f"
spvDuke3DPortAuthor = "Roozbeh GHolizadeh"
spvDuke3DPortHome = "www.spv3d.com"

[Engine Setup]
UsingGapi = 0
ShowSIPButton = 1
Platform_Timer_HZ = 100
LandscapeMode = 0
CacheMemory = "-2400"
ShowFPS = 1
ShowKeyCodes = 0
TickRate = 135
TicksPerFrame = 26
ScanCodeMapping = 0
Alt_EscapeKey = "BakSpc"
Timidity_Dir = "\Storage Card\timidity"

[Scan Code Mapping]

[Screen Setup]
ScreenMode = 1
ScreenWidth = 320
ScreenHeight = 240
Shadows = 1
Password = ""
Detail = 1
Tilt = 1
Messages = 1
Out = 0
ScreenSize = 8
ScreenGamma = 16

Make the changes in bold above. When you start the game be in portrait mode, as soon as the grey loading screen comes up you can open the keyboard.

If you want to stop the keyboard icon showing up over the top of the game, dont run it from explorer. create a shortcut in the start menu. if you are in a program that makes the keyboard icon showup on the tastbar when you load the game then it will not be removed from the screen. If you are at the today screen and run the game from the menu the keyboard icon will not be displayed.

One problem I have is I cant work out how to rempap the keys as it loses all the mappings in the config when I have made these changes.


 

Edited by funem, 28 August 2008 - 06:42 PM.

  • 0

#31
funem

funem

    Newbie

  • Members
  • Pip
  • 10 posts

Wheeeeeee,

I got this working on my WM 6.1 TyTnII by editing the DUKE3D.cfg like this

[Setup]
SetupVersion = "1.3D"
spvDuke3DVersion = "0.4f"
spvDuke3DPortAuthor = "Roozbeh GHolizadeh"
spvDuke3DPortHome = "www.spv3d.com"

[Engine Setup]
UsingGapi = 0
ShowSIPButton = 1
Platform_Timer_HZ = 100
LandscapeMode = 0
CacheMemory = "-2400"
ShowFPS = 1
ShowKeyCodes = 0
TickRate = 135
TicksPerFrame = 26
ScanCodeMapping = 0
Alt_EscapeKey = "BakSpc"
Timidity_Dir = "\Storage Card\timidity"

[Scan Code Mapping]

[Screen Setup]
ScreenMode = 1
ScreenWidth = 320
ScreenHeight = 240
Shadows = 1
Password = ""
Detail = 1
Tilt = 1
Messages = 1
Out = 0
ScreenSize = 8
ScreenGamma = 16

Make the changes in bold above. When you start the game be in portrait mode, as soon as the grey loading screen comes up you can open the keyboard.

If you want to stop the keyboard icon showing up over the top of the game, dont run it from explorer. create a shortcut in the start menu. if you are in a program that makes the keyboard icon showup on the tastbar when you load the game then it will not be removed from the screen. If you are at the today screen and run the game from the menu the keyboard icon will not be displayed.

One problem I have is I cant work out how to rempap the keys as it loses all the mappings in the config when I have made these changes.


Edit:- Fixed it. Just copy the key settings from KeyDefinitions_Landscape1 to KeyDefinitions_Landscape0 and KeyDefinitions_Landscape2 and you get a fully working copy of Duke Nukem 3D on a WM6.1 TyTn II running in landscape :D

/

  • 0

#32
johngotti19

johngotti19

    Newbie

  • Members
  • Pip
  • 4 posts

Wheeeeeee,

I got this working on my WM 6.1 TyTnII by editing the DUKE3D.cfg like this

[Setup]
SetupVersion = "1.3D"
spvDuke3DVersion = "0.4f"
spvDuke3DPortAuthor = "Roozbeh GHolizadeh"
spvDuke3DPortHome = "www.spv3d.com"

[Engine Setup]
UsingGapi = 0
ShowSIPButton = 1
Platform_Timer_HZ = 100
LandscapeMode = 0
CacheMemory = "-2400"
ShowFPS = 1
ShowKeyCodes = 0
TickRate = 135
TicksPerFrame = 26
ScanCodeMapping = 0
Alt_EscapeKey = "BakSpc"
Timidity_Dir = "\Storage Card\timidity"

[Scan Code Mapping]

[Screen Setup]
ScreenMode = 1
ScreenWidth = 320
ScreenHeight = 240
Shadows = 1
Password = ""
Detail = 1
Tilt = 1
Messages = 1
Out = 0
ScreenSize = 8
ScreenGamma = 16

Make the changes in bold above. When you start the game be in portrait mode, as soon as the grey loading screen comes up you can open the keyboard.

If you want to stop the keyboard icon showing up over the top of the game, dont run it from explorer. create a shortcut in the start menu. if you are in a program that makes the keyboard icon showup on the tastbar when you load the game then it will not be removed from the screen. If you are at the today screen and run the game from the menu the keyboard icon will not be displayed.

One problem I have is I cant work out how to rempap the keys as it loses all the mappings in the config when I have made these changes.
 

This works for me, im running Hyperdragon III rom and got duke2d working...
thank, now im working on quake2 to run on my tytn2, need some help though

  • 0

#33
mikeeey

mikeeey

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,986 posts
  • Location:US, Washington, Everett
  • Devices:Nokia n82 (hacked)

This works for me, im running Hyperdragon III rom and got duke2d working...
thank, now im working on quake2 to run on my tytn2, need some help though

I got the newest hyper dragon III rom as well. unfortunatly when it isn't using gapi the framerate is lower (about 25fps instead of 45fps) and you can see the distortion in the frames as they switch (not too noticable tho).

I havn't even tried quake and quake 2 yet, I'm focused on other things, such as DoomGLES, now that proper drivers are working!

  • 0
my signature is too long

#34
trexul

trexul

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:HTC Tytn II
Hello i run duke nukem ..but my pda say ..the mising files duke3d.grp ... why?

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users