Jump to content


Photo

Enable 320x240 video recording on the Q9H

- - - - -

  • Please log in to reply
13 replies to this topic

#1
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,222 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien
It's easy!

Just change the following registry entry FROM 2 TO 3...

HKLM\Software\Microsoft\Pictures\Camera\OEM\VideoProfile\OptionNum

:D

Now, if only I could enable VGA recording... :(

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#2
nickcornaglia

nickcornaglia

    Blackjack'd

  • Members
  • PipPipPipPipPipPip
  • 4,251 posts
  • Gender:Male
  • Location:Mt Laurel, NJ USA
  • Devices:iPhone5
  • Twitter:@nickcornaglia
BEAUTIFUL!!!! I was wondering why the video was so crappy!!!!

  • 0
-Nick

#3
PaulOBrien

PaulOBrien

    It's My Party

  • Founder
  • PipPipPipPipPipPip
  • 36,222 posts
  • Gender:Male
  • Location:Norwich, UK
  • Devices:All the Nexus!
  • Twitter:@paulobrien
Newsworthy? :(

P

  • 0

You can follow me on Twitter - http://twitter.com/paulobrien / Follow MoDaCo on Twitter - http://twitter.com/modaco

Want to donate? MoDaCo is raising money for the Multiple Sclerosis society.

Posted Image


#4
nickcornaglia

nickcornaglia

    Blackjack'd

  • Members
  • PipPipPipPipPipPip
  • 4,251 posts
  • Gender:Male
  • Location:Mt Laurel, NJ USA
  • Devices:iPhone5
  • Twitter:@nickcornaglia

Newsworthy? :(

P

  • of course....maybe along with the button mappings and links.

  • 0
-Nick

#5
avmoto

avmoto

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:Q9h

  • of course....maybe along with the button mappings and links.


sorry, either i am new at this (just got the phone yesterday), or Im dumb as s@#t. How do you get there, for someone that doesn't know what the hell they are doing. :(

  • 0

#6
theothermj

theothermj

    Newbie

  • Members
  • Pip
  • 4 posts
  • Devices:Moto Q9h

sorry, either i am new at this (just got the phone yesterday), or Im dumb as s@#t. How do you get there, for someone that doesn't know what the hell they are doing. :(


You need a registry editor. Try searching for PHM registy editor. There are others, but this one is free.

  • 0

#7
popcity

popcity

    Newbie

  • Members
  • Pip
  • 3 posts
Thanks, the registry edit works great!

  • 0

#8
Panthro

Panthro

    Newbie

  • Members
  • Pip
  • 13 posts
  • Devices:Qtek 8310/Imate SP5

It's easy!

Just change the following registry entry FROM 2 TO 3...

HKLM\Software\Microsoft\Pictures\Camera\OEM\VideoProfile\OptionNum

:D

Now, if only I could enable VGA recording... :(

P


Not that easy for me ....

There is so many things listed here.

I've got ...

HKey_LOCAL_MACHINE\Software\Microsoft\Pictures\Camera\OEM\VideoProfile\

Here I have folders 1 , 2 , 3 (not OptionNum ).
And within each of those folders (1/2/3) I have ....

in folder "1" I've got ...
AudioEncoderCLSID
CaptureColorFrom...
MuxCLSID
PreviewColorForm...
PreviewFrameInter...
VideoCaptureFram... (I'm thinking video frame capture, but my value is 0 not 2).
VideoEncoderCLSID
VideoEncoderProp...

So what do I do?
BTW, I've got a Motorola Q9h AT&T model.

  • 0

#9
dwboston

dwboston

    Newbie

  • Members
  • Pip
  • 13 posts
  • Devices:Dell Streak

Not that easy for me ....

There is so many things listed here.

I've got ...

HKey_LOCAL_MACHINE\Software\Microsoft\Pictures\Camera\OEM\VideoProfile\

Here I have folders 1 , 2 , 3 (not OptionNum ).
And within each of those folders (1/2/3) I have ....

in folder "1" I've got ...
AudioEncoderCLSID
CaptureColorFrom...
MuxCLSID
PreviewColorForm...
PreviewFrameInter...
VideoCaptureFram... (I'm thinking video frame capture, but my value is 0 not 2).
VideoEncoderCLSID
VideoEncoderProp...

So what do I do?
BTW, I've got a Motorola Q9h AT&T model.



In the screen where you see the folders "1", "2", and "3", move the cursor to highlight folder 3, but instead of selecting Folder 3, hit the top left softkey which should be labeled "Values". Then you will see OptionNum, select that and change the value from 2 to 3. Do the same for folders 1 and 2 if they aren't already set to value of 3 (I think they already are).

Edited by dwboston, 09 January 2008 - 09:35 PM.

  • 0

#10
Panthro

Panthro

    Newbie

  • Members
  • Pip
  • 13 posts
  • Devices:Qtek 8310/Imate SP5

In the screen where you see the folders "1", "2", and "3", move the cursor to highlight folder 3, but instead of selecting Folder 3, hit the top left softkey which should be labeled "Values". Then you will see OptionNum, select that and change the value from 2 to 3. Do the same for folders 1 and 2 if they aren't already set to value of 3 (I think they already are).



DUDE ... pure GENIOUS!

THANK you, THANK YOU!

That DID it.
Also you are correct that folders 2 & 3 if highlighted and clicking Values is already set to 3.

I'm content!

  • 0

#11
88Saleen351

88Saleen351

    Newbie

  • Members
  • Pip
  • 46 posts
  • Gender:Male
  • Location:Florida
  • Devices:HTC Touch Pro 2 - Motorola Q9M
Does this work on a Motorola Q9M on Verizons network? Currently there isn't a device specific for q9m on modaco. I am asking this because I recently tweaked the crap out of the camera registry settings.Trying to get 320x240 video record.I sort of did get this to work.But it is not usable.Either I get a recording that is only doing 1 - 3 frames a second or it records a small 27 kb file regardless of how long I actually recorded for.Playing this file results in 2 seconds of video followed by 10 - 20 seconds of a still image.Any ideas?

  • 0

#12
cgerikh

cgerikh

    Newbie

  • Members
  • Pip
  • 7 posts
  • Devices:q9h
I tried this out and yes I'm able to record @ that res (after you switch res option that's now available), but the playback is really bad/choppy. I tampered with the playback options (full screen or not) and still the same result.

You guys are getting smooth playback? Do I need to edit anythign in #3 in the registry for framerate or such?

  • 0

#13
cgerikh

cgerikh

    Newbie

  • Members
  • Pip
  • 7 posts
  • Devices:q9h
Ah I figured it out. 88Saleen this will probably work for you also.

Go back to the registry/almost the same place but a bit deeper instead:
HKLM\Software\Microsoft\Pictures\Camera\OEM\VideoProfile\3\VideoEncoderProperty\3\ and edit the VideoPropertyVT value to something like 10 (mine was set to 45)
At least from starters that game me OK playback. I'm sure you can tamper in there with those settings & get it to give you desirable results.

I'll continue to snoop in there & see if I can improve things further.

Hope that helps :D

  • 0

#14
LuvrGirl

LuvrGirl

    Newbie

  • Members
  • Pip
  • 19 posts
  • Location:So. Calif - LA
  • Devices:AT&T - Moto Q9h Global

Ah I figured it out. 88Saleen this will probably work for you also.

Go back to the registry/almost the same place but a bit deeper instead:
HKLM\Software\Microsoft\Pictures\Camera\OEM\VideoProfile\3\VideoEncoderProperty\3\ and edit the VideoPropertyVT value to something like 10 (mine was set to 45)
At least from starters that game me OK playback. I'm sure you can tamper in there with those settings & get it to give you desirable results.

I'll continue to snoop in there & see if I can improve things further.

Hope that helps :D


Any updates on this? I did the hack to enable the 320x240 option to record video clips in... however, the quality isn't that great. Has anybody figured out any other tweaks in this section of the registry to give better "quality" recording for video clips?

I found this somewhere else, but I have the Q9h with AT&T and I have the 3 folders labeled, 1,2,3, and each one has options... how do I know which one to edit? Why are there so many folders with all the same entries in each folder?

Increase Video Bitrate from 128 to 512
HKEY_LOCAL_MACHINE/Software/Microsoft/Pictures/Camera/OEM
VideoEncoderProperty/1
This is the property for BITRATE
Edit the Key VidoepropertyValue (Yes, it is spelled Vidoe on the key)
Default is approx 128kbps, I have modified up to 512kbps (512000)


Any help is appreciated!

~maria

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users