Jump to content


Photo

ActiveSync fails to connect to exchange server after a period of non-service

- - - - -

  • Please log in to reply
4 replies to this topic

#1
encrypted

encrypted

    Newbie

  • Members
  • Pip
  • 27 posts
  • Devices:HTC Hermes
My ActiveSync which connects to the corporate exchange server to get work emails is fine until a long train journey underground, after which it has problems connecting to the exchange server.

Presumably there is no service underground so something is timing out because when I hit ActiveSync it fails to connect and I have to keep rebooting the phone.

This same problem happened at my old company with their exchange server. I am running WM6 and installed various flavours and all give the same problem.

Is there a timeout setting somewhere I need to change?

TIA for any help.

  • 0

#2
jimbouk

jimbouk

    Hardcore

  • MoDaCo Silver
  • PipPipPipPipPipPip
  • 2,721 posts
  • Location:London
  • Devices:HTC Diamond
Does your internet access work after the underground journey? Or is it just the activesync?

Are you using directpush?

  • 0
Touch HD runnign Dutty's latest rom

#3
encrypted

encrypted

    Newbie

  • Members
  • Pip
  • 27 posts
  • Devices:HTC Hermes

Does your internet access work after the underground journey? Or is it just the activesync?

Are you using directpush?


Internet access works fine, so does Window Hotmail and Yahoo - they sync fine. Its just that ActiveSync with exchange fails.

I run Activesync to sync every 15mins. I get the same type of problem with DirectPush where after a long enough absence of connectivity it just refuses to connect without a reboot.

  • 0

#4
jimbouk

jimbouk

    Hardcore

  • MoDaCo Silver
  • PipPipPipPipPipPip
  • 2,721 posts
  • Location:London
  • Devices:HTC Diamond
Next time try stopping the activesync process either in start/settings/system/memory or via the HTC X button or Taks Manager is you have one of those.

Then try a sync.

It isnt a fix but it may be a good workaround.

  • 0
Touch HD runnign Dutty's latest rom

#5
chucky.egg

chucky.egg

    Did I say that out loud?

  • MoDaCo Silver
  • PipPipPipPipPipPip
  • 4,724 posts
  • Location:Kent, England
  • Interests:Sleeping
  • Devices:Desire S
  • Twitter:@chucky_egg
My Blackjack used to do this all the time
It seems to be an undocumented feature of WM5 - I've not seen it on WM6 Pro

Killing AS seemed to cure it, as Jimbo says, but the only other "solution" (work around) I found was to stop Direct Push and use periodic checking of 30 mins

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users