Jump to content


Photo

How to install and USE .net Compact Framework 3.5 WITHOUT upgrading your ROM.

* * * * * 11 votes

  • Please log in to reply
147 replies to this topic

#61
raju666

raju666

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:p3400
thanks alot for the .cabs paul

  • 0

#62
Tambo

Tambo

    Newbie

  • Members
  • Pip
  • 9 posts
  • Location:Kent England UK
  • Devices:HTC HD (Orange UK)
Hi,
I've installed HDwobble on my HTC HD (Orange UK) & it's giving an error 'newer version of Microsoft.net Compact Framework' required.

I undestand that you copy the 2 cab files over to phone.

If I copy them to my storage card I presume they'll be installed into the correct place?

Do you need to reboot? after each or both are installed?

Do any of you guys with the same phone have any probs with these cabs screwing up the phone.

Reason why I'm asking is I have a lot of programs/apps on my phone & If it's going to cause major probs - then new apps/games etc, that require .net 3.5 I'll just have to avoid installing on my HD.

A hard reset isn't going to be an option...

Thanks for any advice & help.

Tambo

Edited by Tambo, 13 June 2009 - 04:40 PM.

  • 0

#63
jacksprat

jacksprat

    Newbie

  • Members
  • Pip
  • 1 posts
Just installed, and worked a treat. Thanks for the support! :D

  • 0

#64
bovane

bovane

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:Treo Pro

If you're a developer or have knowledge of .net Compact Framework, you'll be aware that version 3.5 has shipped. You'll be aware that it offers a number of enhancements in features, stability and performance, and you'll likely also know that it provides full backwards compatability with previous versions of the Compact Framework. What you may NOT know is that when CF 3.5 is installed on a device, applications that target previous versions of the Compact Framework will continue to run against the old versions, and 3.5 and previous versions will live side by side on the device. Only when new devices come along will we see ONLY 3.5 on a device.

This presents a number of problems, namely

  • Users who deploy CF 3.5 to their device but use applications targeting older versions will not benefit from the 3.5 performance improvements
  • Developers who develop apps for pre CF 3.5 frameworks cannot easily test their applications ready for when 3.5 only devices come along
Thankfully, help is at hand in the form of a little known Compact Framework 3.5 powertoy named '.Net Configuration'. The application, which is available in this download at Microsoft, provides the user with full granularity of control over the .net CF on their device. You can see installed versions, change the used CF version for a particular application or change the used CF version for all applications run on your device! Perfect!

Sadly in Microsoft's infinite wisdom the application in question is tucked away in simple EXE inside the 6.2MB download and somewhat hard to find, so i've taken the liberty of packaging it up into a CAB here that installs it with it's own Start Menu shortcut. I've also included the .net CF 3.5 CAB below, so you can get your device updated quickly and easily by...

- Downloading and installing both CABs below (to internal memory!)
- Running '.Net Configuration' from your Start Menu
- Navigating to the 'Device Policy' tab and selecting version 3.5
- Selecting 'Apply' then 'OK'

That's it, you're done! You can even check it's working by installing my CamerAware Beta and hitting 'About', after which you should see the screen below.

Enjoy, and hope this is useful :D

P

PS If you ARE a developer, there's other goodies in that Powertoys package that are well worth a look too!




Posted Image Posted Image



I HAVE THE TREO PRO WITH A QUAILCOMM PROCESSOR (400MHZ). WILL YOUR FILES - ESPECIALLY THE NETCFV35.WM.ARMV4I.CAB WORK ON MY MOBILE PHONE?
I AM RUNNING WM 6.1 AND HAVE NET CF 2.0.7045.0 installed.
I WAS FOLLOWING THE INSTRUCTIONS FROM THIS PAGE (http://tiltmobility....t-framework-35/) TO DO THE INSTALL WITH YOU FILES.

LAST QUESTION - IF I DONT LIKE 3.5 IS IT REVERSIBLE?

PLEASE RSVP SO I CAN ENJOY THE BETTER .NET

  • 0

#65
diesel369

diesel369

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:htc ppc 6800
Major problem... everything seems to work fine after installation of 3.5... but all of my contacts are gone, and I didn't have any recent pim saved... is this just a bug, are my contacts still somewhere on the phone? someone plz help cuz I have no way of getting all that information back...

  • 0

#66
Zebeth

Zebeth

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:TyTN II

If you're a developer or have knowledge of .net Compact Framework, you'll be aware that version 3.5 has shipped. You'll be aware that it offers a number of enhancements in features, stability and performance, and you'll likely also know that it provides full backwards compatability with previous versions of the Compact Framework. What you may NOT know is that when CF 3.5 is installed on a device, applications that target previous versions of the Compact Framework will continue to run against the old versions, and 3.5 and previous versions will live side by side on the device. Only when new devices come along will we see ONLY 3.5 on a device.

This presents a number of problems, namely

  • Users who deploy CF 3.5 to their device but use applications targeting older versions will not benefit from the 3.5 performance improvements
  • Developers who develop apps for pre CF 3.5 frameworks cannot easily test their applications ready for when 3.5 only devices come along
Thankfully, help is at hand in the form of a little known Compact Framework 3.5 powertoy named '.Net Configuration'. The application, which is available in this download at Microsoft, provides the user with full granularity of control over the .net CF on their device. You can see installed versions, change the used CF version for a particular application or change the used CF version for all applications run on your device! Perfect!

Sadly in Microsoft's infinite wisdom the application in question is tucked away in simple EXE inside the 6.2MB download and somewhat hard to find, so i've taken the liberty of packaging it up into a CAB here that installs it with it's own Start Menu shortcut. I've also included the .net CF 3.5 CAB below, so you can get your device updated quickly and easily by...

- Downloading and installing both CABs below (to internal memory!)
- Running '.Net Configuration' from your Start Menu
- Navigating to the 'Device Policy' tab and selecting version 3.5
- Selecting 'Apply' then 'OK'

That's it, you're done! You can even check it's working by installing my CamerAware Beta and hitting 'About', after which you should see the screen below.

Enjoy, and hope this is useful ;)

P

PS If you ARE a developer, there's other goodies in that Powertoys package that are well worth a look too!




Posted Image Posted Image


  • 0

#67
HT11

HT11

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:htc kaiser
Hello everyone,

Just loaded these 2 cabs in 2 different tilts and it worked great.
Thanks alot.......

  • 0

#68
philmowrey

philmowrey

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:Samsung Saga
Thanks, worked great on my Samsung Saga!

  • 0

#69
alshani

alshani

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:null

If you're a developer or have knowledge of .net Compact Framework, you'll be aware that version 3.5 has shipped. You'll be aware that it offers a number of enhancements in features, stability and performance, and you'll likely also know that it provides full backwards compatability with previous versions of the Compact Framework. What you may NOT know is that when CF 3.5 is installed on a device, applications that target previous versions of the Compact Framework will continue to run against the old versions, and 3.5 and previous versions will live side by side on the device. Only when new devices come along will we see ONLY 3.5 on a device.

This presents a number of problems, namely

  • Users who deploy CF 3.5 to their device but use applications targeting older versions will not benefit from the 3.5 performance improvements
  • Developers who develop apps for pre CF 3.5 frameworks cannot easily test their applications ready for when 3.5 only devices come along
Thankfully, help is at hand in the form of a little known Compact Framework 3.5 powertoy named '.Net Configuration'. The application, which is available in this download at Microsoft, provides the user with full granularity of control over the .net CF on their device. You can see installed versions, change the used CF version for a particular application or change the used CF version for all applications run on your device! Perfect!

Sadly in Microsoft's infinite wisdom the application in question is tucked away in simple EXE inside the 6.2MB download and somewhat hard to find, so i've taken the liberty of packaging it up into a CAB here that installs it with it's own Start Menu shortcut. I've also included the .net CF 3.5 CAB below, so you can get your device updated quickly and easily by...

- Downloading and installing both CABs below (to internal memory!)
- Running '.Net Configuration' from your Start Menu
- Navigating to the 'Device Policy' tab and selecting version 3.5
- Selecting 'Apply' then 'OK'

That's it, you're done! You can even check it's working by installing my CamerAware Beta and hitting 'About', after which you should see the screen below.

Enjoy, and hope this is useful ;)

P

PS If you ARE a developer, there's other goodies in that Powertoys package that are well worth a look too!




Posted Image Posted Image


Would it work on ASUS P750 with WM6.0 OS 5.2.1623?

  • 0

#70
renski

renski

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:mogul
cant seem to get the files to download for some reason?

  • 0

#71
ftfsyfa

ftfsyfa

    Newbie

  • Members
  • Pip
  • 1 posts
great, thanx.

  • 0

#72
harry88

harry88

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:ipaq voice messenger
Thank you SOO very much!!

Microsoft's NETCFSetupv35.msi did NOT work with my iPAQ 510 - but your CAB files DID work. So, what you did was not "just handy" but saved my day.  :)

Note to renski: I had to wait a few minutes before the download popped up. Just be patient  ;)

  • 0

#73
calcha

calcha

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:htc fuze
  • Twitter:@idiot
why is it that when i try to install it on my fuze it says
"installation error stop all applications and processes, maximize all available storage space and run installation again"
i have more than enough memory on my phone and i do not understand why it jus wont instal :)

  • 0

#74
alsehendo34

alsehendo34

    Newbie

  • Members
  • Pip
  • 1 posts

thanks for the apps the net config cab didn't install a shortcut on my htc prophet but i just navigated to the windows folder and ran it from there :)


Thanks I used the Microsoft msi (NETCFSetupv3.5.msi) installer from XP to load 3.5 on the phone and your app works great for switching back and forth. Thanks

Samsung BlackJack II
I upgraded to Windows mobile 6.1

  • 0

#75
JasC

JasC

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:HTC Touch HD
Great - both cabs worked a treat in my un-cooked Orange Touch HD. Many thanks.

  • 0

#76
imanut

imanut

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:Omnia i910
I have the Verizon Omnia i910 version, just installed the newest ROM version. Didn't have a clue what this new compact framework 3.5 was/was not going to do ---- but your cabs worked great on it. I have quite a few programs installed, including SPB stuff, memmaid, SKTools, etc --- I set your cab to run the unconfigured appls with the 3.5 ---------- and, not sure if its just me, but EVERYTHING seems to run much faster !! Great job, and thanks.

gn

  • 0

#77
Clive Cartmel

Clive Cartmel

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:LooX PDA
  • Twitter:@None
Thanks for that Paul. I would not have been able to do this without you!

:D :angry: ;)

  • 0

#78
dhilts

dhilts

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:Touch Pro 2
I have tried different installations of NET Compact Framework 3.5, including the MS download direct to the device. Each time I run the installation to the device or storage card I get the same error message which many other users on this forum are getting stating that I need to free up memory. I have at any given time 120 MB in the device program memory, 206 MB in the device storage memory and I have over 10,000 MB of free memory on the storage card. Anyone have a solution? I haven't figured out how to free up more memory as most everything on the device is what was loaded at time of purchase.

  • 0

#79
dhilts

dhilts

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:Touch Pro 2

I have tried different installations of NET Compact Framework 3.5, including the MS download direct to the device. Each time I run the installation to the device or storage card I get the same error message which many other users on this forum are getting stating that I need to free up memory. I have at any given time 120 MB in the device program memory, 206 MB in the device storage memory and I have over 10,000 MB of free memory on the storage card. Anyone have a solution? I haven't figured out how to free up more memory as most everything on the device is what was loaded at time of purchase.


  • 0

#80
dhilts

dhilts

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:Touch Pro 2
After many struggles for an answer in downloading the Net compact framework 3.5, see the following from another forum. It worked for me running safe mode in my Touch Pro 2. I installed the program from the site as shown and the MS download worked perfectly.



as follows:

I had the same problem on my HTC Kaiser, but I found a solution.
I found a program that acts like safe mode on a computer.
So if you install that program and restart in safe mode (you need to select safe mode when you boot), you will be able to install the compact framework 3.5.
Probable some locked files prevent the normal installation.

The program is an evaluation version, limited to 14 days, but since you only need it for the framework, you don't need to keep if you don't want to.

The app: SafeMode 3__________________
HTC Kaiser (Official HTC 6.1)
ROM version: 3.29.404.0 NLD
ROM date: 05/07/08
Radioversion: 1.65.16.25
Protocolversion: 25.83.40.02H

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users