Jump to content


Photo

SIM trouble

- - - - -

  • Please log in to reply
2 replies to this topic

#1
htctouchcruiser

htctouchcruiser

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:HTC Touch Cruise
He everybody,

Just got my new HTC Touch Cruise, unlocked. Used it in the US, with an AT&T SIM, no problem. Got back to Costa Rica, and plugged in the SIM from the local phone company, and now the device says "no SIM found". What's up? Did the AT&T service now lock the phone to only their SIM? Tried also another SIM from the local phone company, not recognized either. Put the AT&T SIM back in, and that works.

Can anybody help? Been browsing around, and found many people have this problem, and no one seems to be able to find a common explanation/solution.

  • 0

#2
Cal472

Cal472

    Newbie

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Devices:o2 XDA Orbit 2
I would imagine that If you bought the phone from AT&T on a contract then they would probably lock the device to their network only. If it is locked to the network, you may be able to unlock the device by calling AT&T??.. might charge you though.

  • 0

#3
n1ck75

n1ck75

    Newbie

  • Members
  • Pip
  • 36 posts
  • Devices:OLED/TFT Blade
  • Twitter:@n4b_
i had trouble with my sim, make sure you have fully pressed the SIM down till it clicks, if you have done this and still no joy, moouch on over to XDA forum theres a Hard Spl out for the polaris which will unlock it

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users