Jump to content


Photo

Eurotel SDA DEATH - not charging, not starting ...

- - - - -

  • Please log in to reply
1 reply to this topic

#1
peto.kv

peto.kv

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:QTek 8020
i have eurtoel SDA (I). ive been using it for 3years. once i was trying to turn it on, but while there was an eurotel logo (boot screen or how do you call it), the display turned white...it was like a fade effect in presentation ;) since then i am unable to TURN IT ON, CHARGE IT WITH WALL CHARGER or by computer, and also when i plug it into the usb port, computer cannot find anything...

i tried some tricks.. for example from this topic...nothing worked...also the hard reset is unable...

i dont know what to do :wacko: help

  • 0

#2
awarner

awarner

    Staff Team Leader

  • Admin Team
  • PipPipPipPipPipPip
  • 18,507 posts
  • Gender:Male
  • Location:Southampton
  • Interests:Life the universe and everything in it :)

    Lumia 925 one hell of a camera phone
  • Devices:Lumia 925 a real phone at last
  • Twitter:@ashwarner
Interesting as it is exactly the same sort of issue I had with my Lobster.
As a hard reset is not working by what you are describing it sounds like the phone's ROM may have become corrupted.
Without sending to an HTC repair center it may be unlikely that you can revive the phone.

Unfortunately I can not think of a better and cheaper way to fix the phone.

  • 0
Twitter me @ashwarner

Windows Phone 7 Expert.
Windows Phone Business Specialist






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users