Jump to content


Photo

TMobile MDA Compact IV Bugs

- - - - -

  • Please log in to reply
12 replies to this topic

#1
dwhyte

dwhyte

    Newbie

  • Members
  • Pip
  • 12 posts
Hi all,

Having had my MDA Compact IV for a few days, I must say that it is growing on me. :wacko:
I did think I would get a huge buzz immediately as I upgraded from an original MDA Vario but it didn't exite the way I thought. Maybe expecting too much ;)
Am finding new things which amaze all the time and getting used to the interface.
I was waiting for the Touch Pro on TMob but decided to go with the Diamond version as PC Pro said that issues had been resolved with a Rom upgrade. Was told by TMob that new rom was on these phones :D Also decided I don't need the hardware keyboard cause although it looks much better than the Vario, I never used it and got frustrated when I tried. I am quicker pecking with a stylus on the screen keybard and that at least lets me scroll to where I want easliy.
I use the device for business purposes and need all the Exchange server/business connection stuff much more than any media type stuff. Thought the TPro might be better for that but if not using the hardware keyboard, only extra memory and expandable storage is the difference.

However,

There does seem to be a few bugs that I have found, some of which have been mentioned in reviews etc (especially PC Pro magazine), namely:

1) on-screen qwerty keyboard obscures the line of text you are inputting :(
2) Touch3D seems sluggish at times and skips to another area of the screen as it catches up with what you are pressing
3) backlight doesn't come on. Had to restart the device yesderday to get it to work
4) initial setup; the screen alingment didn't work. nothing happens when pressing the crosshairs for about five minutes then it moves to the next area. This sometimes doesn't work at all and needs a reboot
5) having to realign screen a few times as the close x button and right hand side scroll bar are unresponsive. They need a great deal of pressure to use accurately sometimes(Maybe that is just me not being used to the new device? How do I increase screen touch sensitivity?)
6) Standard factory Rom from July 08 on phone, probably explains some of the above issues (Will TMob get a new Rom out, if not, shouldn't we be bombarding them with emails asking to do so?)

will think of more but that is the list so far.

Any suggestions/opinions?

Cheers,
Dave

  • 0

#2
Neil5459

Neil5459

    NeilM

  • Members
  • PipPipPipPipPipPip
  • 1,485 posts
  • Gender:Male
  • Location:Saffron Walden, Essex
  • Devices:HTC Titan, iPad 2 3G
  • Twitter:@Neilmell

Hi all,

Having had my MDA Compact IV for a few days, I must say that it is growing on me. :wacko:
I did think I would get a huge buzz immediately as I upgraded from an original MDA Vario but it didn't exite the way I thought. Maybe expecting too much ;)
Am finding new things which amaze all the time and getting used to the interface.
I was waiting for the Touch Pro on TMob but decided to go with the Diamond version as PC Pro said that issues had been resolved with a Rom upgrade. Was told by TMob that new rom was on these phones :D Also decided I don't need the hardware keyboard cause although it looks much better than the Vario, I never used it and got frustrated when I tried. I am quicker pecking with a stylus on the screen keybard and that at least lets me scroll to where I want easliy.
I use the device for business purposes and need all the Exchange server/business connection stuff much more than any media type stuff. Thought the TPro might be better for that but if not using the hardware keyboard, only extra memory and expandable storage is the difference.

However,

There does seem to be a few bugs that I have found, some of which have been mentioned in reviews etc (especially PC Pro magazine), namely:

1) on-screen qwerty keyboard obscures the line of text you are inputting :(
2) Touch3D seems sluggish at times and skips to another area of the screen as it catches up with what you are pressing
3) backlight doesn't come on. Had to restart the device yesderday to get it to work
4) initial setup; the screen alingment didn't work. nothing happens when pressing the crosshairs for about five minutes then it moves to the next area. This sometimes doesn't work at all and needs a reboot
5) having to realign screen a few times as the close x button and right hand side scroll bar are unresponsive. They need a great deal of pressure to use accurately sometimes(Maybe that is just me not being used to the new device? How do I increase screen touch sensitivity?)
6) Standard factory Rom from July 08 on phone, probably explains some of the above issues (Will TMob get a new Rom out, if not, shouldn't we be bombarding them with emails asking to do so?)

will think of more but that is the list so far.

Any suggestions/opinions?

Cheers,
Dave


Which ROM version do you have (Settings/System/Device Information) ; 1.93 is the current ROM, and 1.37 was the slow original one (actually there was an older, even slower one, but it wasn't released to the public!)

Your screen issues are not typical- the Screen Align and scrollbar/OK button problems may well indicate faulty hardware. I'd suggest a hard reset first (Settings/System/clear Storage) and if its no better send it back for a replacement. The navigation slowness could also be a result of a dodgy hardware problem, if the digitiser isn't working properly.

  • 0
NeilM: Site Moderator and Reviewer on SmartphoneGurus

Posted ImagePosted Image

Windows Mobile Specialist Certification


#3
dwhyte

dwhyte

    Newbie

  • Members
  • Pip
  • 12 posts

Which ROM version do you have (Settings/System/Device Information) ; 1.93 is the current ROM, and 1.37 was the slow original one (actually there was an older, even slower one, but it wasn't released to the public!)

Your screen issues are not typical- the Screen Align and scrollbar/OK button problems may well indicate faulty hardware. I'd suggest a hard reset first (Settings/System/clear Storage) and if its no better send it back for a replacement. The navigation slowness could also be a result of a dodgy hardware problem, if the digitiser isn't working properly.



Thanks Neil,

Yeah screen thing could be faulty hardware.

Rom details:
1.37.110.3 WWE
Date 20/06/08
Radio 1.00.25.03

Not keen on swapping out original TMob ROM to another. My thinking is that TMOb should have this device working out of the box! If that means that they need to upgrade the custom ROM then they have to do it. They must keep up with the manufacturer if HTC update to fix issues surely? They did apparently stop selling the Compact IV for a couple of weeks to sort out issues in July or Aug. I was told that all issues were sorted since then but when I got my device, it showed an original Rom from June 08 <_<

Dave

  • 0

#4
dwhyte

dwhyte

    Newbie

  • Members
  • Pip
  • 12 posts
Forgot to mention that I got the upgrade to Compact IV from original Vario:

Phone free
(Was on an ancient W+W package, out of contract with half price line rental. Was paying £20/month for 200 min/50 texts + 40mb data)
upgrade to Combi 25 + W+W for £30/month

Seemed good to me as I got the phone free but maybe should have haggled for more discount off monthly rate or loyalty discount etc?

What deals have others got?
I am still in my 7 day cooling off period

Dave

Edited by dwhyte, 21 September 2008 - 02:34 PM.

  • 0

#5
andybarker

andybarker

    Diehard

  • Assistant Admin Team
  • PipPipPipPip
  • 377 posts
  • Gender:Male
  • Location:Hertfordshire
  • Devices:S4, Transformer Infinity, N7
I've had my Compact IV for 2 weeks now, and since i upgraded the firmware I've been very happy. The T-Mobile firmware is pretty pants!

I tried the HTC firmware and thought it was good, but preferred the SwiftBL firmware as it was close to the original HTC whilst being much quicker and having the most recent versions of .NET etc.
When T-Mobile bring out a new firmware, I might give it a try.

I've heard people complaining about Sony Ericsson, Nokia, etc having crap firmware when released - so isn't a situation unique to T-Mobile / HTC. Glad there are forums like this to help people out.

  • 0

#6
dwhyte

dwhyte

    Newbie

  • Members
  • Pip
  • 12 posts
another bug:

The Keyboard input (windows mobile keybard) dows not give word suggestions at all even when set to.
Only the Touch3d Qwerty gives suggestions.

Really having a problem with the right hand side of the screen. Scroll bar is a nightmare to use with a lot of pressure needed on the screen and closing windows takes three clicks sometimes.

Any one else had these issues?

Dave

  • 0

#7
FatBloke23

FatBloke23

    Newbie

  • Members
  • Pip
  • 24 posts

another bug:

The Keyboard input (windows mobile keybard) dows not give word suggestions at all even when set to.
Only the Touch3d Qwerty gives suggestions.

Really having a problem with the right hand side of the screen. Scroll bar is a nightmare to use with a lot of pressure needed on the screen and closing windows takes three clicks sometimes.

Any one else had these issues?

Dave

I started a thread about that keyboard input problem a week or two ago -- someone else said it was fine on theirs, and suggested that it was down the cooked ROM (SwiftBL 6, I think) that I was using.

I've not had the chance to flash a new ROM yet, but I'm pretty dismayed to find it happening with an official ROM too. Bugger.

I've not had any screen problems -- you can adjust the pressure though...it's in the settings somewhere.

  • 0

#8
dwhyte

dwhyte

    Newbie

  • Members
  • Pip
  • 12 posts

I started a thread about that keyboard input problem a week or two ago -- someone else said it was fine on theirs, and suggested that it was down the cooked ROM (SwiftBL 6, I think) that I was using.

I've not had the chance to flash a new ROM yet, but I'm pretty dismayed to find it happening with an official ROM too. Bugger.

I've not had any screen problems -- you can adjust the pressure though...it's in the settings somewhere.



Thanks Fatbloke,

Have looked at screen pressure settings, does no good at all.
Other screen related problems had started so I phoned TMob and am getting replacement handset. Will see how that is and then look at software/ROM issues.
Not keen on flashing a non-TMob ROM though without a backup of the original one on the phone.
Anyone with any instructions on how to save the original?

P.S. See my related thread at http://www.whatmobil...isplay.php?f=70 for other details.

Cheers,
Dave

  • 0

#9
camcone

camcone

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:tmobile compact iv

Which ROM version do you have (Settings/System/Device Information) ; 1.93 is the current ROM, and 1.37 was the slow original one (actually there was an older, even slower one, but it wasn't released to the public!)

Your screen issues are not typical- the Screen Align and scrollbar/OK button problems may well indicate faulty hardware. I'd suggest a hard reset first (Settings/System/clear Storage) and if its no better send it back for a replacement. The navigation slowness could also be a result of a dodgy hardware problem, if the digitiser isn't working properly.



Hi, I need help, can anyone help me find the english version of the 1.93 rom update, my son programmed my phone with a german version and I just can find the correct update..

Thanks in advance..

  • 0

#10
stunno

stunno

    Regular

  • Members
  • PipPip
  • 83 posts
  • Location:PRoT
  • Devices:MDA Compact III

Hi, I need help, can anyone help me find the english version of the 1.93 rom update, my son programmed my phone with a german version and I just can find the correct update..

Thanks in advance..


Have a look in the Diamond section on xda developers, http://forum.xda-dev...splay.php?f=428 specifically in the ROM section.

There are a multitude of choices, I'm using the 'Nataly' one and it is a lot quicker that the stock tmobile one. and prettier too

  • 0

#11
Jasonkruys

Jasonkruys

    Diehard

  • Members
  • PipPipPipPip
  • 457 posts
  • Location:Bournemouth
  • Devices:M5000

Thanks Neil,

Yeah screen thing could be faulty hardware.

Rom details:
1.37.110.3 WWE
Date 20/06/08
Radio 1.00.25.03

Not keen on swapping out original TMob ROM to another. My thinking is that TMOb should have this device working out of the box! If that means that they need to upgrade the custom ROM then they have to do it. They must keep up with the manufacturer if HTC update to fix issues surely? They did apparently stop selling the Compact IV for a couple of weeks to sort out issues in July or Aug. I was told that all issues were sorted since then but when I got my device, it showed an original Rom from June 08 :(

Dave


That is the old ROM, and is very poor. T-Mobile have since been sending phones back from repair with an official T-Mo 1.93 ROM on, although I haven't seen anywhere to download it yet. I would seriously consider using a non-standard cooked rom though, much better than the operator roms.

  • 0
Motorola Tristar > Nokia 8210 > Nokia 8310 > SPV > SPV E100 > C500 > M5000 > Diamond/Victor > Leo/HD2

#12
Jasonkruys

Jasonkruys

    Diehard

  • Members
  • PipPipPipPip
  • 457 posts
  • Location:Bournemouth
  • Devices:M5000

Hi, I need help, can anyone help me find the english version of the 1.93 rom update, my son programmed my phone with a german version and I just can find the correct update..

Thanks in advance..


Although it has been seen on phones returned from repair, T-Mobile UK have not yet released an official version for download!

  • 0
Motorola Tristar > Nokia 8210 > Nokia 8310 > SPV > SPV E100 > C500 > M5000 > Diamond/Victor > Leo/HD2

#13
delboy265

delboy265

    Newbie

  • Members
  • Pip
  • 1 posts

Which ROM version do you have (Settings/System/Device Information) ; 1.93 is the current ROM, and 1.37 was the slow original one (actually there was an older, even slower one, but it wasn't released to the public!)

Your screen issues are not typical- the Screen Align and scrollbar/OK button problems may well indicate faulty hardware. I'd suggest a hard reset first (Settings/System/clear Storage) and if its no better send it back for a replacement. The navigation slowness could also be a result of a dodgy hardware problem, if the digitiser isn't working properly.


hi just wondering here but how do you do a hard reset my son was playing with my mda compact iv and somehow changed my access code how do i get it fixed pls help

thank you in advance

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users