Jump to content


Photo

REALLY poor signal on T-Mobile

- - - - -

  • Please log in to reply
1 reply to this topic

#1
Chimpanzee

Chimpanzee

    Chimpanzee

  • Members
  • PipPip
  • 128 posts
  • Location:Bristol, UK
  • Devices:HTC Touch Pro
I just got a Touch Pro on T-Mobile from Expansys (thanks for the tenner off!).

I love the device but the signal is poor to the point of unusable both at work (the center of Bristol) and at home. I've rung T-Mobile who said I should have "excellent" coverage in both my home and work postcodes. I've never been on T-Mobile before but I'd guess it should be better than this?

It's ruining the device for me. Mostly because I can't make calls but there are so many web features on it that I can't use.

Browsing around the web, it looks as if this is a problem for quite a few people. Anyone know of a solution? I have tried setting the band from "Automatic" to GPRS but that made no difference. When I put my Orange sim card in there, it's better but still significantly lower than when it's in my N95.

Does anyone have anything to suggest? I REALLY don't want to have to send this device back.

Anyone in the Bristol area who ISN'T having this problem. If so, it might suggest a faulty handset and I'll get it exchanged.

  • 0

#2
Jonny_doe

Jonny_doe

    Regular

  • Members
  • PipPip
  • 68 posts
  • Location:Bristol
  • Devices:HTC Touch Pro
Hello , sorry i've only just seen this post ..

I got a Touch Pro on T-Mobile from Expansys , and i live in Bristol (Bishopsworth ) , and work in the B.R.I. (hospital) in the center of town , and my signal is fine , infact i've found it better in a lot of places than Orange (my old provider ) was before ...

  • 0
Posted Image




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users