Jump to content


Photo

►► Permanent GPS fix for Samsung i900 & i8000 Omnia ◄◄

* * * * * 3 votes

  • Please log in to reply
247 replies to this topic

#41
ansh_xaviers

ansh_xaviers

    Regular

  • Members
  • PipPip
  • 62 posts

Finally Permanent GPS fix for i900 Omnia (more info click here)

Goodluck! ;)

J.



thanks...its working

  • 0

#42
Junoman

Junoman

    Enthusiast

  • Members
  • PipPipPip
  • 200 posts
  • Devices:Samsung i900 Omnia
Yep!

It's a smart work! ;)

thanks...its working


  • 0

#43
wackyiraqi

wackyiraqi

    Newbie

  • Members
  • Pip
  • 14 posts
  • Devices:Samsung Omnia
I just tried these settings and when I run Garmin XT it crashes the phone immediately. Am I missing something?

  • 0

#44
Heintraag

Heintraag

    Regular

  • Members
  • PipPip
  • 67 posts
  • Devices:Google Nexus S
Running TomTom 7.19 and with this registry fix is works! I chose the built-in gps in TomTom and under 10 seconds it has a perfect steady fix on at least 6 - 8 sats. Thanks!!

  • 0

#45
ascot17

ascot17

    Regular

  • Members
  • PipPip
  • 112 posts
  • Devices:HTC Desire

Running TomTom 7.19 and with this registry fix is works! I chose the built-in gps in TomTom and under 10 seconds it has a perfect steady fix on at least 6 - 8 sats. Thanks!!


+ 1 !!

  • 0
HTC One S (Black)
Stock everything.... so far....

#46
Zarko

Zarko

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:Omnia

I just tried these settings and when I run Garmin XT it crashes the phone immediately. Am I missing something?


Same thing here!! :D

UPDATE
I think I found the solution.

- HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\Samsung GPS Hardware\SleepOnNoData: set from 100 to 0 <-shouldn't be 0 I put 5 myself and Garmin XT works like a charm now


THANK YOU A LOT JUNOMAN, MY NAVIGATION WORKS IN SECONDS EVEN INDOORS NOW WHICH WAS UNTHINKABLE BEFORE

Edited by Zarko, 13 February 2010 - 12:01 AM.

  • 0

#47
slovenec88

slovenec88

    Regular

  • Members
  • PipPip
  • 59 posts
  • Gender:Male
  • Location:Nazarje
  • Devices:Samsung Omnia
  • Twitter:@slovenec88

Same thing here!! :D

UPDATE
I think I found the solution.

- HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\Samsung GPS Hardware\SleepOnNoData: set from 100 to 0 <-shouldn't be 0 I put 5 myself and Garmin XT works like a charm now
THANK YOU A LOT JUNOMAN, MY NAVIGATION WORKS IN SECONDS EVEN INDOORS NOW WHICH WAS UNTHINKABLE BEFORE


Thanks! Garmin crashes with 0..

  • 0

#48
Zarko

Zarko

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:Omnia

Thanks! Garmin crashes with 0..


Slučajno sem pogruntal :D

  • 0

#49
tingchung_chin

tingchung_chin

    Diehard

  • Members
  • PipPipPipPip
  • 308 posts
  • Devices:i900

Same thing here!! :D

UPDATE
I think I found the solution.

- HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver\Drivers\Samsung GPS Hardware\SleepOnNoData: set from 100 to 0 <-shouldn't be 0 I put 5 myself and Garmin XT works like a charm now
THANK YOU A LOT JUNOMAN, MY NAVIGATION WORKS IN SECONDS EVEN INDOORS NOW WHICH WAS UNTHINKABLE BEFORE

Great!!! working now :D

  • 0

#50
^nighthawk^

^nighthawk^

    Newbie

  • Members
  • Pip
  • 49 posts
  • Devices:Samsung Galaxy S
I think the original reporter needs credit also. As it wasnt weirdo , although i admire his hard work.

  • 0

#51
weirdo

weirdo

    Enthusiast

  • Members
  • PipPipPip
  • 249 posts
  • Devices:28005 FloTaniumLite

I think the original reporter needs credit also. As it wasnt weirdo , although i admire his hard work.



doesnt matter to me :D

i always say $HARE OR DIE

  • 0

#52
Junoman

Junoman

    Enthusiast

  • Members
  • PipPipPip
  • 200 posts
  • Devices:Samsung i900 Omnia
Thanks for letting us know bro!

Keep coming! :D

doesnt matter to me :D

i always say $HARE OR DIE


  • 0

#53
JaGuR

JaGuR

    Regular

  • Members
  • PipPip
  • 94 posts
  • Devices:Omnia i900

4. Select 'Other NMEA GPS receiver'
5. Set baud rate to 4800



Works for me thanks,

But don't know why people rave about tomtom, iGO8 is so better in every way

  • 0

#54
oreno

oreno

    Newbie

  • Members
  • Pip
  • 2 posts
Didn't work for me :D
No matter what i do ,i've changed phone part,roms and did the tweak registry but always poor gps reception
Even after 30-40 min no gps fix :D

  • 0

#55
JaGuR

JaGuR

    Regular

  • Members
  • PipPip
  • 94 posts
  • Devices:Omnia i900
Seems after running it the first time and then exiting from it, I get a low memory error, and I then have to soft reset the phone before I can get it to work again :/

  • 0

#56
doi620

doi620

    Regular

  • Members
  • PipPip
  • 52 posts

Seems after running it the first time and then exiting from it, I get a low memory error, and I then have to soft reset the phone before I can get it to work again :/


You guys should go to the original post (#37) and check the links for explanation (it's in German, but you should be able to understand the GPS settings):

http://www.modaco.co...a-900i/page/20/

Edited by doi620, 16 February 2010 - 01:50 PM.

  • 0

#57
fikacu

fikacu

    Newbie

  • Members
  • Pip
  • 11 posts
  • Devices:I900 Omnia
Working great with Garmin.
I get a satelite lock in ~5secs with latest Xtra data.
Tnx alot weirdo, Junoman, tingchung_chin.

  • 0

#58
JaGuR

JaGuR

    Regular

  • Members
  • PipPip
  • 94 posts
  • Devices:Omnia i900

You guys should go to the original post (#37) and check the links for explanation (it's in German, but you should be able to understand the GPS settings):

http://www.modaco.co...a-900i/page/20/



Am already using those registry settings, thanks :D

  • 0

#59
oreno

oreno

    Newbie

  • Members
  • Pip
  • 2 posts
Seems it's without hope for my omnia :D
No fix for my gps
perhaps my gps is broken,i've tried many things including this registry tweaks

  • 0

#60
Bruno Adler

Bruno Adler

    Enthusiast

  • Members
  • PipPipPip
  • 299 posts
  • Devices:Samsung Omnia I900L
Works for me here.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users