Jump to content


Photo

sms incoming msg timestamp is wrong

- - - - -

  • Please log in to reply
14 replies to this topic

#1
nonsence

nonsence

    Newbie

  • Members
  • Pip
  • 4 posts
  • Devices:HTC TYTN II
i got an issue with my wm6.1 (htc rom) htc tytn ii (aka kaiser, aka kais100, aka att tilt, aka i'm sure its got more codenames by now.. sigh lol) anywho,

the problem is that incoming sms text messages have a timestamp from 4 hours ago

i have tried hard reset, configuring the regional/timezone settings, and have installed the microsoft dst timezone patch. also there was a settings regarding the registry i read on the xda forums which was supposed to make it ignore network provider timezone for the phone (i forget the reg key, xda forums is not loading for me now...)

on htc's web site there is a new rom update for the att tilt. its still wm6.1 but probably with some bug fixes, drivers, patches, etc. not sure if it will work on my htc kaiser.... if it does it will also delete some built-in apps which the att rom doesnt have but the htc does include...

i called htc support and was quickly told it was a network issue. i'm using rogers wireless in canada on the gsm network. i called them and they said they wont support it since its an htc branded unlocked gsm pda. so now i'll be calling htc back again to argue the point with them.

i'm waiting for my old sony ericson to charge so i can switch the sim then test sms msg on it. i would assume it will work. i've gone through 4 unlocked gsm phones with rogers and only until the htc kaiser did i have an issue with sms timestamp. so i think it isn't a network issue. cus apparently rogers wont do s*** about it cus its unlocked non-rogers brand.

sry if i sound angry lol. but any help would be appreciated. i hate talkin to tech support. they do nothing most of the time but come up with excuse for not helping lol

any suggestions? :-)

  • 0

#2
Monolithix

Monolithix

    Hardcore

  • MoDaCo Gold
  • PipPipPipPipPipPip
  • 8,783 posts
Have you checked the person sending you the SMS has the time set correctly on their handset?

  • 0

I still exist


#3
nonsence

nonsence

    Newbie

  • Members
  • Pip
  • 4 posts
  • Devices:HTC TYTN II

Have you checked the person sending you the SMS has the time set correctly on their handset?


i havent checked but i would assume that they do have correct times on their own phones. plus this issue happens with anyone sending me a text msg. i tried also sending txt msg to myself via windows live messenger, same issue. i dont think the problem has to do with other devices. cus for example if i got a text msg from china (i'm in canada), the txt msg would (should) show a recieved time in my local timezone. not from china lol. at least thats my understanding of the issue.

my guess... its a registry problem somewhere.... for wm, everything is a registry problem!

  • 0

#4
Monolithix

Monolithix

    Hardcore

  • MoDaCo Gold
  • PipPipPipPipPipPip
  • 8,783 posts
Heh, usually yes. It is strange that it's affecting all messages but I seem to remember hearing the same thing HTC are saying, that it's a network issue. In fact, I thought sms timestamps were set by the receiving SMSC? A quick test here would seem to imply that.

Not saying it isn't necessarily a handset problem though :rolleyes:

  • 0

I still exist


#5
nonsence

nonsence

    Newbie

  • Members
  • Pip
  • 4 posts
  • Devices:HTC TYTN II

Heh, usually yes. It is strange that it's affecting all messages but I seem to remember hearing the same thing HTC are saying, that it's a network issue. In fact, I thought sms timestamps were set by the receiving SMSC? A quick test here would seem to imply that.

Not saying it isn't necessarily a handset problem though :rolleyes:


hmm i dont know. i really dont. but i'm reading up on it - http://www.developer...l.asp?page=smsc

i wish i had another phone right now just to test. but if memory serves me right, sms timestamps were working fine on a 7290 blackberry and a nokia i had a few months ago. same number, same sim. but i guess a few months ago doesnt mean now...

rogers wireless tech said he could "reset" my wireless account. dont know what that means.... but it didnt work

  • 0

#6
nonsence

nonsence

    Newbie

  • Members
  • Pip
  • 4 posts
  • Devices:HTC TYTN II
found the fix on the xda forums.

FIX: You need to add this to the registry: Go to HKEY_LOCAL_MACHINE\SOFTWARE\OEM\PhoneSetting\
Add a dword key "TrustTimeZoneField" and give it a dword value of 0

http://forum.xda-dev...ad.php?t=374956

funny, their forum was down a min ago. then it came back up, i searched it, found that, tried the reg tweak, tested and it worked. now their forum is down again for me... shame. i hope their servers r ok after today

from my reading on that post it seems the issue is in regards to the rogers network giving out the wrong timezone settings, and the wm devices just accepting it without checking. god i hate rogers. also hate microsoft. but i love my tytn ii....... hate my tytn ii..... no no love my tytn ii.... sigh i cant decide....

  • 0

#7
Monolithix

Monolithix

    Hardcore

  • MoDaCo Gold
  • PipPipPipPipPipPip
  • 8,783 posts
Heh, so a combination of both network and WinMo issues! Glad you got it sorted :rolleyes:

  • 0

I still exist


#8
jaxris

jaxris

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:EPiX i907

Heh, so a combination of both network and WinMo issues! Glad you got it sorted :rolleyes:



That registry fix did not work for me on my EPiX on the Rogers network
I did not have the OEM key or the phonesetting key so I added them, then TrustTime DWORD, rebooted and still off by 5 hours.....did I miss something or am I doing it worng?



thanks

J

  • 0

#9
jaxris

jaxris

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:EPiX i907
No one has any ideas?
Not even the usual smart a$$ "your a noob?"
Its really annoying me, such a small thing as a time stamp but damn annyoing!!!

  • 0

#10
byDM

byDM

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:Touch Pro 2
thanks so much!!! I have a touch pro 2 bought unlocked and was starting to loose hope. It worked perfectly! :)

  • 0

#11
celaradar

celaradar

    Newbie

  • Members
  • Pip
  • 1 posts

found the fix on the xda forums.

FIX: You need to add this to the registry: Go to HKEY_LOCAL_MACHINE\SOFTWARE\OEM\PhoneSetting\
Add a dword key "TrustTimeZoneField" and give it a dword value of 0

http://forum.xda-dev...ad.php?t=374956

funny, their forum was down a min ago. then it came back up, i searched it, found that, tried the reg tweak, tested and it worked. now their forum is down again for me... shame. i hope their servers r ok after today

from my reading on that post it seems the issue is in regards to the rogers network giving out the wrong timezone settings, and the wm devices just accepting it without checking. god i hate rogers. also hate microsoft. but i love my tytn ii....... hate my tytn ii..... no no love my tytn ii.... sigh i cant decide....



Anyone got this fix to work on Samsung Omnia device???
those registry folders (OEM\PhoneSetting) dont seem to exist on my phone.
Cab file registred those values, but with no successful result.

  • 0

#12
pmmstan

pmmstan

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:Samsung Omnia II

Anyone got this fix to work on Samsung Omnia device???
those registry folders (OEM\PhoneSetting) dont seem to exist on my phone.
Cab file registred those values, but with no successful result.


Hi, I have the same issue - Omnia II device. Can't find the registry folders OEM\PhoneSettings

Appreciate any help to resolve this timestamp issue please..

Thanks!

Btw, am with Petro Canada Mobility which I believe belongs to Rogers too.

  • 0

#13
l4cky

l4cky

    Newbie

  • Members
  • Pip
  • 21 posts
  • Devices:Samsung OMNIA 2

Hi, I have the same issue - Omnia II device. Can't find the registry folders OEM\PhoneSettings

Appreciate any help to resolve this timestamp issue please..

Thanks!

Btw, am with Petro Canada Mobility which I believe belongs to Rogers too.

I am with Fido Canada, having Omnia 2, same problem here

  • 0

#14
willis111

willis111

    Regular

  • Members
  • PipPip
  • 74 posts
  • Location:Ontario, Canada
  • Devices:Omnia I8000L

I am with Fido Canada, having Omnia 2, same problem here



Same thing here, rogers canada + omnia 2. Haven't been able to find a fix that actually works.

  • 0

#15
rachely476

rachely476

    Newbie

  • Members
  • Pip
  • 1 posts

hmm i dont know. i really dont. but i'm reading up on it - http://www.developer...l.asp?page=smsc

i wish i had another phone right now just to test. but if memory serves me right, sms timestamps were working fine on a 7290 blackberry and a nokia i had a few months ago. same number, same sim. but i guess a few months ago doesnt mean now...

rogers wireless tech said he could "reset" my wireless account. dont know what that means.... but it didnt work

Thanks for sharing the link!

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users