Jump to content


Photo

i8000 TMC driver development

* * * * * 2 votes

  • Please log in to reply
177 replies to this topic

#121
_joker_

_joker_

    Newbie

  • Members
  • Pip
  • 30 posts

Hi,

yes, the phj driver can be used for pay-tmc (in german tmcpro). if you see in igo CA-TMC (no code), then you have the tmcpro channel, but the wrong version of igo. the only version of igo that have a build in tmcpro code is version 8.3.2.90500. if you use the same channel as above, you see CA-TMC (code ok), and that means that you know will get tmcpro messages (even better than normal tmc messages, here in germany).
thanx phj for your fantastic driver.



Thank you for this great contribution :D

I have tested it and it is working great :D Only problem is, that TMC signal is locked in my country. In IGO displays CA-TMC (no key). This probably is not possible to solve?


look quote from geroh. I have iGO8 8.3.2 90500 and phj' gfmapi.dll works fine! iGO say CA-TMC (key ok). Other versions say no key!

Greeting _joker_

  • 0

#122
etermos

etermos

    Newbie

  • Members
  • Pip
  • 28 posts
  • Location:Europe|Sweden|Örebro
  • Devices:Omnia GT-i8000 & sghi900
i got 8.3.4.102680 and gfmapi 1,10 or earlier and it all works ok in sweden


//E

  • 0

#123
trishull

trishull

    Newbie

  • Members
  • Pip
  • 4 posts
  • Devices:samusung omnia
Ok tried everything now but still no go on mine B7610

1. downloaded installed hypergps bet9 (windows directory)
2. downloaded installed gfmapi.dll (windows directory)

getting station 89.0 and 108.0 only and igo cant find any tmc freq.

Noobie need help :D

  • 0

#124
phj

phj

    Regular

  • Members
  • PipPip
  • 85 posts
  • Location:Veszprém, Hungary
  • Devices:I8000

all links here on this page is dead

http://phj.hu/i8000/TMC/

which version HyperGPS is for O2 from this link?
http://forum.xda-dev...ad.php?t=512630
edit:

Thanks, the links corrected - both version were changed... On the Hypergps thread you can download any of the images, neither good directly for OmniaII - the gfmapi.dll differs, and that will replaced with my cab....

  • 0

#125
trishull

trishull

    Newbie

  • Members
  • Pip
  • 4 posts
  • Devices:samusung omnia
working now, i hard reset my b7610, installed hypergps and gfmapi and getting tmc now thanks for this great app. :D

  • 0

#126
Dado...

Dado...

    Diehard

  • Members
  • PipPipPipPip
  • 300 posts
  • Gender:Male
  • Devices:HTC HD2 WP7, HP iPAQ hx2790
anyone from Hungary can tell me is in south Hungary (around Berzence or Barch) have TMC signal?

  • 0
My Device: HTC HD2 (BTTF WP7)
My Old Devices: HTC 7 Pro, Samsung Omnia 2 i8000, Omnia i900...

#127
phj

phj

    Regular

  • Members
  • PipPip
  • 85 posts
  • Location:Veszprém, Hungary
  • Devices:I8000

anyone from Hungary can tell me is in south Hungary (around Berzence or Barch) have TMC signal?

In Hungary the Radio "PETOFI" spread TMC info, the frequencies vary....

  • 0

#128
Dado...

Dado...

    Diehard

  • Members
  • PipPipPipPip
  • 300 posts
  • Gender:Male
  • Devices:HTC HD2 WP7, HP iPAQ hx2790
thank you... every summer i go to Hungary but no problem to "jump" any day to short trip.... best (closest) is 94.3FM in Nagykanizsa for me but here national croatian radio (HRT-HR 3) have same freq :D maybe this summer have chance in hungary to test TMC....

Edited by Dado..., 20 February 2010 - 08:57 PM.

  • 0
My Device: HTC HD2 (BTTF WP7)
My Old Devices: HTC 7 Pro, Samsung Omnia 2 i8000, Omnia i900...

#129
Dado...

Dado...

    Diehard

  • Members
  • PipPipPipPip
  • 300 posts
  • Gender:Male
  • Devices:HTC HD2 WP7, HP iPAQ hx2790

  • 0
My Device: HTC HD2 (BTTF WP7)
My Old Devices: HTC 7 Pro, Samsung Omnia 2 i8000, Omnia i900...

#130
y17dt

y17dt

    Enthusiast

  • Members
  • PipPipPip
  • 183 posts
Hi,

i have played some time with the TMC-driver(and I really love it), but now I started testing it in real life...
So every time I activate HyperGPS, my GPS-reciever looses its satellits. It seems as if it(GPS reciever) restartes every 1-3minutes and the GPS-signal is really poor.
After switching off HyperGPS everything acts als usual again(no probs with GPS).
Yesterday I reinstalled everything and downloadet the newest versions, but it doesn´t change anything. Still the same problems.
So I´m able to receive TMC-messeges, but my GPS doesn´t work proper anymore, while recieving Messeges.

I have tested GPS at:
Com7 Baud 4800 and 9600
should I use different GPS settings?

Regards
Tobi

EDIT: Found the solution. USE ROYALTEK PRTOKOLL WITH IGO 8

Configuration for IGO:
Com4
Use TMC Data(not GPS, TMC Data)
Royaltek.
Use Autodetect in IGO and all will work.

Edited by y17dt, 26 February 2010 - 06:49 PM.

  • 0

#131
y17dt

y17dt

    Enthusiast

  • Members
  • PipPipPip
  • 183 posts
Hey,

found another prob.

I always had bad connections to the TMC-Radio stations. After some investigation I found the problem in the car-charger. I owned a very cheap one from Amazon, wich seems to produce an interferring frequence. So I bought the original one from Samsung and had no problems anymore with loosing my connection.

Regards

  • 0

#132
HHFish

HHFish

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:GT-B7610
Hey all,

thanks PHJ for your work.
I have been trying to make this work on my B7610 for a while now. For some reason, I cannot get Igo 8 to recognise the TMC hardware when selecting Royaltek as protocol. I tried all possible COM ports. But when I set the driver protocol to GNS (TMC+GPS data) Igo 8 finds the hardware and starts searching. The problem with the GNS protocol is that Igo 8 does not seem to pick up any TMC events. I live in Switzerland and when I set HyperGPS to Royaltek in test mode it picks up plenty of $RTTCM events. Needless to say that I am using my headphones as antenna.
I have seen that most B7610 owners here have gotten their Igo 8 to work with Royaltek, so I am confused. Now that I have a big journey coming up, well in two days from now, I got desperate enough to post my first question to this forum.
Does anyone of you have an idea how to solve this problem?
My Igo8 version is 8.0.0.35389 and I am using HyperGPS version 1.0. I installed everything as per PHJ's instructions.

Regards,

  • 0

#133
nizar445

nizar445

    Newbie

  • Members
  • Pip
  • 33 posts
  • Devices:HTC P3600, Samsung B7610

Hey all,

thanks PHJ for your work.
I have been trying to make this work on my B7610 for a while now. For some reason, I cannot get Igo 8 to recognise the TMC hardware when selecting Royaltek as protocol. I tried all possible COM ports. But when I set the driver protocol to GNS (TMC+GPS data) Igo 8 finds the hardware and starts searching. The problem with the GNS protocol is that Igo 8 does not seem to pick up any TMC events. I live in Switzerland and when I set HyperGPS to Royaltek in test mode it picks up plenty of $RTTCM events. Needless to say that I am using my headphones as antenna.
I have seen that most B7610 owners here have gotten their Igo 8 to work with Royaltek, so I am confused. Now that I have a big journey coming up, well in two days from now, I got desperate enough to post my first question to this forum.
Does anyone of you have an idea how to solve this problem?
My Igo8 version is 8.0.0.35389 and I am using HyperGPS version 1.0. I installed everything as per PHJ's instructions.

Regards,



It works perfectly on my B7610. My setting for HGPSClient as follows (only the once that I changed) it might help you.

HGPSClient:

TMC DRIVER ACTIVE
COM Port: COM8
Data output: TMC + GPS Data
Sound output: Speaker
Protocol: Royaltek

  • 0

#134
phj

phj

    Regular

  • Members
  • PipPip
  • 85 posts
  • Location:Veszprém, Hungary
  • Devices:I8000

Hey all,

thanks PHJ for your work.
I have been trying to make this work on my B7610 for a while now. For some reason, I cannot get Igo 8 to recognise the TMC hardware when selecting Royaltek as protocol. I tried all possible COM ports. But when I set the driver protocol to GNS (TMC+GPS data) Igo 8 finds the hardware and starts searching. The problem with the GNS protocol is that Igo 8 does not seem to pick up any TMC events. I live in Switzerland and when I set HyperGPS to Royaltek in test mode it picks up plenty of $RTTCM events. Needless to say that I am using my headphones as antenna.
I have seen that most B7610 owners here have gotten their Igo 8 to work with Royaltek, so I am confused. Now that I have a big journey coming up, well in two days from now, I got desperate enough to post my first question to this forum.
Does anyone of you have an idea how to solve this problem?
My Igo8 version is 8.0.0.35389 and I am using HyperGPS version 1.0. I installed everything as per PHJ's instructions.

Regards,

I have no B7610, but reported as working well. To know that you receive TMC signal or not, the quickest way is to use the PowerRadio. In the case the TMC "leds" are green, you have valid TMC data - in this case the iGO version can be a problem. Please check.

  • 0

#135
HHFish

HHFish

    Newbie

  • Members
  • Pip
  • 3 posts
  • Devices:GT-B7610

I have no B7610, but reported as working well. To know that you receive TMC signal or not, the quickest way is to use the PowerRadio. In the case the TMC "leds" are green, you have valid TMC data - in this case the iGO version can be a problem. Please check.



Dear PHJ and nizar445,

thank you for your support. I have just returned from an Easter vacation which involved travelling half across Europe. I did as advised and can now conclude that indeed my iGo 8.0 was the culprit. After not receiving any messages, even though I did have a green TMC symbol in PowerRadio, I decided to purchase a map update and in the process upgraded to iGo 8.3. I had no problems getting it to work on my return trip with the Royaltek protocol and TCM data only.

I can also confirm y17dt's observation that the GNS protocol interferes with the GPS receiver. His solution is valid.

Many thanks.

  • 0

#136
Odysseas07

Odysseas07

    Enthusiast

  • Members
  • PipPipPip
  • 201 posts
  • Location:Athens
  • Devices:Omnia2
Hello

Can someone tell me if we have to put the headphones everytime to have TMC ???

Thanksssssss

  • 0

#137
Dado...

Dado...

    Diehard

  • Members
  • PipPipPipPip
  • 300 posts
  • Gender:Male
  • Devices:HTC HD2 WP7, HP iPAQ hx2790
yes.... headphones is antenna for radio and radio not working if headphones not connected

  • 0
My Device: HTC HD2 (BTTF WP7)
My Old Devices: HTC 7 Pro, Samsung Omnia 2 i8000, Omnia i900...

#138
y17dt

y17dt

    Enthusiast

  • Members
  • PipPipPip
  • 183 posts

Hello

Can someone tell me if we have to put the headphones everytime to have TMC ???

Thanksssssss



Read from Post 84.

Headphones are not necessary, but you need an antenna. Just read!!!
Regards

  • 0

#139
redscorpion

redscorpion

    Newbie

  • Members
  • Pip
  • 23 posts
  • Devices:Omnia i900
Hi PHJ,

is it possible to port this driver also for Omnia i900?

I know so there is some old OmniaTMC project, but it doesn't support GNS protocol which is needed by Navigon...

So it will be cool if you will be able to modify this driver for i900...

Thanks...

  • 0

#140
phj

phj

    Regular

  • Members
  • PipPip
  • 85 posts
  • Location:Veszprém, Hungary
  • Devices:I8000

Hi PHJ,

is it possible to port this driver also for Omnia i900?

I know so there is some old OmniaTMC project, but it doesn't support GNS protocol which is needed by Navigon...

So it will be cool if you will be able to modify this driver for i900...

Thanks...

Unfortunately I have no i900 device and the OmniaTMC source is unavailable. Because is the radio driver is similar but lacks some entries which the i8000 driver has, quite hopeless to implement it in "blind" mode ...

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users