Jump to content


Photo

i8000 TMC driver development

* * * * * 2 votes

  • Please log in to reply
177 replies to this topic

#161
itsintilas

itsintilas

    Newbie

  • Members
  • Pip
  • 4 posts
Guys,

I have OMNIA II with JG4 Rom. I have succesfully fixed GPS performance with GPS Mod Driver (GPSmoddrivers uses COM2 and GPS uses COM4). Everything works perfectly with IGO8 and Primo1.1, as I have excellent navigation, accuracy and fast sat lock.
So, I tried to setup TMC, as well. I installed all cabs and followed instructions. The problem is that, although TMC seems to work when I setup HyperGPS (Driver can be set active and be tested as well), the GPS has stopped to get sat info.

I have unsuccesfully tried several COM options, like COM2 for GPSmodriver, COM4 for IGO8 and Primo 1.1 and COM 6 and 8 for HyperGPS. I have also unsuccesfully tried everything with GPSModdriver uninstalled.

Any idea?

  • 0

#162
Dado...

Dado...

    Diehard

  • Members
  • PipPipPipPip
  • 300 posts
  • Gender:Male
  • Devices:HTC HD2 WP7, HP iPAQ hx2790

Noticed that also. In Primo, frequency scanning is done in Royaltek only.
Protocol change in sys.txt and hypergps to gns stopped scanning. Freq 0.0
All with V2


royaltec mod is only recommended with Omnia / Omnia II

  • 0
My Device: HTC HD2 (BTTF WP7)
My Old Devices: HTC 7 Pro, Samsung Omnia 2 i8000, Omnia i900...

#163
ketegano

ketegano

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:Samsung Omnia II

Guys,

I have OMNIA II with JG4 Rom. I have succesfully fixed GPS performance with GPS Mod Driver (GPSmoddrivers uses COM2 and GPS uses COM4). Everything works perfectly with IGO8 and Primo1.1, as I have excellent navigation, accuracy and fast sat lock.
So, I tried to setup TMC, as well. I installed all cabs and followed instructions. The problem is that, although TMC seems to work when I setup HyperGPS (Driver can be set active and be tested as well), the GPS has stopped to get sat info.

I have unsuccesfully tried several COM options, like COM2 for GPSmodriver, COM4 for IGO8 and Primo 1.1 and COM 6 and 8 for HyperGPS. I have also unsuccesfully tried everything with GPSModdriver uninstalled.

Any idea?


Hello,

I use COM6 with HyperGPS and it works with iGO8, also I don't use GPS Mod Driver nor any other GPS mod program.

Port :COM6
FM Band : CCIR (I live in Spain)
Data output : TMC Data
Sound output : Speaker
Mute radio : Tuned sound
Log mode : Not logged
Protocol : Royaltek

My iGO8 settings for GPS are Port 7 and 57600 baud.

My sys.txt extract for gps:
[gps]
source="virtlserial"
port=7
baud=57600

My system.ini extract for tmc:
[tmc]
saved_config_available="1"
saved_config_classname="NMEA_GPSTMC_ROYALTEK"
saved_config_portname="COM"
saved_config_port="6"
saved_last_tuning_mode="0"
auto_tuning="0"
saved_last_frequency="1079"

Good luck!

  • 0

#164
norfer

norfer

    Newbie

  • Members
  • Pip
  • 5 posts
  • Devices:omnia i8000
  • Twitter:@gertz

Error reporting switched off - problem solved (at least it seems so :lol: ) THX a lot!


Hello wm2030,
i am also running Navigon 7.3.x on my Omnia 2 with HyperGPS, but as soon as i use HyperGPS with TMC then a get a huge delay in the GPS information: Waiting at a red traffic light i can see for approx 15 seconds how i am arriving!
So could you pls. show here your settings: Navigon version, standard rom version, used port etc?
regards
norfer


BTW: i use the old version of hypergps because with the new one (sept 19) i can get no GPS or TMC signal (no GNS signal, only ports 4-6-8?)

  • 0

#165
Dado...

Dado...

    Diehard

  • Members
  • PipPipPipPip
  • 300 posts
  • Gender:Male
  • Devices:HTC HD2 WP7, HP iPAQ hx2790
for Omnia use Royaltek protocol not GNS

  • 0
My Device: HTC HD2 (BTTF WP7)
My Old Devices: HTC 7 Pro, Samsung Omnia 2 i8000, Omnia i900...

#166
itsintilas

itsintilas

    Newbie

  • Members
  • Pip
  • 4 posts
Thank you guys, I 'll make a try.

  • 0

#167
rrr2

rrr2

    Regular

  • Members
  • PipPip
  • 94 posts
  • Location:Blue Planet
  • Devices:Omnia 2 GT-I8000 8GB

Hello,

I use COM6 with HyperGPS and it works with iGO8, also I don't use GPS Mod Driver nor any other GPS mod program.

Port :COM6
FM Band : CCIR (I live in Spain)
Data output : TMC Data
Sound output : Speaker
Mute radio : Tuned sound
Log mode : Not logged
Protocol : Royaltek

My iGO8 settings for GPS are Port 7 and 57600 baud.

My sys.txt extract for gps:
[gps]
source="virtlserial"
port=7
baud=57600

My system.ini extract for tmc:
[tmc]
saved_config_available="1"
saved_config_classname="NMEA_GPSTMC_ROYALTEK"
saved_config_portname="COM"
saved_config_port="6"
saved_last_tuning_mode="0"
auto_tuning="0"
saved_last_frequency="1079"

Good luck!


Thank You Man! It works! :lol:

Thank You phj! Now I can appreciate your work. Receiving events ...

Is there a way to listen to the radio station while navigating?

  • 0

#168
phj

phj

    Regular

  • Members
  • PipPip
  • 85 posts
  • Location:Veszprém, Hungary
  • Devices:I8000

Thank You Man! It works! :lol:

Thank You phj! Now I can appreciate your work. Receiving events ...

Is there a way to listen to the radio station while navigating?

There is a new 2.1 version, which has ( I hope ) correct audiopath setting. It was a hard work, because the audio device which must talk with differ regarding the jack state....

The original test program which used at the very beginning polished a bit - strongly recommend its usage in the case any TMC reception problem. The most important is the two numbers below the RDS text: the number of received RDS and TMC message frequency. The normal values is 10 : 2 , if less, the reception is not perfect.

Experimental feature of the program is the HyperGPS-like mode: in the TMC screen there is a possibility to select the navigation program, start it and over the virtual COM6 port act as Royaltek TMC receiver.

To download it, please study the web page

  • 0

#169
Ruud S

Ruud S

    Newbie

  • Members
  • Pip
  • 21 posts
  • Devices:GT-I8000

There is a new 2.1 version, which has ( I hope ) correct audiopath setting.


Thank you for this new version. Unfortunately, I'm having a small problem with audio in iGo with this version. Without a headset connected, if I set sound output to Speaker in HyperGPS I have no audio at all in iGo (no screen taps, no voice guidance). If I set sound output to Headset, I do have audio in iGo (again, without headset connected).

I would expect audio to be routed to the speaker independent of the sound output setting if no headset is connected. With a previous version, audio in iGo worked correctly when sound output was set to Speaker.

Kind regards,
Ruud

  • 0

#170
Larry Brent

Larry Brent

    Newbie

  • Members
  • Pip
  • 4 posts
Hi
can someone tell me, what registry values i have to change for loading and unloading the Hypergps driver, because with the HyperGps_Switcher the driver seems not to be unloaded well. My Omnia 2 hangs after every use and i have to softreset the device.


thanks

  • 0

#171
phj

phj

    Regular

  • Members
  • PipPip
  • 85 posts
  • Location:Veszprém, Hungary
  • Devices:I8000

Hi
can someone tell me, what registry values i have to change for loading and unloading the Hypergps driver, because with the HyperGps_Switcher the driver seems not to be unloaded well. My Omnia 2 hangs after every use and i have to softreset the device.
thanks

Unfortunately no such as I know.

  • 0

#172
muchospesos

muchospesos

    Newbie

  • Members
  • Pip
  • 39 posts
  • Devices:Omnia i8000
I installed the 2.1 GFMAPI and Rdsradio. I live in Finland and at my location TMC is working in rdsradio with frequency 99.9 but when I start igo primo i can't get tmc signal. I use the following sys.txt:

[interface]
show_exit=1
extra_settings=0
resolution_dir="800_480"
vga=0

[rawdisplay]
highres=0
screen_x=800
screen_y=480
class="landscape"

[tmc]
port="COM,6"
baud=38400
source="royaltek"
auto_tuning="1"
enable_subscription=1
;harman eten galik opentmc2 opentmc1 hyundai samsung amaryllo royaltek gns

[GPS]
source="virtserial"
port=9
baud=9600
protocol=nmea

I have tried many other TMC solutions but none of them has worked. This configuration shows me the frequency 0.0 others showed just an empty space.

Any Help is appreciated :P

  • 0

#173
rrr2

rrr2

    Regular

  • Members
  • PipPip
  • 94 posts
  • Location:Blue Planet
  • Devices:Omnia 2 GT-I8000 8GB

I installed the 2.1 GFMAPI and Rdsradio. I live in Finland and at my location TMC is working in rdsradio with frequency 99.9 but when I start igo primo i can't get tmc signal. I use the following sys.txt:

[interface]
show_exit=1
extra_settings=0
resolution_dir="800_480"
vga=0

[rawdisplay]
highres=0
screen_x=800
screen_y=480
class="landscape"

[tmc]
port="COM,6"
baud=38400
source="royaltek"
auto_tuning="1"
enable_subscription=1
;harman eten galik opentmc2 opentmc1 hyundai samsung amaryllo royaltek gns

[GPS]
source="virtserial"
port=9
baud=9600
protocol=nmea

I have tried many other TMC solutions but none of them has worked. This configuration shows me the frequency 0.0 others showed just an empty space.

Any Help is appreciated :P


Your sys.txt is odd.
GPS port is usually 7 (9 is the hardware port) as an example.

Try using the one posted by ketegano in this page.
It worked for me.
Also, mine is working better with v2 so consider that too.

  • 0

#174
pda_Phone

pda_Phone

    Newbie

  • Members
  • Pip
  • 1 posts
Thanks phj, you've breathed life into my Omnia II again. Found this at the right time while am currently in Germany. Quite useful feature. :)

  • 0

#175
mad_m

mad_m

    Newbie

  • Members
  • Pip
  • 2 posts
Hi,

http://phj.hu/i8000/TMC seems to be down again ?

Also one question, I guess Omnia Pro B7610 uses the same chip as the I8000 ?
So the installation should work the same way on OmniaPro ?

Tnx !

  • 0

#176
dabiz

dabiz

    Regular

  • Members
  • PipPip
  • 76 posts
  • Devices:samsung omnia II
Hi

I found that TMC works fine for me until I plug the AC car adaptor in the phone, after that I get no reception of TMC... any ideas?

  • 0

#177
Odysseas07

Odysseas07

    Enthusiast

  • Members
  • PipPipPip
  • 201 posts
  • Location:Athens
  • Devices:Omnia2
Phj hello

i just install your New Testing Method with rdsradio but i have problem.

With Previous version gfmapi and hyper i dont have this problem

i start the igo throu the rdsradio and when i go to tmc tab on Primo i can see that it search only on 87MHz and 108 MHz, what i can do for this???

I cant search manualy, it doesnt lett me to search manualy .

Some how it start and search other station but ...

On greece the 95.2 it has TMC the Primo Find this station, but on a few seconds change it and search for another station



I HAVE EXPERIENCE SOMETHING and i dont KNOW how i can do it AGAIN

I had use the rdsradio i close it and then i restart it again and with out HeadSet i can hear FM RADIO.

But i have soft reset my phone and i cant do it again....

PHJ do you know what happend ???

Edited by Odysseas07, 04 January 2011 - 12:46 PM.

  • 0

#178
DannyRo

DannyRo

    Newbie

  • Members
  • Pip
  • 1 posts
  • Gender:Male
  • Devices:PDA HP IPAQ 214
Hello evryone...

I have PDA HP IpaQ214 , GPS Bluetooth extern...and wait to receive from ebay a Royaltek TMC receiver with mini-usb conector...
Tell me...hyperGPS work only if i have a SMARTPHONE with RADIO or work and on PDA with TMC receiver?
Sorry for my poor english,
Best,
danny

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users