Jump to content


Photo

We have root..

- - - - -

  • Please log in to reply
40 replies to this topic

#21
bmic

bmic

    Newbie

  • Members
  • Pip
  • 9 posts

Hi,

I just rooted my milestone. I tried to install 2.1 launcher by using adb emulator. Now my phone doesn't start up ("android" flash screen is hanging). I bricked my phone :)
I also tried to reset it but the setup wizard forced close. I can't get into home screen.

Anyone please help!!!!


if you got into wizard that means you can get ADB working, you will need then:

1 Motorola ADB USB Driver
2 ADB program
3 Stock Launcher or any other Launcher in the market

The command to get a launcher installed is(taking that the file of the new launcher is called 'Launcher.apk'):

'adb install Launcher.apk'

So when you go to "home" the system will ask which launcher do you want to execute.

  • 0

#22
niotio910

niotio910

    Newbie

  • Members
  • Pip
  • 12 posts
  • Devices:Milestone

if you got into wizard that means you can get ADB working, you will need then:

1 Motorola ADB USB Driver
2 ADB program
3 Stock Launcher or any other Launcher in the market

The command to get a launcher installed is(taking that the file of the new launcher is called 'Launcher.apk'):

'adb install Launcher.apk'

So when you go to "home" the system will ask which launcher do you want to execute.


Hi Thanks a lot!
I'll try usb + adb at home since I don't have usb cable atm.
I wonder if I can run adb without activate "Debug" mode in Settings (because I can't have access to Settings).
Can I use abd install ... without root?

Here is the steps I bricked my phone:
I followed this link to install the launcher with following link:
http://alldroid.org/...hp?f=210&t=1220
I used adb emulator (in the phone). In the last steps, I couldn't remount /system. I ignored this step and just rebooted it.
The problem occurred :)


Any more ideas would be appreciated!

  • 0

#23
bmic

bmic

    Newbie

  • Members
  • Pip
  • 9 posts

Hi Thanks a lot!
I'll try usb + adb at home since I don't have usb cable atm.
I wonder if I can run adb without activate "Debug" mode in Settings (because I can't have access to Settings).
Can I use abd install ... without root?

Here is the steps I bricked my phone:
I followed this link to install the launcher with following link:
http://alldroid.org/...hp?f=210&t=1220
I used adb emulator (in the phone). In the last steps, I couldn't remount /system. I ignored this step and just rebooted it.
The problem occurred :)


Any more ideas would be appreciated!


you can try to flash with fastboot in bootloader mode, i think that a image file from a phone just like yours could do do the job.

  • 0

#24
bmic

bmic

    Newbie

  • Members
  • Pip
  • 9 posts

Hi Thanks a lot!
I'll try usb + adb at home since I don't have usb cable atm.
I wonder if I can run adb without activate "Debug" mode in Settings (because I can't have access to Settings).
Can I use abd install ... without root?

Here is the steps I bricked my phone:
I followed this link to install the launcher with following link:
http://alldroid.org/...hp?f=210&t=1220
I used adb emulator (in the phone). In the last steps, I couldn't remount /system. I ignored this step and just rebooted it.
The problem occurred :)


Any more ideas would be appreciated!



if you could get adb working again you can do this steps to get your launcher again:

su
mount -o remount,rw -t yaffs2 /dev/block/mtdblock4 /system
cp /system/app/Launcher.bak /system/app/Launcher.apk
cp /system/app/Launcher.obak /system/app/Launcher.odex
mount -o ro,remount -t yaffs2 /dev/block/mtdblock4 /system
sync
reboot

  • 0

#25
niotio910

niotio910

    Newbie

  • Members
  • Pip
  • 12 posts
  • Devices:Milestone

if you could get adb working again you can do this steps to get your launcher again:

su
 mount -o remount,rw -t yaffs2 /dev/block/mtdblock4 /system
 cp /system/app/Launcher.bak /system/app/Launcher.apk
 cp /system/app/Launcher.obak /system/app/Launcher.odex
 mount -o ro,remount -t yaffs2 /dev/block/mtdblock4 /system
 sync
 reboot


Hi

ADB doesn't see my phone :)
"adb devices" shows nothing

Please help!!!

  • 0

#26
bmic

bmic

    Newbie

  • Members
  • Pip
  • 9 posts

Hi

ADB doesn't see my phone :)
"adb devices" shows nothing

Please help!!!


First you will have to get a system.img of a phone just like yours, you may get it with this commands in ADB(in others phone, obviously):

'cat /dev/mtd/mtd6 > /sdcard/system.img'

Then you will need to get that system.img (in the other phone SD Card) and put it in a folder that have "fastboot" program(in your computer).

Put your phone into bootloader mode.

Execute this within fastboot folder in command line:

'fastboot flash system system.img'

'fastboot reboot'

the end :)

Edited by bmic, 19 January 2010 - 04:48 PM.

  • 0

#27
glossywhite

glossywhite

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,878 posts

1.Download the file there and rename iit to update.zip
2.Put it on to your sd-card
3.shutdown the phone
4.press the camera button and the power button and hold bothe pressed until the warn sigb appears /!\
5.when the sign is there press the camera button and the volume + trigger at the same time (maybe you will need sometime to try it because it has to be rly at the same time)
6.when you have pressed those the recovery menu will appear, just apply the update.zip there

Maybe the will be an error, dont worry its normal, to make sure that its rooted you can just apply the update again

This is not the 2.0.1 update, its just a root patch.


Would you care to explain what is meant by "trigger", please?.

Thanks.

  • 0

#28
niotio910

niotio910

    Newbie

  • Members
  • Pip
  • 12 posts
  • Devices:Milestone

First you will have to get a system.img of a phone just like yours, you may get it with this commands in ADB(in others phone, obviously):

'cat /dev/mtd/mtd6 > /sdcard/system.img'

Then you will need to get that system.img (in the other phone SD Card) and put it in a folder that have "fastboot" program(in your computer).

Put your phone into bootloader mode.

Execute this within fastboot folder in command line:

'fastboot flash system system.img'

'fastboot reboot'

the end :)


Hi,

I just have only 1 phone.
I downloaded the milestone system dump. Does it help any thing?

  • 0

#29
bmic

bmic

    Newbie

  • Members
  • Pip
  • 9 posts

Hi,

I just have only 1 phone.
I downloaded the milestone system dump. Does it help any thing?



Go to alldroid.org and ask a system.img from "poseidon" on the mtdblock thread on the milestone forum, he have one.

Edited by bmic, 19 January 2010 - 06:49 PM.

  • 0

#30
niotio910

niotio910

    Newbie

  • Members
  • Pip
  • 12 posts
  • Devices:Milestone

Go to alldroid.org and ask a system.img from "poseidon" on the mtdblock thread on the milestone forum, he have one.


Hi,

But I think fastboot doesn't see my phone either :)
I tried "fastboot devices" in recovery mode it shows nothing :)

  • 0

#31
Ricardo Fernandes

Ricardo Fernandes

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:milestone
  • Twitter:@ricpf
Brazilian Vivo Milestone rooted successfully!

  • 0

#32
glossywhite

glossywhite

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 1,878 posts
Just rooted my UK A853 Milestone - working a treat!.

  • 0

#33
rj7855

rj7855

    Newbie

  • Members
  • Pip
  • 32 posts
  • Devices:N1, soon eee pad transformer

Hi,

I just have only 1 phone.


When you were following the howto did you change the 4 in mount -o remount,rw -t yaffs2 /dev/block/mtdblock4 /system to the number that is valid for the milestone?

  • 0

#34
bmic

bmic

    Newbie

  • Members
  • Pip
  • 9 posts

Hi,

But I think fastboot doesn't see my phone either :)
I tried "fastboot devices" in recovery mode it shows nothing :)


You have to reboot into bootloader mode first.

  • 0

#35
MJ2332

MJ2332

    Newbie

  • Members
  • Pip
  • 9 posts
  • Devices:Motorola Milestone
  • Twitter:@mj2332
First 2.0.1 Update+Root on Androidiani.com
Enjoy.

  • 0

#36
staba

staba

    Newbie

  • Members
  • Pip
  • 13 posts
Thanks to the guys at Alldroid.org indeed.

For all the info read up on this thread: http://alldroid.org/...hp?f=259&t=1191

  • 0

#37
SeraphimSerapis

SeraphimSerapis

    Newbie

  • MoDaCo Silver
  • Pip
  • 45 posts
  • Gender:Male
  • Location:Germany
  • Devices:Motorola Milestone
  • Twitter:@SeraAndroid

Thanks to the guys at Alldroid.org indeed.

For all the info read up on this thread: http://alldroid.org/...hp?f=259&t=1191


Why Alldroid? We did it on Android-Hilfe.de not Alldroid :)

  • 0
Nexus One - with MCR!
Galaxy S - Sera's JIT-Galaxy V1

Buy me a Beer for Milestone-Root

#38
Tsuharesu

Tsuharesu

    Newbie

  • Members
  • Pip
  • 5 posts
  • Gender:Male
  • Devices:Galaxy S4
finallyyyy o/
im downloading...and expecting so much about this...
if the brazilians are getting root ^^... mine is a vivo milestone too....

im downloading on the droid..and illl change the name of the zip in it too...is there any problem?

hope no... :)

  • 0

#39
Monolithix

Monolithix

    Hardcore

  • MoDaCo Gold
  • PipPipPipPipPipPip
  • 8,783 posts
Bloody hell, getting to the boot menu is a bugger. Sorted now though, nice work guys!

  • 0

I still exist


#40
jutley

jutley

    Addict

  • Members
  • PipPipPipPipPip
  • 501 posts
  • Location:uk
  • Devices:Dell streak baby oh yea
Hi i just got my new uk simfree motorola milestone in uk today and i just did a ota update to v2.01 from v2.0 i want to root can someone guide me step by step and confirm it will work on my uk milestone that was updated ota from 2.0 to 2.01 thankyou in advance.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users